Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
CPU: AMD Ryzen 5 3600
Memory: G.SKILL Ripjaws V Series 16GB (2 x 8GB)
Disk: OSX: Crucial M500 SSD SATA Win10: Crucial MX500 500GB 3D NAND SATA M.2
GPU: PowerColor RED DRAGON Radeon RX 580
Mojave: 10.14.6

- WIFI/BT: No wireless hardware on mobo
- Network: RealtekRTL8111.kext
- Video: RX 580 - WhateverGreen.kext
- Audio: AppleALC.kext - Boot Arg: alcid=3
- Preview: worked OOB with latest kexts
- USB: USBInjectAll.kext - shows USB 3.1 in System Report, mobo says it's v3.2

I had a heck of a time getting the USB drive to boot at first. I was using a previous clover boot drive I had been using on Intel i3-8100 build. Updated clover, config.plist and kext, and it still wouldn't work. I wasted a few days playing with the old USB drive. I then followed the vanilla guide: https://vanilla.amd-osx.com with a new USB drive and it worked right out the gate. I should have just followed the excellent guide right off the bat. It would have saved me a ton of time.

Everything I use in OSX is running great! I have had no issues. Super stable. I mainly use my rig for devops / gaming. I dual boot into Win10 for gaming only. Main apps are web, terraform, vscode, Minecraft, Royal TSX, PowerShell, etc.

I'm not a creative, so I don't use the Adobe suite, nor do I use iMessage / FaceTime.

Everything I use on a daily basis works great!
Screen Shot 2019-09-13 at 9.13.32 AM.png
Screen Shot 2019-09-13 at 9.13.32 AM.png (144.51 KiB) Viewed 442 times
junepy, Egress, dragonx41 liked this


Just checked, and it looks like I have the same issue. I didn't notice it before since I dual boot into Windows 10 to game, but you are right. Something is off with the video graphics. You can't really notice using the GUI or iMovie, but if you try to game on it, OpenGL sucks. I tried just basic Minecraft Java, and FPS is 1/2 to 1/3 of what I get in Windows 10.

Cinebench r20 scores are approximatly the same in OSX and Windows 10, so it must be a graphics driver or something.

Geekbench 5 OpenCL score on Win10 is: 47440
Geekbench 5 OpenCL score on OSX is: 33580

The only thing I notice is the Max Freq reported on GeekBench is 300MHz for OSX and 1.35GHz on Windows 10. I don't know if that's the actual freq it's running on, or just a reported freq.

I don't know if it's an OSX Mojave issue, or Ryzen hackintosh issue. I'll try out the 580 on my intel hackintosh to see if I get the same issue.

Geekbench links:
Win10: https://browser.geekbench.com/v5/compute/85602
OSX: https://browser.geekbench.com/v5/comput ... er][b]Post Merged[/b]
[/center]Finally got a chance to test on my Intel box. It seems to be a ryzen-tosh OpenGL thing. I moved the AMD 580 to my Intel-hackintosh and it is running great with games [Minecraft Java].

Actually, the integrated, on-board Intel graphics perform better than the AMD 580 on the ryzen. Something is definitely wonky on the AMD Ryzen side.

If you are planning on gaming, I would dual boot into Win10 for now until a fix is out.

Geekbench scores:
Intel i3-8100 with the AMD 580:

Intel i3-8100 onboard graphics only:
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]