Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: skydiver71903
Hey guys,

I have been looking around and around for a fix before posting this. I have a stable build on my Gigabyte X470 Gaming 5 motherboard, running Ryzen 5 2600X. Audio works, iMessage works, iCloud works, Sleep/wake works, everything is running great. Except I only have my two USB 3 ports function and 1 USB 2.0 functions but only with a mouse or keyboard. Attached is my config file, I can't seem to find anything about it. I tried the AlGreys method and it didn't work for me. Any help would be amazing.

Thank you everyone for a noob like me.
Post Merged
Sorry for got to add that I am running Mojave 10.14.5.

Thank you again.
You do not have the required permissions to view the files attached to this post.


User avatar
by: arn0
Hey @skydiver71903 would you mind sharing the list of kexts and drivers you installed?

I have the same issue with usb2.
User avatar
by: amdpush
@arn0, Hey arn0. What working and what not working with your 3900x ? , and do you use it daily ? are you doing video editing ? and what guide have you followed? Thank you.
User avatar
by: arn0
@amdpush I just got it to work this week. I am going to make a post but have been hesitant since I've been playing around with it to get sleep working.
User avatar
by: kegman
Install hackintool and click bootloader tab, select the 4 usb port limit patches. Install. Make sure efi mounted. reboot
User avatar
by: skydiver71903
I got everything to work, sorry for the delayed response. But yeah I did what legman said. download Hackintool and do exactly what he said. works like a charm.
AMD FX & OpenCore support

Hi Guys and Gals, I'm trying to install Catalina O[…]

Thank you. This kext worked without problems.[…]

Try adding these boot args, shikigva=40 shiki-id[…]

Screen Shot 2020-01-29 at 7.51.53 PM.png Build[…]