Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: Glics
#50020
Title, so I installed Mojave around a week ago with the vanilla method. Specs are the ones listed in my signature except for the graphics card: when I installed it I had a gtx 660 in my system.
As well known the 660 had this bug where after a dozen of minutes the VRAM would fill up and everything on screen would become glitchy. It was still kind of usable and anyway I had my new RX 580 coming soon so couldn't really complain.
Now I have installed the RX 580 and I am not able to boot anymore, neither in the system nor in the installer. I have checked the ID of the card on Windows on GPU-Z and sure enough it's 67DF as it was supposed to be, so it should be supported by just using Lilu and WhateverGreen, but I have both kexts in my efi and I still can't boot.
I get stuck at around "HPET map device registers failed" and whatever line comes after that usually gets truncated as the pc just hangs.

Things i have tried:
Booting with -radvesa, booting with -radoff, booting with DeInit, reinstalling clover on a USB and starting from scratch with the Vanilla AMD Github config.plist + drivers and kexts suggested in the guide, deleting Name-DSDT in the config.plist, using 0x67DF1002 as (non)FakeID, using a different Clover version.

Attaching my EFI partition, any help is appreciated . Thanks in advance!
You do not have the required permissions to view the files attached to this post.
Last edited by Glics on Mon Jul 15, 2019 1:23 pm, edited 1 time in total.

 Advertising

User avatar
by: Shaneee
#50033
Try this. Replace config and kext folder.
You do not have the required permissions to view the files attached to this post.
Humble_Potaton liked this
User avatar
by: Glics
#50039
Thank you, I will try this as soon as I get home and let you know.
Quick question: I saw you added FakeSMC, so do I have (or is it suggested) to remove VirtualSMC?
User avatar
by: Shaneee
#50040
Yes replace VirtualSMC with FakeSMC. I also built Lilu and Whatevergreen from source to ensure it’s the latest version.
Glics, Egress liked this
User avatar
by: Glics
#50045
Tried it, deleted my kext folder and replaced it wit yours and also deleted virtualsmc.efi but I still get stuck around the line that says "[ PCI configuration begin ]".
Happens both while booting the installer and the system itself.
Not sure if this makes any difference but I forgot to mention that both the installer and the system are 10.14.5.

Attached pics are where it gets stuck (sometimes one line gets printed before the other, not sure if it's some kind of race condition but seems irrelevant to me)

EDIT: I also just tried using a Mac Pro 6,1 SMBios since it's supposed to work with an RX 580 (Especially the one which i have, the Sapphire Pulse 8GB, which has official Metal support), but no difference
You do not have the required permissions to view the files attached to this post.
User avatar
by: Egress
#50054
Try moving the video card to the PCIe slot furthest from the the CPU. You may need to boot a couple of times and wait. Worth a try. Also, try changing machine ID to 14,1.
Glics liked this
User avatar
by: Glics
#50057
Egress wrote:Try moving the video card to the PCIe slot furthest from the the CPU. You may need to boot a couple of times and wait. Worth a try. Also, try changing machine ID to 14,1.
I tried that but nothing changed. Actually I think that would give me worse performance anyway since on my motherboard the first slot is x16 while others are x4.
My SMBIOS was already 14,1 before and that's why I tried changing it to a Pro 6,1, but no difference.
I also just tried disabling/toggling various potentially-worth-checking stuff in the BIOS: HPET, SVM, the Serial and Parallel port and the IOMMU. Sadly none of these gave me any change.
Egress liked this
User avatar
by: Egress
#50100
Try these: 1) SATA ACHI support should be "on". 2) Locate Windows Secure Boot setting in Bios. It should be disabled.

Remember, when changing a setting, a reboot and/or extra boot time may be rquired, up to a few minutes the first time. If the system boots successfully, reboot times tend to be much shorter.
User avatar
by: Glics
#50104
I will double check the AHCI support as soon as I get home to be sure but since I have never used IDE in this PC i doubt it is off.
For the secure boot, I am certain it is off since it couldn't have been turned on prior to enabling CSM (MSI calls it "Windows 10 WHQL Support", but it's basicly CSM, which is needed for the rx580 to boot but wasn't even supported on my previous GPU, the 660).
Again, it worked before, the only changes are the new GPU and CSM being enabled now (without that my GPU doesn't even post, so if I ever reset the bios - which I also tried - I have to put my 660 back in just to enable CSM)
The only thing I can think of is to try is a previous image than 10.14.5.
I will also try to boot with -liludbgall and see if anything useful pops up

EDIT - as I thought sata mode was already set to AHCI and Secure boot was indeed disabled too. Still have to try with a pre-10.14.5 installer, come to think of it I should have an older Mojave installer at work, which I made for a real Mac with createinstallmedia. Will try to put Clover and the patches on that and see if it boots
Post Merged
Bumping since I have tried remaking the installer from scratch with both a recovery-only 10.14.4 and a full install 10.14.5 packages. Neither worked, I downloaded from scratch the following kexts and EFI drivers:
  • Lilu
  • WhateverGreen
  • FakeSMC
  • AppleALC
  • NullCPUPowerManagement
  • RealtekRTL8111
  • HFSPlus.efi
  • ApfsDriverLoader-64.efi
  • AptioMemoryFix-64.efi
This time I also tried from clover some DSDT fixes from the ACPI Patching menu, unfortunately nothing changed at all
Post Merged
Found the problem, I disabled this option in the BIOS and now everything works, still thank you everyone for the help!
You do not have the required permissions to view the files attached to this post.
SSD Very slow

AMD OS X is the registration forum to get the full[…]

看到中文好亲切, 我已经放弃使用Adobe了, 用老版本吧

@anielk , no, didn't. i realized problem is my 1[…]

Anyone found any fixes for this? still having stut[…]