Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#47802
Hi!

After a few months of trial & error I finally got my build to work!!! 8-)
What's working: Xcode, Docker, Apple services (iCloud / FaceTime / Messages / etc.).
The only things that aren't working yet are: my on-board wifi/blouetooth card & on-board sound card line-out jack (digital out works fine).

Many thanks to @XNLC for all the attempts to help me out with my stubborn Gigabyte motherboard & kernel panics I was having.

What finally worked for me was the vanilla Mojave guide (viewtopic.php?f=24&t=5902).
I've created the installer, but skipped adding the AMD kernel, then I've used the Clover kernel patches from https://github.com/AMD-OSX/AMD_Vanilla (with some additional patches provided by @AlGrey).

I'm attaching my final config.plist if anyone would need it.

Kudos to @Shaneee & @AlGrey for all that awesome work you did!
You do not have the required permissions to view the files attached to this post.
Last edited by suntrix on Sun May 05, 2019 7:13 pm, edited 1 time in total.

 Advertising

#47804
Hello.
I have a processor almost identical to yours.
I waiting for the shapire rx580pulse from amazon, since I am currently with strix1060 in windows 10.
Already have the usb waiting for the rx in my hand 8-) .
But I decided to go with the highsierra installer 10.13.6 since Shaneee explains that the modified kernel is only for 10.14.1.
I have seen that many installed 10.14.4.
What are the risks in 14.3 or 14.4 or 14.5 beta?
Your answer maybe gives me security to try it with mojave instead of highsierra.

Thanks bro
#47806
Hi @pali12345,

Yeah, @Shaneee's modified kernel in the guide is for 10.14.1, but I think it's worth to try to use the original (vanilla) kernel with Clover kernel patches (config.plist that I attached already have all of them added).
That was the only way that I could get it to work on my hardware.

I wouldn't recommend to use betas, because you won't be able to find any modified kernel for it (if you'd need one) and kernel patches might also not fully work.
If you're able to access a mac to download the macOS 10.14.4 installer then you'll have the latest stable version up & running :)
#47810
Thanks Suntirx,
Yes I can, my girlfriend has a macbook air.
Basically I am a 3D designer, I need stability and correct functioning of software, blender, vray, photshop, aftereffects, slack, skype etcetc.
Then, would you recommend me to try mojave instead of highsierra ?
Thanks!
#47872
@pali12345, Mojave seems to be running stable to me (I'm a software engineer myself :D )

@mrclan, I've tried running it on KVM under linux before, it was working but very slow. If you are able I think it's worth trying running it on bare hardware (at least then you have more control over any issues if you need to change your BIOS/UEFI settings). You should be even able to run it on a USB hard drive to not risk your other OS being messed up.
#50592
How did you get Docker / VM to work?
What entry was specific to that?

suntrix wrote: Sun May 05, 2019 12:26 pm Hi!

After a few months of trial & error I finally got my build to work!!! 8-)
What's working: Xcode, Docker, Apple services (iCloud / FaceTime / Messages / etc.).
The only things that aren't working yet are: my on-board wifi/blouetooth card & on-board sound card line-out jack (digital out works fine).

Many thanks to @XNLC for all the attempts to help me out with my stubborn Gigabyte motherboard & kernel panics I was having.

What finally worked for me was the vanilla Mojave guide (viewtopic.php?f=24&t=5902).
I've created the installer, but skipped adding the AMD kernel, then I've used the Clover kernel patches from https://github.com/AMD-OSX/AMD_Vanilla (with some additional patches provided by @AlGrey).

I'm attaching my final config.plist if anyone would need it.

Kudos to @Shaneee & @AlGrey for all that awesome work you did!
Egress liked this
#51096
I followed this tutorial -> viewtopic.php?f=24&t=3543&p=45524


cataclysm_99 wrote:How did you get Docker / VM to work?
What entry was specific to that?

suntrix wrote: Sun May 05, 2019 12:26 pm Hi!

After a few months of trial & error I finally got my build to work!!! 8-)
What's working: Xcode, Docker, Apple services (iCloud / FaceTime / Messages / etc.).
The only things that aren't working yet are: my on-board wifi/blouetooth card & on-board sound card line-out jack (digital out works fine).

Many thanks to @XNLC for all the attempts to help me out with my stubborn Gigabyte motherboard & kernel panics I was having.

What finally worked for me was the vanilla Mojave guide (viewtopic.php?f=24&t=5902).
I've created the installer, but skipped adding the AMD kernel, then I've used the Clover kernel patches from https://github.com/AMD-OSX/AMD_Vanilla (with some additional patches provided by @AlGrey).

I'm attaching my final config.plist if anyone would need it.

Kudos to @Shaneee & @AlGrey for all that awesome work you did!

@CaseySJ , I also using liquidctl for both Wind[…]

@CaseySJ , Fenvi FT-T919 would also be my 1st p[…]

Hi, I really wish this topic could get more light […]

Congrats and tell me about the installation, if us[…]