Welcome to AMD OS X

Why not register now to gain full access.

Tutorials for the installation and post install.
User avatar
by: Norton287
#28163
Download link:
Code: Select all
https://drive.google.com/file/d/17-RHrc3VDgg01fwcWhX154fDeIyRz804/view?usp=sharing
Once downloaded you want to disable SIP with Clover Configurator. Take a note of the original settings as you'll need them to reenable SIP after the installation. To disable SIP here's how:





Now that SIP is disabled you need to restart your system to enable it. Once you've restarted it's time to install the kexts to your system to enable Bluetooth support. Here's how:







Now reboot again to load the new kexts and you should have Bluetooth support on your system. Once you plug in your USB bluetooth dongle reboot.
vinhbaoabc, ProjectV8 liked this

 Advertising

User avatar
by: Apoken
#30361
Great tutorial. However I am not able to get this to work. - I can see that now, when I unplug the dongle, a line comes over the Bluetooth marker. However, changing the USB port makes no difference...

Any suggestions?

I have attached my config.
Attachments
(3.31 KiB) Downloaded 44 times
User avatar
by: Apoken
#30401
Norton287 wrote: Tue Oct 24, 2017 12:11 pm Try this config.plist, reboot with it and try installing them again.
Thanks! - However this did not do the trick.

I was not able to boot ''normally'' - I had to boot into safe mode and still nothing.

So I changed the config. again, and now all I back to normal.

I am getting a new dongle.
User avatar
by: buptlink
#32837
Apoken wrote:
Norton287 wrote: Tue Oct 24, 2017 12:11 pm Try this config.plist, reboot with it and try installing them again.
I tried the 4 kexts, and I can't boot two.My system is 10.12.6, cpu:1700 mb:ausu b350-plus

Thanks! - However this did not do the trick.

I was not able to boot ''normally'' - I had to boot into safe mode and still nothing.

So I changed the config. again, and now all I back to normal.

I am getting a new dongle.
Post Merged
When I use kext util to install the 4 kexts , I can't boot. I just crash with some bluetooth crash stack messages. OS:10.12.6
Post Merged
Now I got the reason and solution: turn off the "Serial Port" in motherboard bios settings everything goes fine!
User avatar
by: zzmadd
#35505
The dropbox link has expired
Post Merged
Now,
installed kernel, installed bluetooth fix
And I can now see the bluetooth preference pane, BUT no bluetooth appears to pair.
I think the fix is using the wrong bluetooth adapter.
It's not using the ASUS Broadcom but the Intel.
See attachment
How to tell it should use the other one?
Attachments
Screen Shot 2017-12-28 at 19.31.58.png
Screen Shot 2017-12-28 at 19.31.58.png (84.83 KiB) Viewed 1671 times
User avatar
by: bcchang
#37439
I install your 4 kexts. Bluetooth is working.
I have kanex keyboard and magic mouse 2.
BT keyboard is good working..
Magic mouse 2 pairing is successed. But, it don't work. pointer and click don't work.
I had test it with BT usb dongle and Apple native BCM wifi + BT express card.
But, it is same.
What is the probem?
I use GenericUSBXHCI.kext.
User avatar
by: dpernek
#38852
I have the same problem. Tried two usb dongles, ASUS BT 400 and some kind of LOGILINK, and apple magic keyboard works, but magic mouse 2 does not. It connect but doesn't work.
This is what I get when type command kextstat | grep touch

125 0 0xffffff7f81434000 0x24000 0x24000 com.apple.driver.AppleMultitouchDriver (264.6) 32DD13F2-22E6-3922-A68E-A07E1E1358A4 <52 5 4 3 1>
User avatar
by: AlGrey
#38855
@dpernek, your specs ?
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]