Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: Matthew Harrison
#54773
Hi all,

I'm having a bit of trouble trying to get my Mojave installer to boot. I've attached the image with my error.

System
CPU: Ryzen 3 3200G
Motherboard: ROG Strix B-350F
Ram: Corsair Vengeance 8GB 3000MHz (x2)

- Tried a few different configs but revert back to the vanilla master posted in the tutorial
- Tried setting my SMBIOS correctly for my RAM configuration
- Tried both RAM sticks in different spots
- Tried 1 RAM stick in all 4 different locations
- Tried changing between different osxaptiofixdrv

There's probably more I've tried but I'm starting to loose it and need a bit of help to figure this one out.
Attachments
image.jpeg
image.jpeg (133.85 KiB) Viewed 154 times

 Advertising

User avatar
by: Shaneee
#54774
OpenCore or Clover? Also did you include the AMD patches in your config?
User avatar
by: Matthew Harrison
#54775
Sorry, wasn't clear about the boot loader. I am using clover boot loader, latest version. I've copied the patches to the config via Xcode.
Post Merged
We are referring to the patches in the vanilla master from github, correct?
User avatar
by: Shaneee
#54776
What version of Mojave? Clover patches only support Mojave 10.14.6 (18G84, 18G87, 18G95, 18G103)
User avatar
by: Shaneee
#54778
That's why then. Again Clover patches only support 10.14.6. Follow the vanilla guide and give Catalina a go depending on your GPU of course and use OpenCore. https://vanilla.amd-osx.com/
Matthew Harrison liked this
User avatar
by: Matthew Harrison
#54779
Shaneee wrote:That's why then. Again Clover patches only support 10.14.6. Follow the vanilla guide and give Catalina a go depending on your GPU of course and use OpenCore. https://vanilla.amd-osx.com/
Wow, just looked at the guide & now see that. Would it be possible to install using OpenCore? Not as familiar with that, but would give it a go before downloading Catalina.

If not I'll likely just give Catalina a go.
Post Merged
Only asking because I noticed the version under OpenCore is 10.14.*
User avatar
by: Shaneee
#54790
OpenCore supports all version of 10.13, 10.14 and 10.15
Matthew Harrison liked this
User avatar
by: Matthew Harrison
#54796
Shaneee wrote:OpenCore supports all version of 10.13, 10.14 and 10.15
Ok, thanks for your help, will post results!
Post Merged
Shaneee wrote: Mon Feb 17, 2020 2:03 pm OpenCore supports all version of 10.13, 10.14 and 10.15
Ok, so I managed to get OpenCore to start the boot into the installer, but before I even get to the installer I get basically the same error I got in the first picture.

"
Start LoadRAMDisk
EndLoadRAMDisk
Start FinalizeBootStruct
Start RandomSeed
End RandomSeed
"

Any thoughts?
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]