Welcome to AMD OS X

Why not register now to gain full access.

#54539
I've got a very similar x570 Taichi & 3950x setup to @Fuzzhouse [viewtopic.php?f=35&t=9916&hilit=taichi], @iamso78 [viewtopic.php?f=35&t=9636&p=53268&hilit=taichi#p53268]and @CaseySJ and can't seem to get the OC bootloader/installer running. I'm pretty tech savy, but new to hackintoshes (I used Linux for years and am comfy editing XML). I have even tried to use Fuzzhouse's EFI folder directly and compared his config.plist to mine line by line (there are differences). I've been pouring over the Opencore vanilla guide and a bunch forums and videos, and yes, I've read and looked over https://github.com/acidanthera/OpenCore ... ration.pdf too.

First, here's more abut my config:

CPU: AMD Ryzen 5 3950x
Motherboard: Asrock Taichi X570 [Updated BIOS v 2.70]
RAM: g-Skill Trident Z Neo 64GB [F4]-3600C16Q-64GTZNC]
HDD: Samsung EVO 1TB NVME [x2- mirror drive for once I get OS X installed]
GPU: Gigabyte Radeion Vega64 Gaming OC Edition [Updated to latest BIOS]
WiFi/BT: Fenvi FV-T919
OS: Win 10 Pro x64 (hopefully not for long)
USB Drive: ADATA 64GB UV128 USB 3.2 Gen 1 Flash Drive (AUV128-64G-RBY)

Hackintosh Installation Stuff:
  • gibMacOS [Catalina 10.15.3 FULL install]
  • SSDTTime]
  • opencore 0.5.5 RELEASE]
  • ProperTree [for OC loader]]
KEXTs
I would post the list, but my error shouldn't have ANYTHING to do with KEXTs. I doubt it's a driver issue (but maybe), and am less confident about ACPI issues but still doubt it...

Cliff notes:
After I got the system HW put together I threw Windows 10 Pro x64 on it to test everything out, get some benchmarks, update firmware and generally make sure everything is working- everything seems good and it running fast, though my multi-core Geekbench score is about 15% slower than I expect. Once I was up and running I created my USB installer following the opencore guide without much issue. Grabbed EFIs (special thanks to Fuzzhouse for a few that I didn't have on hand), used SSDTTime for the ACPI directory, setup config.plist from sample using ProperTree's "OC Snapshot" function and patched it for 17H Ryzen processor. All looked good and I dared a smile for how easy it was...

I rebooted and changed my BIOS settings, saved and exited (more on those changes below). A few blinks the the LEDs (the rainbow unicorn vomit variety from my RAM) and I relished at the progress as I pressed F11 to select my impressive USB install drive. Then I made my selection for "USB partition 1" when, uh, that doesn't look right...

ERROR:
After POST press F11 to enable boot device selection the OC boot menu includes 2 entries:

"OpenCore Boot Menu (REL-055-2020-02-03)"

"*1: Reset NVRAM"

"Choose boot entry:"

If I don't do anything option 1 runs after a few seconds and reboots the machine. If I select option '1' the machine reboots- in other words all I can do it reboot. So, how did I get there? Just to make sure I didn't miss anything stupid I scrapped the whole USB and started again.

DETAILED BACKGROUND
Let's start from the very beginning... it's a very good place to start... (sound of music reference, anyone?)

Right click on gitMacOS.bat and run as admin. When the menu comes up I hit "r" to show the full installation options. Then "5" for Catalina 10.15.3 Full Install. Tick, tick, tick about a minute goes by and my download is complete.

Double click MakeInstall.py as non-admin (since you can't right-click a py script and run as admin). When the menu came up I typed "2O" (my drive was #2, and typed capital o, not 0/zero for OpenCore only [no clover here]). MakeInstall.py shot me the following:

"Using MBR..."

"DiskPart exited with non-zero status (1). Aborting."

"Press [enter] to return..."

So I reran MakeInstall.py via cmd.exe as administrator and that fixed error. When prompted I pointed MakeInstall.py to the downloaded OS X file as required. No problems reported. BUT, and this might be a big deal, it only took about 1:20 seconds to finish instead of the quoted 15-20 from other users. I know my system is fast (I have fast internet service too), but HOLY S*%T if that's real...

***Note: I suspect that there may be a problem at this step since my OC boot menu doesn't seem to work... Let me know if I missed something from the above.***

After MakeInstall.py ran I cracked open my EFI directory on the USB and took care of the steps as described in the guide.
  • Removed Legacy Drivers]
  • Added Required Drivers]
  • Revoved Tools (no replacements, just an empty directory)]
  • Copied over my kexts from a scratch directory (partial thanks again to Fuzzhouse for the verification from his uploaded EFI)]
Then I ran SSDTTime as regular (non-admin) by doubleclicking, but got an error in the output from Dump DSDT stating "...can't create directory to relocate files" or something like that. To fix one I cracked open cmd.exe as admin again and ran SSDTTime.py directly. Reran the following options from the menu:
  • 4 -> Dump DSDT - created the "Results" folder with files in it]
  • 2 -> FakeEC - I assume it modified files in the above folder, but I didn't do a diff
Feeling good about my progress I copied the Sample FULL plist (I have also used the regular 'sample.plist' in previous attempts) from the opencore/docs directory over to my USB OC directory and renamed it config.plist. I opened the config.plist in ProperTree and ran OC Snapshot from the menu as described in the guide. Once that ran (successfully as I saw changes and didn't get an error) I deleted/removed the sample "kernel -> patch" section and pasted in the kernel -> patch section from the 17H patch. Saved the config.plist file and bang, ready to rock...

I restarted the machine and reset the BIOS to default (I'd been playing around in past attempts). After restarting I hit F11 after POST to select USB drive. Opencore started up and spit out the following:

"OC: Configruation requires vault but no vault provided!"

After a bunch of reading and hunting I edited the config.plist for the followng entries from their default values:
  • Misc -> Security -> RequireVault: "False" from True [doesn't fix it alone]]
  • Misc -> Security -> RequireSignature: "False" from True]
  • Misc -> Security -> AllowNvramReset: "True" from False]
  • Misc -> Security -> AllowSetDefault: "True" from False
I also tried a few BIOS Changes:
  • Boot -> Fast Boot: "Disabled"]
  • Boot -> Above 4G Decoding: "Disabled"
I got the same result as above, so one last time I reset my BIOS to defaults with no luck. Given all the above, can anyone tell me why opencore 0.5.5 is giving me the following :oops: ?

"OpenCore Boot Menu (REL-055-2020-02-03)"

"*1: Reset NVRAM"

"Choose boot entry:"
Post Merged
From the information that @tinyj included in his recent successful ASRock build (link below) I was able to get the OC bootload up and running. I've got a few more issues to nail down before I've got my installation complete, but anyone with an ASRock board should pay attention the information in that post...

viewtopic.php?f=35&t=10078&p=54548&sid= ... er][b]Post Merged[/b]
[/center]Long back story, but I bought at Vega64 for my build (as originally stated) and got a Vega56 with a Vega64-BIOS flash (i.e. I didn't get what I ordered). So I returned the GPU and figured I'd pick up a Powercolor Red Dragon 5700XT instead (no more messin around with used stuff for this guy)... Well long story short I put the 5700XT in and everything started fine but after the usual boot messages I just got a black screen.

I found some people saying that the display port (DP) dosn't always work so well and tried HDMI with no luck. After hours of searching I found that if I delete WEG (Whatevergreen) and add "agdpmod=pikera" to NVRAM -> Add -> boot-args I can get it to at least load. Cool right- so I crank up vi from the terminal in the installation so I can modify my NVME EFI folder by changing the config.plist to remove WEG and add the boot arg. I'm not a huge fan of vi and editing the config.plist xml directly in an editor I haven't used regularly in 20 years isn't exactly a recipe for a stress free Saturday (and yes, I could have just copied the config.plist from the USB, but I could have just bought a Mac too).

Anyhow, after the modifications I rebooted and managed to log in for about 3 seconds when I got a pretty nasty hard reset after some bad flickering and noise on my monitor. I see a lot of folks running the 5700XT on X570 mobos... but for the life of me I can't seem to get a simple GPU swap running.

I don't like losing DP and WEG (Whatevergreen)- it just feels like a massive step back. I even tried rebuilding the installation package/USB but the issue seems pretty fundamental to the 5700XT.

Anyone have suggestions?
Post Merged
Update: Good news first- it looks like I've got my install back with the above fixes for the 5700XT (they work- but keep reading). I got an updated message about my memory configuration having issues. This is the same message I got before I used the MacProMemoryNotificationDisabler.kext (with config.plist addition too for the noobs).

But (bad news) after the above changes I can't see anything about my Mac!

After posting the previous update I rebooted on a hunch that maybe the system just needed a second to adjust... when I rebooted I dismissed the memory error message and just used th system for a while- all seemed good. Then I hit the apple in the top left and selected "About this Mac" and KABOOM! Hard reset without even a blue screen.
Post Merged
I figured out the error. I’m using MacProMemoryNotificationDisabler because I like pain and picked MacPro7,1 as my SMBIOS and that Kext fixes an alert where the MacPro has 6 banks of RAM but my X570Verify only has 4. Long story short that Kext requires WEG, so when I took that out to use my 5700XT, well I have to deal with the alert (or change my SMBIOS).

 Advertising

AMD OSX with Dual boot?

So I had a ryzen system and installed catalina on […]

Can you share EFI with me? Thank you! Emial:foreve[…]

Use the tool to download 10.15.3 instead of 10.15.[…]

@fabiosun or @Shanne is this the correct guide for[…]