Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: crokman
Hi Guys and Gals,
I'm trying to install Catalina OSX 10.15.2 on my pc.
The machine is composed:
MB - ASUS ROG Crosshair V Formula Z
CPU - AMD FX 9370 Unleashed
RAM - 4x8GB DDR3 Corsair Dominator
GPU - 2x R9 270 (not the "X" version)
HDD - 240GB SSD Crucial BX500 (for OS. previous install of MacOS High Sierra)
- 240GB SSD Kingston SA400S (Windows10)
- 500GB HDD Samsung HD502 (storage drive)
- 2TB HDD Seagate ST2000DM001

I tried with clover bootloader with no results (and I read a lot of posts telling that is no more supporting Catalina). Now I would like to try with OC.
I have a panic message quite immediately after boot.

Is there someone can help me compiling a working EFI folder?

Thank you for your time guys and gals.

In the attachment you can find my actual EFI folder
IMG_20200123_102642_1.jpg (3.18 MiB) Viewed 879 times
(1.74 MiB) Downloaded 54 times
dzonix liked this


User avatar
by: Shaneee
In your Config under Kernel > Quirks set PanicNoKextDump to YES. This will remove the kext info so we can see whats causing the panic. Reboot with that enabled and post a picture of the panic.
User avatar
by: crokman
Shaneee wrote:In your Config under Kernel > Quirks set PanicNoKextDump to YES. This will remove the kext info so we can see whats causing the panic. Reboot with that enabled and post a picture of the panic.
Hi Shaneee, here we have the panic pic.

Any idea for the reason why it happened?
IMG_20200130_120823.jpg (3.09 MiB) Viewed 866 times
User avatar
by: Shaneee
Hm that's a hard one to pin point. You've got the FX patches right and you've not mistaken them for the 17h Zen patches? Also do you have NullCPUPowerManagment?
User avatar
by: crokman
Right, I used the bulldozer series Patch (15th).
And I have NullCPUPowerManagement in OC/Kexts/..
My OC is:
  • dsdt.aml
cleaned. 0 errors, 0 warnings, 0 remarks and 0 optimizations.
  • SSDT-RTC-FIX.aml
I tried this one just to try booting OC (I found it on TonyMacX86 but it seems not working)

  • ApfsDriverLoader.efi
  • FwRuntimeServices.efi
  • VBoxHfs.efi
  • VirtualSMC.efi
  • AppleALC.kext
  • AppleIntelE1000e.kext
(my lan chipset was here in mojave and high sierra)
  • Lilu.kext
  • NullCPUPowerManagement.kext
  • VirtualSMC.kext
  • Whatevergreen.kext
  • CoreOffset
  • libaistat
  • rtcread
  • smc-fuzzer
  • smcread
Maybe I forgot something or there's something more than necessary...
I'm blowing up! :lol:

Here's my config.plist if can be useful
(4.1 KiB) Downloaded 28 times
User avatar
by: Shaneee
Ok that EFI you shared in the first post was a bit of a mess tbh. I've cleaned it up and added the patch for AppleIntelCPU to remove NullCPU. Replace your whole EFI folder with this one.
(1.1 MiB) Downloaded 89 times
User avatar
by: crokman
thank you but I'm still stuck in the same place!
Any idea?
IMG_20200131_093738.jpg (3.52 MiB) Viewed 831 times
User avatar
by: Shaneee
Try with this,
(740.82 KiB) Downloaded 66 times
User avatar
by: crokman
@Shaneee, this time stopped a bit early than normal.. no panic but it stopped during pci configuration i think
IMG_20200131_115435.jpg (3.66 MiB) Viewed 828 times
User avatar
by: Shaneee
Does your motherboard have an option for Above 4G Encoding? If so make sure it's disabled. You can also try changing npci=0x2000 to npci=0x3000 in the boot args.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]