Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#53851
CPU: AMD Ryzen 5 3950x
Motherboard: Asrock Taichi X570
RAM: Corsair Vengeance LPX 128GB 2666MHz DDR4
HDD: Sabrent 1TB NVME 4.0
USB : 3.2
GPU: NITRO+ RX 5700 XT
LAN: Smalltree kext
Bootloader: OC 0.5.4
OS: 10.5.2 + Arch Linux

4k+ Video editing and After Effects Machine! We needed to replace a rented maxed out iMacPro1,1 at work so i convinced my boss to buy this beast. I have an Intel Clover build I've been running for about 5 years now. I use for running Pro Tools. I admin 6 macs at our company and my Hackintosh has been just as reliable as the real ones. Hoping this machine can match that.

Things to do still:
Getting no schema errors in OC
Rename processor
USB ports are reporting 480Mbs -- not sure if that how they are performing. They're all present at least
Install 10Gbe
Getting: Setting NVRAM 7C436110-AB2A-4BBB-A880-FE41995C9F82:nvda_drv - Not Found
Attachments
.png
.png (123.32 KiB) Viewed 627 times
Screen Shot 2020-01-19 at 11.15.55 AM.png
Screen Shot 2020-01-19 at 11.15.55 AM.png (55.3 KiB) Viewed 627 times
Screen Shot 2020-01-19 at 11.21.19 AM.png
Screen Shot 2020-01-19 at 11.21.19 AM.png (19.32 KiB) Viewed 627 times
amdpush liked this

 Advertising

#53852
Thanks for your post! I'm looking into replacing a maxed out 5,1 Mac Pro that's starting to have some hardware (logic board) related issues and was going to use the same board and processor you've specified here. It will be used for high end audio production in conjunction with an Antelope Discrete 8 interface in USB mode since the Ryzen/Thunderbolt thing hasn't been sorted out yet.

You mentioned having done this with a Pro Tools system so my question to you would be, do you think this configuration will be stable enough for everyday work? I'll be running Mojave since there are still a few apps that aren't compatible with Catalina.

Thx!
fuzzhouse liked this
#53860
U can fix the USB port following the guide here https://github.com/khronokernel/Opencor ... USB-map.md
Moreover, u can fix it 2 ways 1) Kext 2) DSDT, link to Asrock x570 Taichi is here https://drive.google.com/open?id=1mR_4M ... gBeleLpBCH

Your synthetic score is low, with PBO enabled in BIOS (it can reach 4.05Ghz on all cores) , I am able to hit >15K score in Geekbench 5 and 10K for r20 on x62 280mm AIO cooling.

TB3 works fine with Asrock x570 Taichi, been using it since day 1, suggest you read all the comments (alot of ppl's time & effort was put in, and information is accurate) in this thread https://amd-osx.com/forum/viewtopic.php ... 0a6221c430
fuzzhouse liked this
#53884
Kylyx wrote: Sun Jan 19, 2020 9:21 pm Thanks for your post! I'm looking into replacing a maxed out 5,1 Mac Pro that's starting to have some hardware (logic board) related issues and was going to use the same board and processor you've specified here. It will be used for high end audio production in conjunction with an Antelope Discrete 8 interface in USB mode since the Ryzen/Thunderbolt thing hasn't been sorted out yet.

You mentioned having done this with a Pro Tools system so my question to you would be, do you think this configuration will be stable enough for everyday work? I'll be running Mojave since there are still a few apps that aren't compatible with Catalina.

Thx!

I'm pretty hopeful that it will be. My Intel hackintosh is on Mojave and runs great. Don't really have any problems.
Post Merged
iamso78 wrote: Mon Jan 20, 2020 2:48 am U can fix the USB port following the guide here https://github.com/khronokernel/Opencor ... USB-map.md
Moreover, u can fix it 2 ways 1) Kext 2) DSDT, link to Asrock x570 Taichi is here https://drive.google.com/open?id=1mR_4M ... gBeleLpBCH

Your synthetic score is low, with PBO enabled in BIOS (it can reach 4.05Ghz on all cores) , I am able to hit >15K score in Geekbench 5 and 10K for r20 on x62 280mm AIO cooling.

TB3 works fine with Asrock x570 Taichi, been using it since day 1, suggest you read all the comments (alot of ppl's time & effort was put in, and information is accurate) in this thread https://amd-osx.com/forum/viewtopic.php ... 0a6221c430
Thank you! I'm going to get on it.
#53891
There's a "ryzenshine" thread on hear that made me want to avoid the onboard TB3 as it seemed hard to get it working properly. I have an old intel hackintosh with a Gigabyte TB2 card and it worked out of the box with no hassle. That said I'm currently struggling with the Gigabyte TB3 card in this board. So we'll see how it goes. I'm getting a black screen when i enable TB in the bios. I have a 5700XT and i think i may be running out of lanes, but I'm not sure. -- I'm in over my head.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]