Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#52856
@CaseySJ,

Do you have problems with Nvme SSD not recognise problem with Taichi?
Since my NZXT H510 doesnt have a restart button, if I had a kernel panic and long press shutdown and restart, 1 of my SSD disappeared as well under BIOS.
I also waiting for my BCM94352Z to arrive b4 I get a new board to replace the current one.

Sabrent 1TB 4.0 is pretty good value vs my current ADATA 8200PRO, initially I wasn't sure if 4.0 was supported in MacOS, but recently I found a reddit post confirming it works.
https://www.reddit.com/r/hackintosh/com ... zen_hacks/

 Advertising

#52857
@iamso78,

My 1TB NVMe SSD works perfectly every time -- cold boot or warm boot. I've created a simple SSDT that makes it appear as an Internal drive in macOS.

I also have an NZXT H510 (Elite). Because it lacks a reset button as you noted, I use one of these Silverstone remotes for US$24:
https://www.amazon.com/SilverStone-Tech ... 273&sr=8-1

Instead of a BCM94352Z, I opted for the Fenvi FV-T919 which is natively supported in macOS. To avoid conflicts with the built-in WiFi/BT (Intel AX200), I created an SSDT to disable the USB port on which internal Bluetooth is connected.

This allows me to use the built-in Intel card (WiFi 6 and Bluetooth 5) in Windows, but the Broadcom 94360CD (on Fenvi) in macOS.

Attached ZIP contains the SSDTs (two main SSDTs and a helper SSDT). Depending on the M.2 slot, the SSDT named SSDT-ASROCK-X570-NVME.aml may need to be modified.
Attachments
(1.95 KiB) Downloaded 61 times
#52861
@CaseySJ,

Fenvi FT-T919 would also be my 1st preferences, works natively on my friend's build. Funny you mention built-in WIFI/BT module, my friend bought Aorus Elite WIFI version and to our surprise, there is no option in BIOS to disable/enable WIFI/BT, lucky removing it was pretty straight forward after removing the I/O shield.

I went for BCM94352Z b/c there no physical space left for me to install Fenvi FV-T919 (i used up all 6 slots, 1080Ti 3 slot, 5700XT 2 slot, and TB3 AIC 1slot). Therefore I plan to switch out the WIFI/BT M.2 module on the Taichi.

I fixed the comestic Internal drive by injecting device property as built-in under DeviceProperties in Opencore plist.
Post Merged
@CaseySJ,

I just tested with Gigabyte Titan Ridge v1.0 card, not sure what firmware is on the card since there is a firmware update via Gigabyte website.
LG 5K display works, hotplug sort of work (Audio/Camera/USB C wont get detect, just display).

Shutdown and then restart requires hotplug to get the LG 5K display to work, or you have to boot into Windows 1st make sure LG 5k display is working and then reboot into MacOS, with Alpine Ridge V2.0 it works straighaway even after shutdown and restart.

Still requires 2 displayport plug in to TB3 AIC to make LG 5K display work, eventhough 5700XT has Displayport 1.4 and Titan Ridge has 1.4 vs 1.3 on Alpine Ridge.

Hope the finding is useful for x570 Creator owners.

BTW I think new X570 chipset driver update (new November update) specifically GPIO driver made my Alpine Ridge v2.0 go into safe mode firmware. I now got a warning saying cannot connect until new firmware is installed, hence I swap out for a Titan Ridge v1.0
Post Merged
Update
ok flash firmware to NVM version 43.00 from 23. Audio/Camera/USB C doesnt work on LG 5k Display anymore. I think the issues is 15 USB limit.
CaseySJ liked this
#52918
Hi CaseySJ,

Good to see you here. I was wondering if you've tried activating TB3 on Windows before trying to use it on MacOS?

I'm waiting on parts (I too ordered an ASRock X570 Creator based on internal TB3), so I've not yet tried anything, but coming from a successful startup of TB3 on an ASRock Z390 ITX mobo (rj510), it required WIndows activation, along with an SSDT that I'd derived from one of your early Designare files, to work on MacOS. So possibly this mobo will also first require Windows activation of TB3.

I should have all parts by this weekend, so hopefully I can begin working on it soon. I'd really like to getTB3 working, as it was one of the attractive features of this build, along with the 3950X CPU. I've prepped both Clover and OpenCore EFI folders.
#52927
Hello @iGPU,

You may not like my answer, but here goes! :)

I installed Windows on the ASRock X570 Creator and it was able to make full use of on-board Thunderbolt, including hot-plug and eGPU. However, eGPU on Windows is fairly wishy-washy. But in all others respects, Windows had no trouble on this board.

I also downloaded and installed a newer Intel Thunderbolt driver (newer than the version on ASRock website) hoping that it would help to activate the card in macOS if I did a warm boot from Windows back to macOS.

But alas, nothing -- absolutely nothing -- would even activate the on-board Thunderbolt port for use with actual Thunderbolt devices. DisplayPort monitors and USB-C devices do not count. But every Thunderbolt device (eGPU, docking station, Apple Thunderbolt to Ethernet adapter) that worked on this motherboard under Windows would simply NEVER work under macOS. I tried CSM Support on/off, I tried different Thunderbolt Security settings in BIOS, I tried to change even unrelated BIOS parameters, but nothing worked.

So ultimately I disassembled the system and replaced it with the ASRock X570 Taichi and ASRock Thunderbolt 3 AIC Rev 2. Hot-plug still does not work, but Thunderbolt devices do actually work when connected prior to boot.

I also attempted to replace the ASRock Thunderbolt AIC with Gigabyte's GC-Titan Ridge. But the behavior was the same. Thunderbolt devices do work when connected prior to boot, but there's no hot-plug capability.
Post Merged
@iamso78,

MacOS uses "dual-link SST" (Single Stream Transport) to send two DisplayPort 1.2 signals simultaneously to the LG UltraFine 5K. One of the DisplayPort streams paints the left half of the monitor; the other paints the right half. This is necessary in order to deliver a High Bit Rate signal to the monitor. Apparently, DisplayPort 1.4 is not capable of delivering that much information to a 5K display at 60Hz, so the only solution is to send two DP 1.2 streams.
#52936
@CaseySJ,

Cold startup, no display showing on LG 5k display, I need to unplug & plug, I havent check if it still work if unplug B4 startup.

Been playing around with trying to get the built in Camera/Audio/USB C on LG 5 K display to work, no success thus far.
I contacting Gigabyte to see if they could provide NVM 23 firmware for download and flash back to see if it works again.
Post Merged
Update
Dont update to NVM 43 firmware, manage to get another Titan Ridge stock NVM 23 firmware, bult in Audio/Camera/USB C all working. I was also experience display flickering both in MacOS/windows on the latest NVM 43 firmware.
CaseySJ liked this
#52968
@CaseySJ,

Let's hope we can eventually get the TB3 ports working. To me, the X570 Creator is just about the ideal Hackintosh mobo at this point in time:

1) BT module can be replaced, freeing up a PCIe slot
2) 10G AQUANTIA ethernet port (AQC107 natively supported by Apple since High Sierra); this too frees up a PCIe slot
3) It has 2 TB3 ports that further free up PCIe slots
4) The free PCIe slots can easily allow 2 GPU, while still providing space for a Firewire or SATA PCIe board

Anyhow, a really nice mobo design, if we can get TB3 to work.

One more avenue to pursue is to look at what ASRock has not turned on or off in the TB3 section in BIOS. There are tools to look at these sections and I'll start poking around the BIOS this weekend. If a setting can be changed, then perhaps the TB3 ports will begin working.

Meanwhile, that got me to do a first round mini-mods of the BIOS to get what I think is a nice splash screen (shown below). I've done this mod before for the ASRock Z390 ITX and an ASUS PD1 X299 build (Gigabyte BIOS is not so easily modified). Attached are modded BIOS for X570 Creator (latest + a beta version) and X570 Taichi.

I flashed the BIOS (beta version) without issue, following the guidelines in the Creator manual. Flashing does not require presence of a CPU or to have the mobo powered. Only PS needs to be on and connected to mobo.

The ROM files are too large to load here, so below are Google Drive links (updated 2/29/20; better image size):
Attachments
New splash image
New splash image
test.jpg (200.69 KiB) Viewed 484 times
Original splash image
Original splash image
original.jpg (11.91 KiB) Viewed 484 times
Last edited by iGPU on Sun Mar 01, 2020 4:17 pm, edited 4 times in total.
CaseySJ liked this
#52985
@iGPU,

The new splash screen looks great! Was it easy to patch the BIOS?

I've already used IFRExtract to disassemble the "setup" section of ASRock firmware. Alas I didn't find GPIO3 Force Power or other pertinent settings. That's when I sent a message to ASRock Tech Support, who replied that GPIO3 Force Power is turned on by default. I didn't ask why Thunderbolt on the X570 Creator doesn't work with macOS -- that question would probably have been out-of-scope of their technicians.
#53038
@CaseySJ,

I'm currently running a maxed out 2010 Mac Pro in my recording studio and am starting to see some hardware issues with the USB ports so I'm looking for a good way forward.

Do you think the Taichi/Creator w/Titan Ridge AIC combo would be solid enough for a TB device that doesn't require any hotplug capabilities? I'd be using a TB2 Apogee audio interface with Apple TB3 to TB2 adapter.

The info on the whole Thunderbolt/Ryzen thing is pretty sparse right now so I thought I'd get your opinion! Thx!
#53046
@CaseySJ,

Modifying the BIOS was not too difficult. (Some BIOS cannot be easily modified, Gigabyte is kinda difficult.)

I followed directions set up by KGP. Here is a summary:

A. Overview:
1) Install BREW
2) use UEFITool to modify copy of your BIOS.

B. Install BREW
1) bash
2) /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homeb ... er/install)"
3) brew install qt5
4) brew link qt5 --force

C. To make UEFITool:
1) git clone https://github.com/LongSoft/UEFITool
2) cd /UEFITool/ (or drop folder from users/rj/UEFITool) into Terminal
3) qmake uefitool.pro
4) make

D. Change BIOS Splash Image
1) Run UEFITool
2) Select "File" —> "Open image file" and load BIOS
3) Select “Edit” —> “Search”
4) Enter: "GUID" search, “Header Only” for "7BB28B99-61BB-11D5-9A5D-0090273FC14D"
5) Double click on that message and search for the first “Raw section"
6) Next, verify this is the correct image by:
a) highlight (click) on this raw section
b) right-click and select “Extract body…”
c) once downloaded, change extension of this file from “*.raw” to “*.jpg” and open in Preview
7) Next, change name of desired splash image from “*.jpg” to “*.raw” and follow reverse of above:
a) right-click on raw section but now select “Replace body…”
b) select your chosen splash image jpg file
8) Select “File” —> “Save Image File…”, naming it as original with an addition such as “*_mod”
9) Optionally, re-extract this image to verify all was properly saved.
10) Re-name BIOS file per manual to allow flashing of this modified file.
CaseySJ liked this
  • 1
  • 2
  • 3
  • 4
  • 5
  • 31
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]