Welcome to AMD OS X

Why not register now to gain full access.

Tutorials for the installation and post install.
User avatar
by: artouiros
#50597
So this will not work with 15-16 patches on older CPUs? I did try AppleALC but got stuck at boot :
Code: Select all
kextd stall IOHDACodecFunction

 Advertising

User avatar
by: lucaspdude
#50992
Not sure if you guys could help me but, i have and External USB Audio interface, Behringer U-PHORIA UMC22, that is crackling a lot.

I looked everywhere, but no one was able to solve this problem.
User avatar
by: morgenshtern
#51286
Dear @AlGrey!
Will you help me with my sound problem?
Chip is ALC892. I've spend three days getting audio to work with no results. On Windows audio works well.
Log and config in attachment.
Thanks!
(672.69 KiB) Downloaded 34 times
(3.93 KiB) Downloaded 44 times
User avatar
by: jubarim
#52014
I managed to make my Gigabyte B450 Aorus M audio work - it has the ALC892 as well.

I used the layout 1. I have not tested much, it seems like some times the audio fails, but it is ok. Here are my boot flags:
Screen Shot 2019-10-28 at 17.59.14.png
Screen Shot 2019-10-28 at 17.59.14.png (168.76 KiB) Viewed 670 times
User avatar
by: CKarra
#52064
Codec: Realtek ALC892
macOS: Catalina, v10.15
SMBIOS: iMac Pro (2017)

After many hours of repeated failure, I now have working audio. Here are the steps I followed.

  • Enable System Preferences > Sound > "Show volume in menu bar" in macOS.
  • Modify config.plist using Clover Configurator:
    • Acpi > Patches: Disable patch "Change HDAS to HDEF" for now, if you added it earlier
    • Acpi > Fixes: Untick FixHDA
    • Devices > Audio: Leave Inject blank and untick ResetHDA (you can enable this later if you have problems after a cold boot)
    • Devices > Properties: Remove the Layout_ID line item (only if you added one manually)
    • Save your changes
  • Remove all audio kexts from (AppleALC, AppleHDA, Lilu, VoodooHDA, etc.) your EFI folder.
  • Download and extract Lilu.kext (v1.3.8) and AppleALC.kext (1.4.2).
  • Copy Lilu.kext and AppleALC.kext to EFI > CLOVER > kexts > Other.
  • Modify config.plist using Clover Configurator:
    • Save your changes and Restart...
    • Click the volume icon in the menu bar to see if your audio device is listed

IMPORTANT!! - You must try EACH and EVERY Layout ID in your boot argument until you have success. For Realtek ALC892, they are: 1, 2, 3, 4, 5, 7, 12, 15, 16, 17, 18, 28, 31, 90, 92, 97, or 99. I found success with alcid=5 ONLY after following all previous steps listed here.

All this failing, you could then try repeating the process with ResetHDA or the "Change HDAS to HDEF" patch enabled if these apply to your configuration.

I really hope this helps at least one other person; please let me know if it did. :thumbup:

CKarra.

P.S. You can change the audio quality settings using the Audio Midi Setup application built into macOS.
User avatar
by: CTETechTEach
#53814
Hey, I'm working on this and trying to set the alcid, but it says 0x100003 before the layout Id. How does that look in the '=' situation? Is it alcid=0x1000003? I had partial audio with VoodooHDA, but it would keep cutting out on me during games and stuff. Just trying to fix it the right way.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]