Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: Mudza
AntarcticPL wrote: Sat Oct 12, 2019 8:06 pm Hi Micheldiz, yes it works for me without any problem.
But, I'm still using Gigabyte GA-990fxa-UD5 motherboard with AMD fx8350 processor and RX580 GPU.

Make sure you generate a new serial before using my config.plist. I have wiped it.
And of course change your settings in Graphics section of Clover Configurator for your GPU if needed, I'm using Orinoco (rx580).
Hi AntarticPL, what kext list do you use on your build, have you add AppleMCEReporterDisabler.kext and SSDT-EC0.aml like this link mention : https://amd-osx.com/2019/10/10/macos-ca ... is-on-amd/

Our motherboard near same, I use Asus sabertooth 990FX but I use radeon HD7850. Oh what connection do you use for your display? HDMI or Display port? I use display port here


User avatar
by: AntarcticPL
I always try to keep kexts to the bare minimum. My list in Clover - Other folder:
- AHCIPortInjector
- FakeSMC
- NullCPUPowerManagement
- RealtekRTL8111
- VoodooHDA
And AppleMCEReporterDisabler.kext in the Clover - 10.15 folder

I'm not using any aml file. Also no lilu or whatevergreen. That messed up my setup multiple times.
My display is connected with Displayport.

good luck
User avatar
by: GuessWh0sBack
micheldiz wrote: Sat Oct 12, 2019 5:15 am This also happens on my machine. I've first just update Mojave to Catalina. Works fine, but no Sleep/wake. In Mojave the sleep/wake just works. I was very happy cuz it "just worked" after I installed a rencently bought RX 580 (suffery with Nvidia and a buggy old R9 for years, I was fulfilled, so then... I updated it). So then I tried a clean install. No luck again.

I'm using the vanilla pslist and also have a pendrive with a custom EFI. Both works, but no sleep/wake.

What happens is, when I send it to sleep. The machine tries to. The USB perifericals turn off and so on. But the motherboard keeps on for hours. The BIOS POST Code painel keeps the same code (saying it stills on and nothing changes).

I think something is preventing it to finish the sleep. Not sure if it is the USB controler(AppleUSBXHCIPCI). Maybe the kernel? As I'm not using any kernel crafted for AMD specifically.

I have a software called "Sleep Expert" and it is all normal on it.

With my other pendrive EFI I've tested several combinations of clover configs. No luck. The whole system seems totally fine.

I have exactly the same problem. Has anyone already found a solution? With the config.plist mentioned here I didn't got it to work. Im on a Ryzen 3600X (X570) and a RX580 and used the Vanilla guide.
User avatar
by: Filosaur
Maybe there is an issue, but i didnt try it. I have checked Never hibernate
You do not have the required permissions to view the files attached to this post.
User avatar
by: Mudza

Hi, AntarcticPL can you share your clover Boot.log
Still stuck here no success for sleep wake in my build, maybe theres a clue in your boot.log for me

After update to Catalina(19A602) and change hibernate mode to 3, now sleep wake run normaly
User avatar
by: Jagung
Mudza wrote:@AntarcticPL,

After update to Catalina(19A602) and change hibernate mode to 3, now sleep wake run normaly
Has anyone else tried this ? working ?
AppleTV and red screen

Do you get a pink/purple-ish screen? I have the pu[…]

I have the same issue with my 57800 and sleep/wake[…]

I have the same HW. I have an USB Keyboard and a U[…]

I wanna your efi,and try it.Would u like to send t[…]