Welcome to AMD OS X

Why not register now to gain full access.

EDIT (SOLVED): For anyone who has this issue, this fixed the problem for me:
https://www.insanelymac.com/forum/topic ... nt=2658099

Hi all,

I am getting this error:
Code: Select all
OPEMU: mov rax, [rax]
With what appears to be this flashing occasionally:
Code: Select all
AppleUSBHostController hardwareExceptionThreadCallGated
I followed this install guide:
Before I would get the USB error almost right away, but after using this prelinked:
https://amd-osx.com/forum/viewtopic.php ... a09#p45968
The code seems to get much further before hitting the errors mentioned above.

My system specs:
Motherboard: MSI 970A-G43
CPU: AMD FX 8350 Black Edition
GPU: Sapphire R9 Fury X
SSD: Crucial MX500 500GB
RAM: Qumox 8GB DDR3 1600MHz

My EFI kexts/Other folder:

I've also gone through my bios and set all the settings I could find in the guide.
Last edited by LukeHero on Tue Jul 30, 2019 4:58 pm, edited 3 times in total.


User avatar
by: Shaneee
User avatar
by: LukeHero
I have followed the guide.
Some steps were not so clear though, such as 'Browse to CLOVER/EFI/CLOVER and go to the drivers64UEFI folder' when the 'drivers64UEFI' does not exist. I did what seemed similar to the steps however.
Now the error I get when trying to run the USB installer is:
Code: Select all
I have tried the USB device in multiple ports both USB2.0 and USB3.0.
User avatar
by: Shaneee
As you've got FX use this kext, https://files.amd-osx.com/XLNCUSBFix.kext.zip

Inject it with Clover.
User avatar
by: LukeHero
That's got me quite far! The installer proceeded to load and I was able to install Mojave.
The issue now is when trying to run the first time setup I am able to chose language and keyboard, then comes a screen asking about privacy, once I press continue on that screen the system restarts itself. The same also happens on the language selection if I click the 'show all' for input methods.

The verbose output says generating report, which it does, then proceeds to shut down the system, there doesn't seem to be any obvious clues as to what it could be.

I noticed when unplugging the ethernet cable the system will restart before getting to the privacy section, maybe the issue is related to the that?

EDIT 1: Sometimes an error will show, one time I saw this:
Code: Select all
nothing at 0x107282000
another time it displayed this:
Code: Select all
[0x112b84000...0x112b93000] nothing at 0x112b84000
The codes seem to be different each time, and sometimes there is no code at all.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]