Welcome to AMD OS X

Why not register now to gain full access.

Tutorials for the installation and post install.
User avatar
by: AlGrey
AppleALC is now compatible with the Zen platform.

You can get a copy from here : https://github.com/acidanthera/AppleALC/releases
Also get the latest Lilu : https://github.com/acidanthera/Lilu/releases

Instructions :

1. Mount the EFI partition : Open Clover Configurator and click on the "Mount EFI" tab. Under Efi Partitions, identify your hard drive and click MOUNT PARTITION.

2. IF PRESENT, Remove AppleHDADisabler.kext and VoodooHDA.kext from EFI/CLOVER/kexts/10.xx and Other (xx is your MacOs version)

3. Copy Lilu.kext and AppleALC.kext to EFI/CLOVER/kexts/Other

4. Open your config.plist (in /EFI/CLOVER/)

5. Add the following bootflag. Replace XX with a compatible codec layout (https://github.com/acidanthera/AppleALC ... ted-codecs)
Code: Select all

Help and Problem Reporting
Attach the following files in a zip file:
- config.plist
- IORegistryExplorer dump (File -> save)
- and make sure you have your specs in your signature + MacOS version you are using.
Code: Select all
IORegistryExplorer : https://nofile.io/f/cyhoWKcGM8f/debugtools.zip
Shaneee, Marcyvee, Alex Mac liked this


User avatar
by: Jimmy1232
I still experience audio crackling with AppleALC. On top of that, volume is extremely quiet (basically unusable) AND audio output for speakers and headphones is combined (so I can't pick which one to use without physically plugging/unplugging headphones), so VoodooHDA is objectively better on my Ryzen build

OS: MacOS Mojave 10.14.1
CPU: Ryzen 2200G
MOBO: MSI B350M Mortar
GPU: Sapphire RX580 Nitro+
RAM: 16GB DDR4 @ 3200Mhz
Ethernet: Yes
SSD: Yes
USB: Not working properly
Sound: Not working properly
(6.32 MiB) Downloaded 65 times
User avatar
by: Marcyvee
:clap: Do it works with mojave 10.14.3?
If yes, how to check my codec version? I have a gigabyte ab350 gaming rev1
User avatar
by: Shaneee
Marcyvee wrote::clap: Do it works with mojave 10.14.3?
If yes, how to check my codec version? I have a gigabyte ab350 gaming rev1
Should do yes but 10.14.3 isn't recommended as kernel is only on 10.14.1

You'll need layout 11. Same board as me.
Marcyvee liked this
User avatar
by: Marcyvee
I think is not what I were looking for. Today I'll try your new kernel.
User avatar
by: Taillis Mariquito
I tried all layouts available for me and none worked. I have a ALC887 and here is my specs
Processor: AMD Ryzen 5 2600X
Motherboard: Gigabyte GA-A320M-S2H
GPU: MSI RX580 Armor OC 8Gb
Memory: 8GB DDR4 2333Mhz
Mojave 10.14.3
(1.57 MiB) Downloaded 64 times
User avatar
by: TaeSeok Kim
my audio doesn't work... here is my specs...
CPU : AMD Ryzen 2400G
MOBO : Asrock B450 Gaming its/ac
GPU : Gigabyte RX580 Gaming 4G
RAM : 8x2 DDR4 233
MOJAVE 10.14.3
(5.14 MiB) Downloaded 47 times
User avatar
by: yamilmanzur
Is there a way for the sound regulator to work, either in the settings panel or in the top bar?
User avatar
by: JurassicOSX
How would I enter the boot flag? I have a Realtek ALC892 codec
jayb.online liked this
User avatar
by: mikiveliki
I do not know which layout ID to use because there are lot of them for my chip (Realtek ALC887 0x100202, 0x100302, layout 1, 2, 3, 5, 7, 11, 13, 17, 18, 20, 33, 40, 50, 99). my motherboard is asus prime b350 plus and codec is realtek alc887. please suggestion. and if that make sense, I copied applealc.kext to other and EFI/CLOVER/kexts/10.xx ...
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]