Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: Parthpanchal
Hello, I bought a new HDD (WD Black 2tb) today. Plugged it in correctly, it shows up in BIOS and it shows up in Device Manager, but it doesn't show up in disk management so I can initialize and partition it. I've tried googling but none of the results helped or the problems people had weren't similar to mine.

My Motherboard is Maximus VI Hero and CPU is i7 4770k if that helps with anything.

I am currently running on SSD with Windows 8.1 x64 installed.

Any help would be appreciated.

Edit: solved it by deleting partitions in Hiren's boot

https://appsync.biz/abcya/ https://appsync.biz/adam4adam/] https://appsync.biz/pof/


long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]