Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
#55360
I recently built a Ryzen-based hackintosh (3900X / X570 Aorus Master, clean install of 10.15.3 using OC 0.5.5) to test and see if it's a viable replacement for my old Intel-based one (8700K / Z370 Aorus Gaming 7, using Clover and running Mojave 10.14.6). After verifying that the clean macOS install worked with finishing touches like mapping all the USB ports, I used Migration Assistant to migrate the Intel system over to the AMD. After the migration, everything appears to be working (though Adobe apps required those fixes, and even then I could not get any recent version of Lightroom Classic to work and had to downgrade to 8.4.1).

But there is one weird issue with the mouse cursor that I've run into, and while it's not a show stopper it is extremely annoying. What's happening is that when the mouse cursor seems to behave oddly when it turns from the normal pointer arrow to the text selection cursor. It is by far the most noticeable with the Search text field in Music.app, where the movement speed will slow down to a crawl. I made a short screen recording of this behavior, where I'm moving the mouse at roughly the same speed when the cursor is over the text box vs. when it's not. I also feel like I'm experiencing the issue in other applications as well when the cursor turns into the text selection one, but nowhere else is it nearly as bad as with Music.app Search, so I'm not 100% positive if I'm just imagining it or not.

To make sure this isn't a Catalina issue (as this is actually the first machine I've upgraded to Catalina) I also went and upgraded my 2012 rMBP, and that appears to be perfectly fine. Admittedly it's also a different instance of Music.app, but no issues with the Search box there.

Back to the AMD hackintosh, I also tried quitting all the things that adjust mouse behavior - SteelSeries Exact Mouse to disable acceleration, and Logitech G HUB which is used for my mouse (G502 Lightspeed + PowerPlay mat), and none of that seems to have made a difference.

So, at this point I'm not sure if this is an issue caused by being a hackintosh, being specifically an AMD hackintosh, or even possibly my specific instance of Music.app. The next step for testing would be to go back to the Intel hackintosh and upgrade it to Catalina, but that would require a lot of effort (most of the hardware used has been moved to the AMD system), so I'd like to see if anyone has any ideas about this. Because if I'm being honest, if I went through all that trouble I might just end up sticking with the Intel hackintosh after all - I'd like more cores/threads than what the 6C/12T 8700K, but I could live with it for another year or two as I wait for Intel CPUs to (hopefully) catch up, or Apple actually starts using AMD CPUs. And between the Adobe apps issues and this, there are just enough annoyances with the AMD system that I'd rather stick with the tried-and-true Intel-based setup.

E: I see there have been some related topics/posts pertaining to issues with mouse cursor, but the closest thing to a solution (make sure cursor size is normal in System Preferences -> Accessibility -> Display -> Cursor) doesn't apply as mine is already set that way. I did try disabling the "shake to locate" option and that didn't make any difference either.
Post Merged
Found another instance of weird mouse behavior. If I do Cmd-Shift-4 to do a selected area screen capture, the mouse movement becomes extremely slow while I'm dragging the rectangle that sets what area of the screen is being captured - if I were to estimate, it would be as if the mouse DPI setting got lowered from 2000, my default to something like 400.

 Advertising

#55425
This is honestly a lost cause. I've had this issue since forever and it seems that only a few people on earth has this bug.

I've had this bug on my R2200G and my R3600.

I thought it was maybe a GPU related bug but I doubt it. I'm using an MSI RX 480 4GB and I've had this problem since 10.13 and it kept happening on 10.14 and 10.15.

I've found absolutely no fix for this and I've been looking for years for a solution.
#55427
Yeah, the more I used the system the less tolerable this became. Last night I had enough and just said screw it and went back to my 8700K-based hackintosh. And at this point, probably not going to bother with the AMD route again until if/when Apple actually starts using AMD CPUs.
#55468
pleaseclap wrote:I have the same issue and can't figure it out :(. Are you all running multiple monitors? It doesn't seem to occur with only one.
I am. I've already switched back to my Intel system so I can't test anymore, but not using multiple monitors is a complete non-option as a fix anyway.
#55906
Had the same issue on following config: Ryzen 7 2700 / MSI B450 pro / 16 Gb / GT 710

On Mojave / Catalina pointer freezed for about half a second on every cursor change, everything else was perfect (including sleep, iServices, virtualisation with VirualBox and running some games with terrifyingly low FPS).
I tried playing with ACPI, adding additional kext, changed a dozen SMBIOS's, but nothing could help, this glitch just made OS unworkable.
Though on High Sierra everything was smooth, so I sticked to 10.13.6 until GPU upgrade.

Changing GT 710 to Asus RX 560 resolved this issue on Catalina. Both cards have native support and I am not sure what caused this issue, but everything works perfect on 10.15.3 now.
#56727
Same bug here too. 3900x + 5700xt. I dont actually remember having this bug from my fresh install. I guess i'll go ahead and reinstall and see if the problem persist.
Post Merged
Found the issue with my setup.

Right now I'm use 2 monitors.

1x 27" Dell s2719dgf @144Hz
1x 32" Samsung UJ32 @60Hz 4K

After reinstalling the entire system a couple times, redid ACPI compiling, etc.
At the end, unplugging one of my HDMI cable fixed the cursor lag problem.

I guess I'll have to start using Display port cables.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]