Page 1 of 5

AMD FX & OpenCore support

Posted: Wed Jan 29, 2020 1:45 pm
by crokman
Hi Guys and Gals,
I'm trying to install Catalina OSX 10.15.2 on my pc.
The machine is composed:
MB - ASUS ROG Crosshair V Formula Z
CPU - AMD FX 9370 Unleashed
RAM - 4x8GB DDR3 Corsair Dominator
GPU - 2x R9 270 (not the "X" version)
HDD - 240GB SSD Crucial BX500 (for OS. previous install of MacOS High Sierra)
- 240GB SSD Kingston SA400S (Windows10)
- 500GB HDD Samsung HD502 (storage drive)
- 2TB HDD Seagate ST2000DM001
OPTICAL 2x ASUS BW-16D1HT BlueRay DVD RW

I tried with clover bootloader with no results (and I read a lot of posts telling that is no more supporting Catalina). Now I would like to try with OC.
I have a panic message quite immediately after boot.

Is there someone can help me compiling a working EFI folder?

Thank you for your time guys and gals.

In the attachment you can find my actual EFI folder

Re: AMD FX & OpenCore support

Posted: Wed Jan 29, 2020 2:13 pm
by Shaneee
In your Config under Kernel > Quirks set PanicNoKextDump to YES. This will remove the kext info so we can see whats causing the panic. Reboot with that enabled and post a picture of the panic.

Re: AMD FX & OpenCore support

Posted: Thu Jan 30, 2020 11:15 am
by crokman
Shaneee wrote:In your Config under Kernel > Quirks set PanicNoKextDump to YES. This will remove the kext info so we can see whats causing the panic. Reboot with that enabled and post a picture of the panic.
Hi Shaneee, here we have the panic pic.

Any idea for the reason why it happened?

Re: AMD FX & OpenCore support

Posted: Thu Jan 30, 2020 6:19 pm
by Shaneee
Hm that's a hard one to pin point. You've got the FX patches right and you've not mistaken them for the 17h Zen patches? Also do you have NullCPUPowerManagment?

Re: AMD FX & OpenCore support

Posted: Thu Jan 30, 2020 6:41 pm
by crokman
Right, I used the bulldozer series Patch (15th).
And I have NullCPUPowerManagement in OC/Kexts/..
My OC is:
OC/ACPI
  • dsdt.aml
cleaned. 0 errors, 0 warnings, 0 remarks and 0 optimizations.
  • SSDT-RTC-FIX.aml
I tried this one just to try booting OC (I found it on TonyMacX86 but it seems not working)

OC/Drivers
  • ApfsDriverLoader.efi
  • FwRuntimeServices.efi
  • VBoxHfs.efi
  • VirtualSMC.efi
OC/Kexts
  • AppleALC.kext
  • AppleIntelE1000e.kext
(my lan chipset was here in mojave and high sierra)
  • Lilu.kext
  • NullCPUPowerManagement.kext
  • VirtualSMC.kext
  • Whatevergreen.kext
Tools
  • CoreOffset
  • libaistat
  • rtcread
  • smc-fuzzer
  • smcread
Maybe I forgot something or there's something more than necessary...
I'm blowing up! :lol:

Here's my config.plist if can be useful

Re: AMD FX & OpenCore support

Posted: Thu Jan 30, 2020 7:28 pm
by Shaneee
Ok that EFI you shared in the first post was a bit of a mess tbh. I've cleaned it up and added the patch for AppleIntelCPU to remove NullCPU. Replace your whole EFI folder with this one.

Re: AMD FX & OpenCore support

Posted: Fri Jan 31, 2020 8:41 am
by crokman
thank you but I'm still stuck in the same place!
Any idea?

Re: AMD FX & OpenCore support

Posted: Fri Jan 31, 2020 10:09 am
by Shaneee
Try with this,

Re: AMD FX & OpenCore support

Posted: Fri Jan 31, 2020 11:00 am
by crokman
@Shaneee, this time stopped a bit early than normal.. no panic but it stopped during pci configuration i think

Re: AMD FX & OpenCore support

Posted: Fri Jan 31, 2020 11:03 am
by Shaneee
Does your motherboard have an option for Above 4G Encoding? If so make sure it's disabled. You can also try changing npci=0x2000 to npci=0x3000 in the boot args.