Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: crokman
#54300
I did it but my Mac will recon a 7MB display instead of a fake graphic card.
Do I have to use another ID maybe?

 Advertising

User avatar
by: Shaneee
#54301
User avatar
by: crokman
#54334
I'm back again! I tried following the guide you gave me but, unfortunately nothing changed. My GPU is recon as a 7MB monitor. I used to boot with -raddvi and radpg=15. Now the all the stuffs have a better looking but still lo-res display. pixels are very sharp. I found something about injectATI but I think it's a clover stuff. Am I right?
I used r9 270x fake id (1068 0210 as shown in the guide) and I tried with the original one (1168 0210).
In Mojave I used to use 0x68191002 as fake id. It was another card, I know, but all the VRam was recon.
Any suggestions? I saw something about patching DSDT.. Is it a possible solution?

PS Now keyboard is working fine with IT layout. I had to reboot a couple of times to make the changes effectives.
Post Merged
A couple of photo
Post Merged
------------------------------
UPDATE

I found this method as I told before:
https://www.hackintoshzone.com/files/fi ... 0x-series/
Is it a good solution?
You do not have the required permissions to view the files attached to this post.
User avatar
by: Shaneee
#54369
Are those images with DeviceProperties or the DSDT?
User avatar
by: crokman
#54371
Those are with device property patched
I'm trying to compile 2 SSDT, one for each video card.
I will post updates as soon as I can.

_______________________________
UPDATE

I setted up ssdt patches and left the fakeid configuration in DeviceProperties.
This is the result:
Post Merged
No kext loaded
Post Merged
Then here the 2 SSDT
You do not have the required permissions to view the files attached to this post.
Shaneee liked this
User avatar
by: Shaneee
#54373
Remove the Device Properties for testing the SSDT.
User avatar
by: crokman
#54374
Done but still 7MB monitor with no kext loaded for the graphic cards.
Maybe I did some error trying compiling the SSDTs
I tried to follow the guide on GitHub referring to hd7xxx series. On HighSierra and Mojave my GPUs was detected as HD7xxx series 2048MB
You do not have the required permissions to view the files attached to this post.
User avatar
by: Shaneee
#54375
Why are you using IGPU? You should be applying the patches to GFX0
User avatar
by: crokman
#54376
:?
ok I will edit
User avatar
by: Shaneee
#54377
I'm sure that's how it should be... The other option is to manually add your device ID into the kexts themselves. Modifying the system kexts isn't 100% recommended but it "should" work.

Can you share EFI with me? Thank you! Emial:foreve[…]

Use the tool to download 10.15.3 instead of 10.15.[…]

@fabiosun or @Shanne is this the correct guide for[…]

I have a hp6305 with X740 AMD CPU and a Geforce 31[…]