Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: Mudza
#51660
AntarcticPL wrote: Sat Oct 12, 2019 8:06 pm Hi Micheldiz, yes it works for me without any problem.
But, I'm still using Gigabyte GA-990fxa-UD5 motherboard with AMD fx8350 processor and RX580 GPU.

Make sure you generate a new serial before using my config.plist. I have wiped it.
And of course change your settings in Graphics section of Clover Configurator for your GPU if needed, I'm using Orinoco (rx580).
Hi AntarticPL, what kext list do you use on your build, have you add AppleMCEReporterDisabler.kext and SSDT-EC0.aml like this link mention : https://amd-osx.com/2019/10/10/macos-ca ... is-on-amd/

Our motherboard near same, I use Asus sabertooth 990FX but I use radeon HD7850. Oh what connection do you use for your display? HDMI or Display port? I use display port here

 Advertising

User avatar
by: AntarcticPL
#51665
I always try to keep kexts to the bare minimum. My list in Clover - Other folder:
- AHCIPortInjector
- FakeSMC
- NullCPUPowerManagement
- RealtekRTL8111
- VoodooHDA
- XLNCUSBFix
And AppleMCEReporterDisabler.kext in the Clover - 10.15 folder

I'm not using any aml file. Also no lilu or whatevergreen. That messed up my setup multiple times.
My display is connected with Displayport.

good luck
User avatar
by: GuessWh0sBack
#51760
micheldiz wrote: Sat Oct 12, 2019 5:15 am This also happens on my machine. I've first just update Mojave to Catalina. Works fine, but no Sleep/wake. In Mojave the sleep/wake just works. I was very happy cuz it "just worked" after I installed a rencently bought RX 580 (suffery with Nvidia and a buggy old R9 for years, I was fulfilled, so then... I updated it). So then I tried a clean install. No luck again.

I'm using the vanilla pslist and also have a pendrive with a custom EFI. Both works, but no sleep/wake.

What happens is, when I send it to sleep. The machine tries to. The USB perifericals turn off and so on. But the motherboard keeps on for hours. The BIOS POST Code painel keeps the same code (saying it stills on and nothing changes).

I think something is preventing it to finish the sleep. Not sure if it is the USB controler(AppleUSBXHCIPCI). Maybe the kernel? As I'm not using any kernel crafted for AMD specifically.

I have a software called "Sleep Expert" and it is all normal on it.

With my other pendrive EFI I've tested several combinations of clover configs. No luck. The whole system seems totally fine.

I have exactly the same problem. Has anyone already found a solution? With the config.plist mentioned here I didn't got it to work. Im on a Ryzen 3600X (X570) and a RX580 and used the Vanilla guide.
User avatar
by: Filosaur
#51763
Maybe there is an issue, but i didnt try it. I have checked Never hibernate
Attachments
Snímek obrazovky 2019-10-16 v 22.19.05.png
Snímek obrazovky 2019-10-16 v 22.19.05.png (563.79 KiB) Viewed 1057 times
User avatar
by: Mudza
#51813
@AntarcticPL,

Hi, AntarcticPL can you share your clover Boot.log
Still stuck here no success for sleep wake in my build, maybe theres a clue in your boot.log for me

UPDATE :
---------------
After update to Catalina(19A602) and change hibernate mode to 3, now sleep wake run normaly
User avatar
by: Jagung
#52009
Mudza wrote:@AntarcticPL,

UPDATE :
---------------
After update to Catalina(19A602) and change hibernate mode to 3, now sleep wake run normaly
Has anyone else tried this ? working ?
User avatar
by: djseban
#52623
No luck with hibernatemode=3 either. System tries to go to sleep, turns of fUSB ports, but PC remains powered up. If I wait more than 3 minutes I get KP report on reboot:
Code: Select all
panic(cpu 0 caller 0xffffff800f4a1c6c): Sleep transition timed out after 180 seconds while calling power state change callbacks. Suspected bundle: com.apple.iokit.IOUSBHostFamily. Thread 0x187a.
Failure code:: 0x00000020 00000014

Backtracing specified thread
Backtrace (CPU 0), Frame : Return Address
0xffffff921c03b900 : 0xffffff800ee5dc88 mach_kernel : _machine_switch_context + 0xc8
0xffffff921cabb9b0 : 0xffffff800ed5b5b1 mach_kernel : _thread_unstop + 0x1771
0xffffff921cabba20 : 0xffffff800ed59daf mach_kernel : _thread_block_reason + 0xaf
0xffffff921cabba70 : 0xffffff800ed4abf3 mach_kernel : _lck_mtx_sleep_deadline + 0x73
0xffffff921cabbab0 : 0xffffff800f43ecbf mach_kernel : __ZN10IOWorkLoop9sleepGateEPvyj + 0xbf
0xffffff921cabbaf0 : 0xffffff800f43fdc3 mach_kernel : __ZN13IOEventSource9sleepGateEPvyj + 0x53
0xffffff921cabbb30 : 0xffffff7f8f981258 com.apple.iokit.IOUSBHostFamily : __ZN22AppleUSBHostController20lowerOnePowerStateToEm + 0x114
0xffffff921cabbca0 : 0xffffff7f8fcc2af4 com.apple.driver.usb.AppleUSBXHCI : __ZN12AppleUSBXHCI20lowerOnePowerStateToEm + 0x2e2
0xffffff921cabbd10 : 0xffffff7f8fde4e1a com.apple.driver.usb.AppleUSBXHCIPCI : __ZN15AppleUSBXHCIPCI20lowerOnePowerStateToEm + 0x1fc
0xffffff921cabbd60 : 0xffffff7f8f980053 com.apple.iokit.IOUSBHostFamily : __ZN22AppleUSBHostController18setPowerStateGatedEmP9IOService + 0x2db
0xffffff921cabbdc0 : 0xffffff800f441698 mach_kernel : __ZN13IOCommandGate9runActionEPFiP8OSObjectPvS2_S2_S2_ES2_S2_S2_S2_ + 0x138
0xffffff921cabbe20 : 0xffffff7f8f97fd74 com.apple.iokit.IOUSBHostFamily : __ZN22AppleUSBHostController13setPowerStateEmP9IOService + 0x32
0xffffff921cabbe30 : 0xffffff800f426654 mach_kernel : __ZN9IOService19driverSetPowerStateEv + 0x184
0xffffff921cabbea0 : 0xffffff800f42645a mach_kernel : __ZN9IOService15pmDriverCalloutEPS_ + 0x2a
0xffffff921cabbec0 : 0xffffff800ed7b625 mach_kernel : _thread_call_delayed_timer + 0xea5
0xffffff921cabbf40 : 0xffffff800ed7b151 mach_kernel : _thread_call_delayed_timer + 0x9d1
0xffffff921cabbfa0 : 0xffffff800ece013e mach_kernel : _call_continuation + 0x2e
      Kernel Extensions in backtrace:
         com.apple.iokit.IOUSBHostFamily(1.2)[5E8D1616-2C4B-3E81-B199-59D3531E0759]@0xffffff7f8f96c000->0xffffff7f8fa64fff
            dependency: com.apple.driver.AppleBusPowerController(1.0)[5F8013C3-D135-3795-8C05-F5DDA387ADC4]@0xffffff7f8f952000
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[98454AB6-B806-330F-98C6-FEA7F44D22BA]@0xffffff7f8f95a000
            dependency: com.apple.driver.AppleUSBHostMergeProperties(1.2)[A7569701-C592-31CF-8740-439114078F9F]@0xffffff7f8f968000
         com.apple.driver.usb.AppleUSBXHCI(1.2)[599B22B3-975E-3473-9C75-0E850D3EDE8D]@0xffffff7f8fcae000->0xffffff7f8fd05fff
            dependency: com.apple.iokit.IOACPIFamily(1.4)[4A40B298-87E0-373E-84A9-9A2227924F8F]@0xffffff7f8f8e2000
            dependency: com.apple.iokit.IOUSBHostFamily(1.2)[5E8D1616-2C4B-3E81-B199-59D3531E0759]@0xffffff7f8f96c000
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[98454AB6-B806-330F-98C6-FEA7F44D22BA]@0xffffff7f8f95a000
         com.apple.driver.usb.AppleUSBXHCIPCI(1.2)[23A02E94-8F3B-30A2-9980-251B4E702CB9]@0xffffff7f8fddd000->0xffffff7f8fe0efff
            dependency: com.apple.iokit.IOACPIFamily(1.4)[4A40B298-87E0-373E-84A9-9A2227924F8F]@0xffffff7f8f8e2000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[AA7C7A4F-9F5D-3533-9E78-177C3B6A72BF]@0xffffff7f8f8f4000
            dependency: com.apple.iokit.IOUSBHostFamily(1.2)[5E8D1616-2C4B-3E81-B199-59D3531E0759]@0xffffff7f8f96c000
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[98454AB6-B806-330F-98C6-FEA7F44D22BA]@0xffffff7f8f95a000
            dependency: com.apple.driver.usb.AppleUSBXHCI(1.2)[599B22B3-975E-3473-9C75-0E850D3EDE8D]@0xffffff7f8fcae000

BSD process name corresponding to current thread: kernel_task
Boot args: -v npci=0x2000 debug=0x100 keepsyms=1 alcid=18 busratio=42 

Mac OS version:
19B88

Kernel version:
Darwin Kernel Version 19.0.0: Thu Oct 17 16:17:15 PDT 2019; root:xnu-6153.41.3~29/RELEASE_X86_64
Kernel slide:     0x000000000ea00000
Kernel text base: 0xffffff800ec00000
__HIB  text base: 0xffffff800eb00000
System model name: iMacPro1,1
System shutdown begun: NO
Panic diags file available: YES (0x0)

System uptime in nanoseconds: 268067276306
last loaded kext at 34974820651: @filesystems.exfat	1.4 (addr 0xffffff7f9341a000, size 65536)
User avatar
by: chrinist
#54046
Did anyone figure out the Catalina sleep issue? I too, updated to Catalina from Mojave (which didn't have any issue sleeping before) and my sleep doesn't work anymore. I just restored my system back to Mojave until some more issues are figured out by smarter people than me lol.
Post Merged
I just saw above someone said they had success with the below changes so I will try this as well. Sorry, I didn't see this until after I submitted my post.

"After update to Catalina(19A602) and change hibernate mode to 3, now sleep wake run normally" ~ Mudza
User avatar
by: bondpham
#54512
I had problem after sleep, can not wake:
Code: Select all
anic(cpu 0 caller 0xffffff80178a2d1c): Sleep transition timed out after 180 seconds while calling power state change callbacks. Suspected bundle: com.apple.iokit.IOUSBHostFamily. Thread 0x43b0.
Failure code:: 0x00000020 00000014

Backtracing specified thread
Backtrace (CPU 0), Frame : Return Address
0xffffff9210a4b900 : 0xffffff8017260178 mach_kernel : _machine_switch_context + 0xc8
0xffffff922753b9b0 : 0xffffff801715d771 mach_kernel : _thread_unstop + 0x1771
0xffffff922753ba20 : 0xffffff801715bf6f mach_kernel : _thread_block_reason + 0xaf
0xffffff922753ba70 : 0xffffff801714cdd3 mach_kernel : _lck_mtx_sleep_deadline + 0x73
0xffffff922753bab0 : 0xffffff801783fb9f mach_kernel : __ZN10IOWorkLoop9sleepGateEPvyj + 0xbf
0xffffff922753baf0 : 0xffffff8017840ca3 mach_kernel : __ZN13IOEventSource9sleepGateEPvyj + 0x53
0xffffff922753bb30 : 0xffffff7f98298278 com.apple.iokit.IOUSBHostFamily : __ZN22AppleUSBHostController20lowerOnePowerStateToEm + 0x114
0xffffff922753bca0 : 0xffffff7f98623af4 com.apple.driver.usb.AppleUSBXHCI : __ZN12AppleUSBXHCI20lowerOnePowerStateToEm + 0x2e2
0xffffff922753bd10 : 0xffffff7f98745e1a com.apple.driver.usb.AppleUSBXHCIPCI : __ZN15AppleUSBXHCIPCI20lowerOnePowerStateToEm + 0x1fc
0xffffff922753bd60 : 0xffffff7f98297073 com.apple.iokit.IOUSBHostFamily : __ZN22AppleUSBHostController18setPowerStateGatedEmP9IOService + 0x2db
0xffffff922753bdc0 : 0xffffff8017842578 mach_kernel : __ZN13IOCommandGate9runActionEPFiP8OSObjectPvS2_S2_S2_ES2_S2_S2_S2_ + 0x138
0xffffff922753be20 : 0xffffff7f98296d94 com.apple.iokit.IOUSBHostFamily : __ZN22AppleUSBHostController13setPowerStateEmP9IOService + 0x32
0xffffff922753be30 : 0xffffff8017827534 mach_kernel : __ZN9IOService19driverSetPowerStateEv + 0x184
0xffffff922753bea0 : 0xffffff801782733a mach_kernel : __ZN9IOService15pmDriverCalloutEPS_ + 0x2a
0xffffff922753bec0 : 0xffffff801717d7e5 mach_kernel : _thread_call_delayed_timer + 0xea5
0xffffff922753bf40 : 0xffffff801717d311 mach_kernel : _thread_call_delayed_timer + 0x9d1
0xffffff922753bfa0 : 0xffffff80170e213e mach_kernel : _call_continuation + 0x2e
      Kernel Extensions in backtrace:
         com.apple.iokit.IOUSBHostFamily(1.2)[B7CF50DA-73BD-3233-B207-9036BCAD8E1A]@0xffffff7f98283000->0xffffff7f9837bfff
            dependency: com.apple.driver.AppleBusPowerController(1.0)[9DFFFA4B-7650-37DD-9892-09A64F1A0BC4]@0xffffff7f98269000
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[D19CDA63-3A3D-3C02-AEA2-C061630D17A7]@0xffffff7f98271000
            dependency: com.apple.driver.AppleUSBHostMergeProperties(1.2)[2A37B852-2C0E-3B06-A0D9-B153DD653807]@0xffffff7f9827f000
         com.apple.driver.usb.AppleUSBXHCI(1.2)[4650C412-33F6-322C-A80A-150FC3DA1B18]@0xffffff7f9860f000->0xffffff7f98666fff
            dependency: com.apple.iokit.IOACPIFamily(1.4)[3D78401B-5D2D-33BC-9E41-DD2164EA874D]@0xffffff7f98236000
            dependency: com.apple.iokit.IOUSBHostFamily(1.2)[B7CF50DA-73BD-3233-B207-9036BCAD8E1A]@0xffffff7f98283000
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[D19CDA63-3A3D-3C02-AEA2-C061630D17A7]@0xffffff7f98271000
         com.apple.driver.usb.AppleUSBXHCIPCI(1.2)[71C22181-4BD4-3E9B-AD35-E10850981E3A]@0xffffff7f9873e000->0xffffff7f9876ffff
            dependency: com.apple.iokit.IOACPIFamily(1.4)[3D78401B-5D2D-33BC-9E41-DD2164EA874D]@0xffffff7f98236000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[ADD485B5-3EF8-37C4-B3C5-F86326E497A4]@0xffffff7f97b2f000
            dependency: com.apple.iokit.IOUSBHostFamily(1.2)[B7CF50DA-73BD-3233-B207-9036BCAD8E1A]@0xffffff7f98283000
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[D19CDA63-3A3D-3C02-AEA2-C061630D17A7]@0xffffff7f98271000
            dependency: com.apple.driver.usb.AppleUSBXHCI(1.2)[4650C412-33F6-322C-A80A-150FC3DA1B18]@0xffffff7f9860f000

BSD process name corresponding to current thread: kernel_task
Boot args: shikigva=80 -v keepsyms=1 npci=0x2000 debug=0x100 alcid=1 

Mac OS version:
19D76

Kernel version:
Darwin Kernel Version 19.3.0: Thu Jan  9 20:58:23 PST 2020; root:xnu-6153.81.5~1/RELEASE_X86_64
Kernel UUID: A8DDE75C-CD97-3C37-B35D-1070CC50D2CE
Kernel slide:     0x0000000016e00000
Kernel text base: 0xffffff8017000000
__HIB  text base: 0xffffff8016f00000
System model name: iMacPro1,1 (Mac-7BA5B2D9E42DDD94)
System shutdown begun: NO
Panic diags file available: YES (0x0)

System uptime in nanoseconds: 1449852503650
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]