Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: Jagung
Hi guys, just updated to Catalina from Mojave.

Sleep and wake was working fine on Mojave, but not on Catalina.

Has anyone manage to get sleep to work on Catalina ?


User avatar
by: Shaneee
It seems sleep is broken on Catalina.
User avatar
by: Mudza
AntarcticPL wrote: Fri Oct 11, 2019 9:20 pm Yes, working on my fx8350 and RX580 hack with the same settings as for Mojave in my config.plist.
Can you share your config.plist, i have fx8120 try many way to sleep wake but still no luck
User avatar
by: bdfish1104
My Ryzen 3600 could sleep and wake up without any issue on Mojave but could not sleep on Catalina.

It always report kernel panic which is caused by com.apple.iokit.IOUSBHostFamily.

I have tried some way to solve it but no lucky.
User avatar
by: micheldiz
This also happens on my machine. I've first just update Mojave to Catalina. Works fine, but no Sleep/wake. In Mojave the sleep/wake just works. I was very happy cuz it "just worked" after I installed a rencently bought RX 580 (suffery with Nvidia and a buggy old R9 for years, I was fulfilled, so then... I updated it). So then I tried a clean install. No luck again.

I'm using the vanilla pslist and also have a pendrive with a custom EFI. Both works, but no sleep/wake.

What happens is, when I send it to sleep. The machine tries to. The USB perifericals turn off and so on. But the motherboard keeps on for hours. The BIOS POST Code painel keeps the same code (saying it stills on and nothing changes).

I think something is preventing it to finish the sleep. Not sure if it is the USB controler(AppleUSBXHCIPCI). Maybe the kernel? As I'm not using any kernel crafted for AMD specifically.

I have a software called "Sleep Expert" and it is all normal on it.

With my other pendrive EFI I've tested several combinations of clover configs. No luck. The whole system seems totally fine.
User avatar
by: AntarcticPL
I am still using the XLNCUSBFix.kext that I needed for Mojave to get my USB ports working in Catalina.
See my config.plist, wiped serial.
You do not have the required permissions to view the files attached to this post.
User avatar
by: Mudza
still not working for me, after use your config.plist what is your hibernate mode? I use 0 mode is that right?
User avatar
by: micheldiz
@AntarcticPL, Are you saying it works for you?

I've just test your clover configs and it didn't worked for me. Actually it gets a bit worse, don't even boot.

See photos from the screen https://drive.google.com/drive/folders/ ... sp=sharing
also some other printscreen. And my original config.plist

Using the config.plist from AntarcticPL with
Code: Select all
-v -UseKernelCache No 
says "This version of Mac Os is not supported on this platform!"
Then I used my backup with the same clover, and I get a panic. So I used another pendrive with the original clover configs.


PS. My pmset configs
Code: Select all
pmset -g                     
System-wide power settings:
Currently in use:
 hibernatemode        0
 womp                 1
 networkoversleep     0
 sleep                10
 Sleep On Power Button 1
 ttyskeepawake        1
 hibernatefile        /var/vm/sleepimage
 disksleep            10
 displaysleep         10

pmset -g assertions             
2019-10-12 16:29:57 -0300 
Assertion status system-wide:
   BackgroundTask                 0
   ApplePushServiceTask           0
   UserIsActive                   1
   PreventUserIdleDisplaySleep    0
   PreventSystemSleep             0
   ExternalMedia                  1
   PreventUserIdleSystemSleep     0
   NetworkClientActive            0
Listed by owning process:
   pid 73(powerd): [0x0000000e00088000] 00:22:02 ExternalMedia named: "com.apple.powermanagement.externalmediamounted"  
   pid 118(hidd): [0x0000001600098051] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle serviceID:1000004ec name:AppleUserHIDEventSe product:GXT 890 Keyboard eventType:3"  
	Timeout will fire in 600 secs Action=TimeoutActionRelease
Kernel Assertions: 0x104=USB,MAGICWAKE
   id=500  level=255 0x4=USB mod=31/12/1969 21:00 description=com.apple.usb.externaldevice.60100000 owner=GXT 890 Keyboard
   id=501  level=255 0x4=USB mod=31/12/1969 21:00 description=com.apple.usb.externaldevice.00300000 owner=Patriot Memory
   id=502  level=255 0x4=USB mod=31/12/1969 21:00 description=com.apple.usb.externaldevice.60200000 owner=Razer USB Audio Enhancer
   id=503  level=255 0x4=USB mod=31/12/1969 21:00 description=com.apple.usb.externaldevice.00900000 owner=Gaming Mouse G502
   id=504  level=255 0x100=MAGICWAKE mod=31/12/1969 21:00 description=en0 owner=en0
Idle sleep preventers: IODisplayWrangler
User avatar
by: AntarcticPL
Hi Micheldiz, yes it works for me without any problem.
But, I'm still using Gigabyte GA-990fxa-UD5 motherboard with AMD fx8350 processor and RX580 GPU.

Make sure you generate a new serial before using my config.plist. I have wiped it.
And of course change your settings in Graphics section of Clover Configurator for your GPU if needed, I'm using Orinoco (rx580).

I have the same HW. I have an USB Keyboard and a U[…]

I wanna your efi,and try it.Would u like to send t[…]

I need your advice

High Sierra. The GPU is holding you back.

Thought my experience would be a positive addition[…]