Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: DTMHibbert
#57029
Hi All,

New memeber here,

I have recently successfully installed Catalina on my Ryzen 3900x based machine and im really happy so far.

One problem im having so far is that i cant use all USB port on the rear IO of my motherboard. i have gone through most tutorials i can find online around port mapping and using SSDT's and DSDT's and different kext and just cannot for the life of me get this to work.

My Build
  • Ryzen 3900x @ 4.3GHz
  • Asus VIII Crosshair Hero
  • Corsair MP600 1TB nvme x2
  • MSI GTX970 until my 5700XT arrives
  • 16GB CAS15 RAM
Thanks Guys :)

 Advertising

User avatar
by: Shaneee
#57034
In your config set Kernel -> Quirks -> XhciPortLimit to True and add this SSDT to the ACPI folder. Don't forget to include it in your config under ACPI -> Add.
Attachments
(1.17 KiB) Downloaded 75 times
User avatar
by: tung_opeth
#57041
can you put it to sleep?
User avatar
by: DTMHibbert
#57053
Shaneee wrote: Thu Apr 30, 2020 11:33 pm In your config set Kernel -> Quirks -> XhciPortLimit to True and add this SSDT to the ACPI folder. Don't forget to include it in your config under ACPI -> Add.
You sir, are amazing.... i owe you a rather large drink, all ports working perfectly :thumbup:
Shaneee liked this
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]