Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
#50984
Second EDIT: this can apparently also happen on a real Mac; here's a thread.

EDIT: In the course of switching to Catalina I have finally figured this problem out! It is indeed caused by the graphics drivers, but only in my particular hardware setup since I have TWO cards installed. The issue does not appear with ONE card!

To clarify:

- the problem started on High Sierra which I had migrated from an i5 machine (using Clover)
- it persisted as I ran my AMD machine with a new Mojave install (again, Clover)
- the problem disappeared when I test-installed Catalina 15.1 with Clover and ONE graphics card in my machine
- the problem came back after I added the second card to my system for testing
- I'm now testing Catalina 15.2 with OpenCore and the issue persists with both cards installed

It's clear at this point that running two cards simultaneously causes the issue. Since Catalina is the first version of macOS allowing me to use my primary Navi-based card, I can throw out the other card which I did for my first Catalina test, at which point the problem went away completely!

FYI, I used an RX 560 by Sapphire for Mojave and the Navi card (RX 5700 XT) for gaming on Windows. But the issue also manifested itself with my previous macOS card, a GeForce GT 730. That's the card I ran High Sierra on when I tested my AMD build. So it really doesn't matter what cards you use; the problem is using two cards at all.

SOLUTION:
Since I only used the other card to get around macOS's missing support for Navi, I can remove it now and be happy running my Navi card solo. If you need to run an extra card for macOS because your primary card is not supported, you might want to try and disable the unsupported card by ACPI patching. I have never attempted this but I've read it's possible with OpenCore. My guess is that as soon as one card is "invisible" to macOS, the cursor issue disappears.
Then again, many people are running two cards and have not noticed this problem, so it might be specific to certain chipsets or hardware.

Original post below.

------------------

I have a weird issue with my Mojave system. Whenever the mouse cursor turns into a hand, i-beam or other shape, or even when it grows because of the "shake to find cursor" feature, the pointer stops for the blink of an eye. It's almost as if it freezes for one frame, then continues.

It took me a while to find out why my mouse had erratic movement when I swapped my Intel hackintosh for a Ryzen. That's the weirdest thing; the same mouse ran smoothly without issues on the old machine. When I moved the SSD that contained the Intel macOS system to the Ryzen machine (for testing), the problem immediately started. So it must be related to the Ryzen kernel patches or some other issue macOS has with the AMD hardware!

I think the issue is in fact related to graphics as I've observed some other slight graphical glitches, which I never had on the Intel machine with the same GPU installed (GT 730). These glitches are very slight, such as a window moving erratically when minimized, the launchpad not coming up smoothly or a minimized app having a rectangle arond the dock icon. All of these glitches only happen occasionally.
What I can't figure out is why the change of a mouse pointer graphic would mess with the USB input data of the mouse. Is this something that could be caused (fixed?) by kexts and patches?

The mouse is an MX Master and the USB device is the Unifying receiver. And before y'all start, I know this mouse has issues with macOS but I've tested several mice, including a corded one! The issue persists with all of them. My MX Master does have another issue with wireless performance but that seems to be based on the new motherboard and not macOS.

Any insights appreciated. (Maybe someone with an X570 mobo can test this?)
Last edited by MadMax1998 on Sun Feb 23, 2020 1:53 pm, edited 2 times in total.

 Advertising

#55046
MadMax1998 wrote:@thejumono, see my first post where I added the solution. Good luck!
I am using only one card (GT710) and I have this problem with the cursor :(
* Ryzen / OpenCore
* Catalina 10.15.3 / Mojave too.

It appears to be a problem with the operating system itself.
I don't know what else to do at the moment. :roll: Any news?

best regards.
#55482
Same issue here.

Single card.

Ryzen 3900x, 5700xt, ax370 gaming 5 motherboard.

Issue appears most severely with two or more monitors connected, however it is definitely present in an almost negligible way with a single monitor, barely noticeable but still affected.

Have attempted the solutions here (thanks OP), unfortunately not effective.
#56566
Hi guys,

same here, getting on my nerves extremely.
I switched from Intel to AMD and from Clover to OpenCore (with AMD Vanilla Guide). I installed my (PowerColor) AMD RX5700XT before switching to AMD and I had no problems at all. I have not reinstalled my OSX system.

Now I changed two components, Bootloader and Motherboard/CPU and I dont know where is problem coming from.

I noticed if I trigger fat mouse with swiping mouse fast I see extreme rising of CPU usage from windowserver process, can you see this on your build too?
Second thing, I have Apps folder in dock, if I open it, it laggs. If I open it again it will not lag. I think this is caused by downclocking GPU for power saving. This was not happening with my Intel system. This is not a problem for me, but the mouse lagging is a showstopper.

I am using Hacintosh for years and if I upgrade my hardware I read hacintosh forums for hardware recommends, so I choose my new system because everything is working for other people without problems and now this problem.

System spec before:
macOS Catalina 10.15.4
CLOVER Bootloader

MSI B150M Pro VDH
16GB Memory 2133MHz
Intel i7-7700
AMD RX5700XT (PowerColor)
Three monitors connected via DP to DVI Cable
-----------------------
System spec after:
macOS Catalina 10.15.4
OpenCore 0.5.7 Bootloader

Gigabyte AORUS I X570 Pro WiFi (Mini ITX Version Rev 1.0)
AMD Ryzen 7 3800X
16GB Memory 3600MHz
AMD RX5700XT (PowerColor)
Three monitors connected via DP to DVI Cable

Steps tried to fix mouse lagging (on shape changing behavior):
- Change SMBios from iMacPro19,1 to iMac19,1 and MacPro7,1
- Installed SSDT-PLUG and AGPMInjector for CPU and GPU PowerManagement
- Installed AMDRyzenCPUPowerManagement.kext and SMCAMDProcessor.kext
- Updated LiLu and Whatevergreen to newest versions

Steps I will try in future:
- Try CLOVER to boot this AMD system (no luck so far, so I change to OC)
- Try a fresh install (no hope this bug will disappear)
- Try to disable cursor change (only workaround)
Post Merged
I freshly installed macOS 10.15.3 and 10.15.4 on a freshly installed SSD for testing.
In Recovery and Installer, this kinda strange lagging of cursor is there too.

On fresh installed systems it's even worse, cursor freezing for every 10secs or so, without changing shape. Console and kernel logfile has no information about this situation. Even window server logs had no errors. CPU increase of this process is heavily if mouse is changing shape.

On my production system I set all mouse shapes to static with Mousecap, so it's better usable. But unfortionately I am using Office and Remote connections a lot, Mousecape is not working there. System is running normally, execpt mouse problem.

In conclusion, GPU is working with my older intel system without a problem. Other people with similar setup has no problems anyway. So there must be a misconfiguraton or something happening here, I never used OpenCore before.

I think this has to do with PowerManagement or a Timer or Sync thing, but I am no very experienced with this and logfiles giving no hints (for me) about the issue.

If someone has other ideas, this would be very helpful. I noticed I posted in mojave forum, should I start a new Thread in Catalina? I cannot go back to Mojave for testing, because of the RX5700XT.
Clover was not working for me, I tried EFIs from other users too, kernel is not even starting.
Attachments
(5.41 KiB) Downloaded 5 times
Bildschirmfoto 2020-04-13 um 20.39.49.png
Bildschirmfoto 2020-04-13 um 20.39.49.png (106.22 KiB) Viewed 170 times
Bildschirmfoto 2020-04-13 um 20.38.58.png
Bildschirmfoto 2020-04-13 um 20.38.58.png (47.16 KiB) Viewed 170 times
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]