Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
User avatar
by: MadMax1998
Now I know that AVID explicitly state that AMD hardware is not supported by Pro Tools, but on Windows the software runs just fine. The problem is with macOS.

On my old High Sierra install from an Intel system, where PT ran fine (I ran version 12.4), it refused to start after transplanting the SSD into my Ryzen system. And now that I've installed Mojave and PT fresh, same thing. I even tried with Pro Tools First to get a current version of the software, just in case I needed that. But again, doesn't start.

It might be one of those programs that need a certain Intel-specific thing the kernel patches don't provide? Like Steam does too?

Since I have nothing else to give you guys, here's the crash log of PT First:
*** Digidesign Session Trace for: /Applications/Pro Tools First.app (pid=0x537, version=19.5.0)
*** Build Details: Build: Production; Branch: ProTools_First_2019.R1.X; InternalVersion: 2019.R1.0; Target: Release(0); Build: 322
*** Starting Timestamp: Mittwoch, 28. August 2019 um 00:27:02 Mitteleuropäische Sommerzeit (1238045177 uS)
*** System Details: OS Version: 10.14,6, CPU Speed: 3.6 gHz, Architecture: Intel 64 bit, Num Processors: 16 logical 8 physical, Memory: 16384 MB
*** Build Date: May 4 2019
*** DigiTrace Config File: /Applications/Pro Tools First.app/Contents/Resources/config.digitrace
*** Machine UUID: 56CF.9606.114D.2A76
*** Facilities to trace:

[email protected]_HIGH(0073)
[email protected]_HIGH(0077)
DTF_ALL[email protected]_NORMAL(0d02)
[email protected]_NORMAL(005a)
[email protected]_LOW(0e0b)
[email protected]_LOW(0e0f)
[email protected]_HIGH(0028)
[email protected]_HIGH(002b)
[email protected]_HIGH(0730)
[email protected]_NORMAL(0f09)
[email protected]_NORMAL(0f07)
[email protected]_LOW(0e0c)
[email protected]_NORMAL(0e10)
[email protected]_NORMAL(0076)
[email protected]_LOW(0e0e)
[email protected]_LOW(0e37)
[email protected]_NORMAL(0033)
[email protected]_HIGH(0e22)
[email protected]_HIGH(0083)
[email protected]_NORMAL(0084)
[email protected]_HIGH(0086)
[email protected]_HIGH(0087)
[email protected]_HIGH(0085)
[email protected]_NORMAL(0034)
[email protected]_NORMAL(0e0d)
[email protected]_HIGH(0e15)
[email protected]_HIGH(000f)
[email protected]_NORMAL(0f14)
[email protected]_HIGH(0e13)
[email protected]_NORMAL(0d04)
[email protected]_HIGH(0d00)
[email protected]_HIGH(007e)
[email protected]_HIGH(0f10)
[email protected]_HIGH(0b0d)

Time(s),Tid,Facility,Name : Debug Message
1238.214150,00307,0e0d: Pace eden lib version: 5.0.1, r43417 (, licenseSupport version: 5.0.3, r44013 (, libAuthServicesVersion=4, licenseDAuthServices=4 (success=yes)
1238.225774,00307,0e0d: ShoeTool_Init - shoe tool installed version is 12.000000, currentVersion is 12.000000, needToInstall=false
1238.225875,00307,0e0d: ShoeTool_IncreaseAIOLimits - var=46, newVal=512, curVal=512, rtn=0
1238.225879,00307,0e0d: ShoeTool_IncreaseAIOLimits - var=47, newVal=512, curVal=512, rtn=0
1238.225882,00307,0e0d: ShoeTool_IncreaseAIOLimits - var=48, newVal=32, curVal=32, rtn=0
1238.225884,00307,0e0d: ShoeTool_IncreaseAIOLimits - limits are already up to date, skipping DigiShoeTool
1238.231155,00307,0e0d: ShoeTool_CreateFolder - inPath=/Applications/Avid
1238.231321,00307,0e0d: ShoeTool_CreateFolder - received error 17
1238.231334,00307,0e0d: ShoeTool_CreateFolder - inPath=/Applications/Avid/Licenses
1238.231404,00307,0e0d: ShoeTool_CreateFolder - received error 17
1238.231408,00307,0e0d: ShoeTool_CreateFolder - inPath=/Applications/Avid/Licenses/Avid
1238.231472,00307,0e0d: ShoeTool_CreateFolder - received error 17
1238.231478,00307,0e0d: ShoeTool_CreateFolder - inPath=/Applications/Avid/Licenses/Avid/Pro Tools
1238.231556,00307,0e0d: ShoeTool_CreateFolder - received error 17
1238.231570,00307,0e0d: ShoeTool_CopyFolder - inSrcPath=/Applications/Pro Tools First.app/Contents/SharedSupport/Licenses/Avid/Pro Tools, inDstPath=/Applications/Avid/Licenses/Avid/Pro Tools
1238.263032,00307,0e0d: ShoeTool_CopyFolder - received successful reply
1238.263191,00307,0e0d: ShoeTool_CreateFolder - inPath=/Applications/Avid
1238.263269,00307,0e0d: ShoeTool_CreateFolder - received error 17
1238.263273,00307,0e0d: ShoeTool_CreateFolder - inPath=/Applications/Avid/Licenses
1238.263331,00307,0e0d: ShoeTool_CreateFolder - received error 17
1238.263336,00307,0e0d: ShoeTool_CreateFolder - inPath=/Applications/Avid/Licenses/Third Party
1238.263409,00307,0e0d: ShoeTool_CreateFolder - received error 17
1238.263417,00307,0e0d: ShoeTool_CopyFolder - inSrcPath=/Applications/Pro Tools First.app/Contents/SharedSupport/Licenses/Third Party, inDstPath=/Applications/Avid/Licenses/Third Party
1238.265851,00307,0e0d: ShoeTool_CopyFolder - received successful reply
1238.906741,00307,0e0f: LoadAndRunProToolsDLL - loaded ProTools dll.
1238.908676,00307,0e0d: Sys_PACE::GetDigitalSignature - looking for Eden dsig for path "/Applications/Pro Tools First.app/Contents/Frameworks/Pro Tools.framework/"
1239.706522,00307,0e0d: Sys_PACE::GetDigitalSignature - looking for Eden dsig for path "/Applications/Pro Tools First.app/Contents/Frameworks/CFnd.framework/"
1239.767732,00307,0e0d: Sys_PACE::GetDigitalSignature - looking for Eden dsig for path "/Applications/Pro Tools First.app/Contents/Frameworks/DFW.framework/"
1239.833405,00307,0e0d: Sys_PACE::GetDigitalSignature - looking for Eden dsig for path "/Applications/Pro Tools First.app/Contents/Frameworks/AAE.framework/"
1239.903234,00307,0e0d: Sys_PACE::GetDigitalSignature - looking for Eden dsig for path "/Applications/Pro Tools First.app/Contents/Frameworks/AAXHost.framework/"
1239.975452,00307,0e0d: Sys_PACE::GetDigitalSignature - looking for Eden dsig for path "/Applications/Pro Tools First.app/Contents/Frameworks/TIShellMgr.framework/"
1240.049061,00307,0e0d: Sys_PACE::GetDigitalSignature - looking for Eden dsig for path "/Applications/Pro Tools First.app/Contents/Frameworks/SMgr.framework/"
1240.126584,00307,0e0d: Sys_PACE::GetDigitalSignature - looking for Eden dsig for path "/Applications/Pro Tools First.app/Contents/Frameworks/PTW.framework/"
1240.153292,00307,0e0d: Sys_PACE::GetDigitalSignature - looking for Eden dsig for path "/Applications/Pro Tools First.app/Contents/Frameworks/PTCloud.framework/"
1240.218719,00307,0e0c: Expected Release Date: May 4 2019
1240.401385,05303,0034: [catch_exception_raise] got mach exception: 2
By the way, it doesn't matter whether I use online or iLok activation. The iLok works fine in iLok License Manager. The problem is really the DAW itself won't start for some reason. I don't even get the splash screen and have to force quit the app.

Any insights appreciated, or maybe future kernel patches will fix. :thumbup:
Post Merged
I think I found the anwser to my own question... citing:
Pro Tools - some components are still 32-bit.
https://www.pro-tools-expert.com/produc ... now-so-far

So I assume this will work with as soon as AVID qualifies Pro Tools for Catalina.


User avatar
by: el1nd1o
I'm having the sam issue I have a Ryzen 3900x with x570 ASrock phantom gaming 4
with 64g ram and a vaga56 Gpu and 500g ssd
everything seems to work find but protools it says its not responding 😢🤯I hope avid update soon I need to work Im forced to use windows 10 in order to use PT I really do not like PT on windows. this is the only reason why I made my ryzontosh. someone please help use out 🙏🏻
Post Merged
im runing Mojave 10.14.6 forgot to mention that
mr.savage liked this
User avatar
by: Ilan Cortes
I am having the same issues Pro Tools 11 with 3700x + x570. I know it's technically not supported BUT on my Macbook Pro 2013 it's running fine on a newer version of Mojave. I was forced to use not so good windows to say it kindly. It performs well but I'm so used to mac shortcuts and the mac ecosystem in general. I was enticed to build hackintosh with the AMD Ryzen and It's sad that it doesn't open Pro Tools.

@willeyh, do you have it running on your setup?
User avatar
by: willeyh
I had it running on my previous i7 4790 running Sierra as my personal Pro Tools license is only 12.8.3. So no dice on High Sierra or above. And I don´t really want to splash that amount of cash.
Running Pro Tools Ultimate at work, but still on High Sierra and a "trash can" Mac Pro.

Pro Tools 11 is not supported above 10.10.5 so how can you be running that on your Mojave Macbook?
User avatar
by: Ilan Cortes
You know, I never even thought of it. I just bought a used MacBook and installed it on at the time the OS X before Mojave. It installed fine I didn’t receive any errors . When I updated the OS it didn’t break anything!

so here am I just assuming it would work with my Mojave’s Ryzentosh but I got the same errors listed above. The icon would just jump up and down until it didn’t.

I even considered replacing my motherboard and cpu to the intel counterpart to get pro tools working but now you have me wondering if somehow my install of Pro Tools 11 is an anomaly and it won’t open on the intel hackintosh.
User avatar
by: Shaneee
It's possible that it's a 32bit application and won't run with the AMD native patches because there's no OPEMU included. If that is the case I can see it getting updated soon enough as Catalina drops 32bit support entirely.
User avatar
by: Kuleone
Shaneee wrote:It's possible that it's a 32bit application and won't run with the AMD native patches because there's no OPEMU included. If that is the case I can see it getting updated soon enough as Catalina drops 32bit support entirely.
Hi Shaneee, I just wanted to clear the air. First Protools has been 64bit since Protools 2018.
I’ve been working on this issue for two weeks straight. All I can say since the Vanilla patches, I can no longer run Protools on High Sierra or Mojave. I have the latest Version 2019.10 which has been qualified for Mojave. I did two new installs again today with High Sierra and Mojave, still the same issues. The program was running great with the old method of patching. Some program installations don’t run or even install with the new patch? Which ran with no issues on the old version. I have been running my studio on your old patch with no problems, any insight on your part would be greatly appreciated. Thank you and everyone else for the hard work you put in. :thumbup:
User avatar
by: jacksocs
Any follow up since Avid released 2019.12? I'm curious if that has made the difference to getting Pro Tools to launch. I've got Pro Tools running on a few intel hacks and it runs super well, so my suspicion is that its the 32 bit support apps that have been the problem.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]