Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.

i'm having an issue i can't seem to solve and would sincerely appreciate any help i can get in fixing it and having a functional installation.

below is the hardware i am using, description of the problem, and solutions i've tried.

hardware: FX-8350 CPU installed in a Gigabyte GA-990FXA-UD3 Rev 4.1 mommyboard (F2 BIOS, F3 causes thermal problems), 8gb (4GB x 2) Corsair Vengeance 1600 9-9-9-24 RAM, 2 Gigabyte R9 270 2GB video cards and a Toshiba 3GB SATA hard drive.

OS Version: Mojave 10.14.6 (previously attempted to install 10.14.4, had same issue)

OpenCore Version: 0.5.6

OpenCore notes: system set as "MacPro6,1" in config.plist. npci=0x2000 placed in boot-args section before all this was attempted (mojave installer would not boot without it). config.plist passes 'slowgeek' sanity check.

the problem: "IOConsoleUsers: gIOScreenLockState 3" loop before login screen at boot. i will refer to this as the "gIOSLS3 loop" from here on out for brevity.

solutions tried:
  • first reboot after successful mojave installation resulted in display of GIOSLS3 error message after clicking "continue" on "privacy" screen, which then resulted in a reboot. suggested solution attempted: create a fake "temp" user with admin privileges via single user mode to get beyond the error message/reboot issue, as per XLNC post on another forum.

    this fix DOES NOT WERK on 10.14.4 or 10.14.6. attempted on both aforementioned versions. dctl is non-functional in single user mode and displays errors when attempt is made to use it per the post.

    i got around not being able to create the fake temp user by hand simply by physically removing the drive from the hackintosh system, putting it in a USB 3 external drive caddy, booting up the hackintosh Mojave installation on a real mac (my late 2012 mac mini) and creating my 'proper' user account that way. after "proper" user creation on a real mac and returning the drive back to the hackintosh system, this resulted in gIOSLS3 loop after boot.

    after much googling, i gleaned that the gIOSLS3 loop is caused by a GPU issue.
  • tried adding appropriate radeon driver kexts to OC/Mojave usb installer boot stick. no change. gIOSLS3 loop remained.
  • installed LILU + Whatevergreen on OC/Mojave usb installer boot stick. no change.
  • generated fakeID-patched SSDT's for gpu's. generated a pair of files 4 different times for 4 different variants of R9 270x cards that allegedly werk on Mojave, per a FAQ/guide found linked via the vanilla guide. no change.
  • tried removing radeon drivers previously added. no change.
  • tried disabling CSM in BIOS. no change, and caused other interesting problems, like firewire not being detected properly.
  • tried disabling onboard serial port in BIOS. no change.
  • tried changing OS Type in BIOS. no change.
  • tried booting up using all of the Whatevergreen radeon-related boot-args switches (radvesa, radpg, etc, plus agdpmod vit9696/pikera), one active at a time. no change.
  • tried all of the above with just a single video card installed and appropriate spoof SSDT removed. no change.
i do not know what else to try, and i'm stuck. it is quite possible that either i'm not setting up/using LILU/Whatevergreen correctly (not much documentation -- is it just drop in and forget it?), or i didn't generate the fakeID SSDT files correctly, largely because the guide didn't make much sense to me as to what information/data about the card went where.

i'm happy to supply my fakeID-patched ssdt files if anyone wants to take a peek at 'em, and would be overjoyed to get help with generating them properly if that's what's going to get me a booting mojave installation on this system.

this is all very frustrating, because i feel like i'm just standing on the verge -- i think once this hurdle is figured out, i'll have a completely functional hackintosh.

again, any help or guidance with this will be sincerely appreciated.


p.s. versions of LILU and Whatevergreen are the latest i could find via github.
p.p.s. i'm not really keen on trying to update the vBIOS on the video cards -- tried this with one, bricked it, had to boot in with a freeDOS stick, rip a copy of the vBIOS from the werking card, apply it to the bricked card, and hope fer the best. luckily, this restored it.
Post Merged
i'm still having this problem and i still can't get mojave to boot into the gui -- it still just does its thing right up to the point where it shows an apple logo with status bar, draws the status bar almost all the way to 'finished', blanks the screen, and then gIOSLS3 loops.

is it possible that something else is hanging up the system from going to the login screen? if so, how do i figure it this out? i'm really frustrated and could really use some guidance. is there some log file that gets created that might show me what's puking when the apple logo/status bar is up on the screen before it goes into the gIOSLS3 loop?

everything looks ok for the most part right before it draws the apple logo/status bar and i don't see any error messages that stand out as something that would need to be fixed for it to finish booting up. i can post an example video of what it looks like when it fails if it'll help.

here are some more things that i've tried to fix the problem and get it to boot into the gui and give me a login screen. all have resulted in the gIOSLS3 loop.

  • installed debug versions of OpenCore (0.5.6), LILU and Whatevergreen. WEG shows messages upon boot now, which is nice, but doesn't really indicate whether or not it's even doing much with the video cards other than seeing that they're there.

    after the debug versions of all three got installed, i tried all radeon WEG boot-args individually as well as the adgpmod= switches. no change.
  • hooked drive back up to external usb 3 caddy, mounted the APFS partition on a real mac, edited the info.plist files for the AMD drivers (AMD7000Controller.kext and AMDRadeonX4000.kext) for my R9 270's and added their real id to them (10026811). no change.
  • tried all WEG radeon boot-args switches again individually. no change.
  • re-added various spoof SSDT files i created using the 6810 ID. no change.
  • changed what i assumed is the PCIROOT listing for the card in the OpenCore config.plist and added the card's ID there via a device-id entry. no change.
  • tried both HDMI and DVI output to my cinema display. no change.
what else could be causing this?

again, any help or direction would sincerely be appreciated.



long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]