Welcome to AMD OS X

Why not register now to gain full access.

#53850
Hello! I've been trying to get my OpenCore configuration working for about a week or so to no avail. I am attempting to boot from a previous installation of Mojave 10.14.6, which worked fine for the longest time with Clover until it randomly stopped booting one day. After messing with Clover for some time to try and revive my installation, I came across OpenCore and decided to give it a go while my machine was already out of commission.

However, there is a certain period while booting Darwin that my PC consistently panics at, although not always ending with the same log line. It is most commonly immediately after "HID: Legacy shim 2", but has also come after "[PCI Configuration Begin]", "HPET: map device registers failed", and rarely, "RTC: lost battery power - time may be invalid". The last line is always preceded by "RTC: Only single RAM bank (128 bytes)".

I have been using the following boot-args: -v npci=0x2000 debug=0x100 keepsyms=1
Note: I have also tried replacing with npci=0x3000 -- no dice.

You may be thinking: "If Clover was working for so long with whatever settings you had been using, did you at least base your OpenCore configuration from your past settings?"

Well, I did, or at least tried. In my old Clover config.plist, I had noticed that the AppleRTC patch had been applied, so I attempted to recreate this in OpenCore. First, I found a kext patch for com.apple.driver.AppleRTC (10.14.4+), but it yielded no different result. I then tried RTCMemoryFixup with exclusions for B4-B7 and 58-59 (which I found from a different forum), but no luck there, either.

I have also considered it potentially being a DSDT issue, but seeing as I had booted Clover fine without many DSDT patches before, I now believe this is not the case (I had only been using FixShutdown, actually).

My kexts (in load order):
* Lilu
* VirtualSMC
* NullCPUPowerManagement
* WhateverGreen
* AppleALC
* SmallTreeIntel82576
* NoTouchID

My relevant BIOS settings:
* SATA Mode: AHCI
* CSM Support: Enabled (I have also tried Disabled, but not only does this make no difference, I then have graphical issues)
* 4G Decoding: Enabled (I have also tried Disabled -- no difference)
* SVM (virtualization): Enabled (I have also tried Disabled)
* IOMMU: Disabled (I have also tried Enabled)
* Legacy USB Support: Disabled (I have also tried Enabled)

My CPU/MB:
* Ryzen 7 2700X
* Gigabyte X470 AORUS Gaming 5 WiFi

Any help at all is appreciated. Thanks in advance! I can provide additional information if/when needed.

 Advertising

For iMessage etc you'll need to generate another […]

Help booting Mojave installer

OpenCore supports all version of 10.13, 10.14 and[…]

@teseraph , Hi i'm planning to build the same […]

Known issue on AMD hacks. We assume it's because t[…]