Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: VaultIvi117
#51209
Hi, I have some trouble to install OS X Mojave in my build, I followed the Vanilla OS X guide, but when I boot from my USB at this point the monitor got signal but didn't show anything. Any suggestion?

Kexts:
- FakeSMC.kext
- NullCPUPowerManagment.kext
- Whatevergreen.kext
- Lilu.kext
You do not have the required permissions to view the files attached to this post.

 Advertising

User avatar
by: frle10
#51223
I don't have a solution to this as I'm facing the same problem, I just tried to install from USB after thoroughly following the Vanilla guide. After many lines of status messages the system seems to advance to install phase but instead stays on a completely black screen with no response.

I have pretty much the same CPU as you and I'm using VirtualSMC instead of FakeSMC kext.

Anyone have any ideas what could be causing the problem?
User avatar
by: VaultIvi117
#51230
I tried to unplug and plug back, and didn't work for me, any suggestions? Or any idea about this issue?
User avatar
by: frle10
#51231
I've found another post on this forum where a user had a black screen but after the installation. Might not be related to our problem but it is worth a try.

XLNC suggested in that topic that one should try run the installer with these bootflags:
-lilubetaall radpg=15

viewtopic.php?f=52&t=3814&p=36927&hilit ... 870#p36927

You can change the bootflags in Clover bootloader when you boot from USB in the menu before clicking "Boot MacOSInstaller", there is an Option menu.

P.S. I've had a much bigger problem appear too, after letting the black screen be for a while, my computer went into sleep after some time and afterwards did not POST anymore. Couldn't even get to Windows. Had to clear CMOS by adjusting the jumpers on the motherboard so be careful. :)

EDIT: I think those bootflags above are connected with Radeon GPU behavior. I think this problem has to do something with AMD GPUs? Not sure. However, it is worth a try no matter what configuration you have, and post your results. :)
Post Merged
UPDATE: I tried several things and had no success... However I will post my methods here so you can try them out too.

So I tried:
- reppluging the video cable
- unplugging the second monitor cable
- flag -lilubetaall and radpg=15 combined
- flag radpg=15 alone
- flag -radvesa alone
- changed flag npci=0x2000 to npci=0x3000 and added flag PCIRootUID=0 (combined)

When I played with bootflags I only added new ones or modified the existing ones, I never removed ones that were there by default.
User avatar
by: VaultIvi117
#51274
Sorry for answer late, I tried everything and nothing. I read about a possible solution, it's swap from HDMI to DP, but I don't have DP.
Sleep wake solutions?

This also happens on my machine. I've first just[…]

Hey there :wave: I have the same issue with my 2[…]

hi guys, thanks for all the hard work getting thi[…]

You'll get it recognised with full resolution but […]