Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: Magysely
#54668
Hello everyone !

I'm finally posting here after scratching my head all day trying to install Mojave.

My latest hackintosh dates from the earlier Clover days on Intel (probably on OSX Maverick) but I decided to try out this bootloader that looks very promising.

My problem is that I get stuck right at the installation. When trying to install, I get a message along the lines of "cannot install because GPU doesn't support Metal and filevault has to be disabled" (don't recall the exact wording).

Here's my system specs:
Gigabyte x470 Aorus Ultra Gaming
Ryzen 7 2700
MSI Gaming X GTX 980 ti

The only reason I went for Mojave instead of Catalina is just that I didn't have any 16Gb USB sticks on hand, to be honest...

So to provide a bit more info, I mainly used the guide uploaded by Snazzylabs recently on YT.

I used gibMacOS to prepare the USB drive and download the latest full install version of Mojave.
Added the drivers (ApfsDriverLoader, FwRuntimeServices, VBoxHfs).
Built my DSDT and SSDT-EC via SSDTTime.
Generated my config.plist using ProperTree. Also applied AMD_Vanilla-opencore patches.
Added the follownig Kexts:
  • WhateverGreen
  • FakeSMC
  • Lilu
  • AppleALC
  • SmallTreeIntel82576
  • NullCPUPowerManagement
  • GenericUSBXHCI
In my BIOS, I've disabled CSM support. Tried with and without enabling the above 4G decoding but didn't seem to cause any changes.

Some observations I made:
  • I can't go past the PCI configuration in bootloader if I don't have bootargs npci=0x2000 or 0x3000
  • When using bootargs npci=0x2000 or 0x3000, I get to the installer without issues, but then can't actually install because of my GPU apparently lacking Metal support
I'm currently out of ideas to try out. It seems obvious there's an issue with my GPU but I couldn't find evidence that it wasn't supported with WhateverGreen. Am I missing something ?

Attached is my config.plist and my DSDTs if that helps.
Post Merged
EDIT: I've managed to get it to install fully after recreating the complete USB installer from scratch. Now I have issues with crappy display output but I understand that's just how it is for Nvidia users starting from Mojave. Will revert and install High Sierra to see if I get any luck.

Piece of general advise: if you change something without effect, undo your change before trying anything else !

I can't possibly pin point what the issue was with my first attempts, but somehow by going from scratch it fixed it.

Cheers.
Max
Attachments
SSDT, DSDT and config
(15.81 KiB) Downloaded 48 times

 Advertising

User avatar
by: pdq
#56841
@Magysely, can you upload the config.plist and DSDT which works well?
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]