Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
Hi kind users of the internet.

I´ve been scratching my head and drinking too much wine trying to not flip for the past couple of days. Over USBs...... :wtf:
Fresh Vanilla install of High Sierra from early september-ish. All kexts injected from kexts-other, nothing in l/e

Went through the "Native USB on Ryzen" thread and the script worked fine. And I can see the USB 3 Controller under "Hardware->USB".
Problem is: My Yamaha AGO06 and my Belkin USB 2.0 HUB and my Apple Keyboard is not recognised. In either of my mobos USB ports.

So if I then boot with GenericUSBXHCI and USBInjectAll in my kexts->other everything except my MOTU Fastlane MIDI->USB works. "Hardware->USB" is blank ofc.
And if I reboot or shut down, kernel panic. Screen goes black, but the hardware and lights stay on.

-v prints out the "Failed to allocate port 1" or "3". Tried disabling different ports in BIOS. Stopped getting the "Port 3" but not both.

I can live with kernel panic after reboot and shutdown, but I need the MOTU Fastlane (and yes, driver is installed).
And I can live with a different sound card (Focusrite 2i2 works fine) on Native, without GenericUSBXHCI, but I need the keyboard and USB-hub.

My setup is:
Asus Prime x570-p
Ryzen 5 3600x with XMP.
NVIDIA GTX 1070 (so Mojave and Catalina has no driver support).

AppleALC, Lilu, NullCPUPowerManagement, RealtekRTL811, VirtualSMC, WhateverGreen

Any advice?


User avatar
by: Shaneee
What was it like before you applied a fix? My AB350 board works native without any USB fixes.
User avatar
by: willeyh
My memory is a bit blurred, but I think only a selection of ports worked without GenericUSBXCHI. And the reboot/shutdown thing always gave me "System recovered from a kernel panic" after next boot. (Had to manually shut down the system).

But. A bit more reading today, and actually using my brain in a somewhat sober state, I do think it might be down to a port limit when running Native. (that being without Generic and InjectAll kexts).
I came over this gem of explaining the USB-conundrum https://usb-map.gitbook.io/project/

I´m still at work, so I haven´t tested corpnewts USBMap yet. But from my mobos manual my ports tally would be something like:

5x USB 2.0 (2 back 3 mid)
2x USB 3.2 G.1 (back) (working as G.2 w Zen 2)
4x USB 3.2 (mid)
2x USB 3.2 G.2 (back)
2x USB 3.2 G.2 (back)

10 x USB 3.2 = 20 - 5 x USB 2.0 = 5 - Total ports: 25

So mine would end up something like this.
  • HS01
Now the kexts-to-patch would only be this one? Which is patching Apples USBXCHI
AppleUSBXHCI C8000000 83FB02 C8000000 83FB11 algrey USB patch for ryzen

When inspecting hardware->usb I can see 3 x USB 3 Controllers, with devices connected listed underneath. But never more than 2 devices per controller.
So with: MOTU Fastlane, Mouse, Keyboard, Scarlett 2i2, AURA (for whatever reason), and a second mouse just for port checking connected - I am using 6 ports x 2 (as they are all connected to a 3.2 port) for a total tally of 12 ports. But the port limit is 15. so.

Now I feel like I´m just rambling. But I´ll keep cracking on when I get home and check out how or if my USBs are mapping.
And I´ll provide a screenshot.
Post Merged
Hmm. USBMap unable to locate any valid ports. Running native, without USBInjectAll.
Post Merged
I´m using this as kind of a notebook or log now, it thats ok. If not please do tell and I´ll stop.
IOReg finds the following:
Post Merged
Renamed XHC1 to XHC.
WEhDMQ== to WEhDXw==
XHC0 still remains tho. Guessing XHCI to XHC (WEhDSQ== to WEhDXw==) did not work.
And if I´m even on the right track.
Post Merged
Ok. Progress. Or how "Wine makes you do stuff".
Tested every. single. usb. port. with my Scarlet 2i2. Lights up, shows up in Audio Devices. Everything is dandy.
Could also be the changes I made to config.plist.

And I re-added USBInjectAll and XHCI-unsupported.kext

SO what I´ve learned is this:
The Native USB Patch works - to some extent.
No kernel panic, I can see my USB Controllers, USB 3.2, 3.1 and 2.0 ports works.
Every USB device listed or "seen" as a USB-HUB does not.
So my Belkin USB 2.0 hub will not connect, neither will any devices connected to it.
My Apple Keyboard w. numpad has 1 USB port on either side, seen as a hub. Does not work.
The kicker tho. My Yamaha AGO06, which does not have ANY ports and is an audio device will not work. On any port. It is somehow seen as a hub. My 2i2 works flawlessly.

These three devices worked without a hitch with GenericUSBXHCI.kext.

I´m now kinda at a loss, and probably gonna call it a night for today. Any help beyond this is much appreciated.
The "How to fix USB-hubs on 10.13.6" conundrum.
Post Merged
Small update. I now suspect this being something to do with the current avaliable.
Stuck at 500mA. No extra operating current for iPhone. etc.
Post Merged
Upgraded to Mojave to see if the problem persisted. Everything worked. Don´t feel like banging my head against the wall anymore.
Guess I´m off to buy an AMD GPU.
Screen Shot 2019-10-24 at 18.52.58.png
Screen Shot 2019-10-24 at 18.52.58.png (82.04 KiB) Viewed 1819 times
Screen Shot 2019-10-24 at 18.33.17.png
Screen Shot 2019-10-24 at 18.33.17.png (96.37 KiB) Viewed 1819 times
Screen Shot 2019-10-24 at 18.19.03.png
Screen Shot 2019-10-24 at 18.19.03.png (136.45 KiB) Viewed 1820 times
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]