Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
User avatar
by: Shaneee
#45854
Download the following application, https://amd-osx.com/files/IOReg.zip
Save that to file and extract a clean DSDT using Clover. When at Clover boot screen press F4 then boot. Mount EFI and navigate to EFI > EFI > CLOVER > ACPI > origin.

Now upload the saved IOReg file and DSDT.aml from the Clover folder and I'll make a SSDT for you to fix NVME. I had to do the same for mine.

 Advertising

User avatar
by: AlGrey
#45904
@treysig33, @DerJKM, replace your PCI address (can be found in the bootlog generated by clover configurator)
Attachments
unknown.png
unknown.png (54.81 KiB) Viewed 998 times
User avatar
by: Robert Nguyen
#48465
@treysig33 & @DerJKM I've figured it out, hope it can help:
Attachments
Screen Shot 2019-06-02 at 11.48.33 AM.png
Screen Shot 2019-06-02 at 11.48.33 AM.png (613 KiB) Viewed 964 times
Screen Shot 2019-06-02 at 11.48.03 AM.png
Screen Shot 2019-06-02 at 11.48.03 AM.png (62.81 KiB) Viewed 964 times
Screen Shot 2019-06-02 at 11.47.33 AM.png
Screen Shot 2019-06-02 at 11.47.33 AM.png (139.07 KiB) Viewed 964 times
AlGrey, ErikW, e97 liked this
User avatar
by: e97
#52331
Thanks for sharing! Side note: my PciAddr does not match up from the bootlog to DiskUtility but the PCIe root address does
User avatar
by: tikizondo94
#54255
Back to having this issue again. This time with OpenCore Bootloader. I have added my NVMe device properties and added "internal" built in. But still the drive shows as an external in disk utility. Any ideas how to fix this within Opencore?
User avatar
by: Shaneee
#54261
I use a SSDT to fix mine. Is that not what you used on Clover?
User avatar
by: tikizondo94
#54266
I used Clover/Devices/Arbitrary. Added my pci address for my NVME drive then added built-in "1" data. Worked fine within Clover. I dont see any options like this within Opencore. Or maybe im missing something.
User avatar
by: Shaneee
#54268
That's still possible in OpenCore under DeviceProperties.
Code: Select all
	<key>DeviceProperties</key>
	<dict>
		<key>Add</key>
		<dict>
			<key>PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x4)</key>
			<dict>
				<key>AAPL,slot-name</key>
				<string>Internal</string>
			</dict>
		</dict>
		<key>Block</key>
		<dict/>
	</dict>
For example.
tikizondo94 liked this
User avatar
by: tikizondo94
#54270
Im currently using that method but it dosent seem to make a difference. It shows my NVME drive in PCI devices in system report. Thats all. Still shows external in diskutil.
Attachments
(2.01 MiB) Downloaded 27 times
Screen Shot 2020-02-01 at 7.36.26 AM.png
Screen Shot 2020-02-01 at 7.36.26 AM.png (1.5 MiB) Viewed 767 times
User avatar
by: Shaneee
#54271
Send me your DSDT and IOReg output.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]