Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
#41579
I know there is a lot of similar topics here but I think I tried everything before I decided to start a new topic here.
I get very distorted audio from my new Hackintosh. I tried a few USB sound cards I own, same issues. The only exception is when I play some Youtube videos from Safari or Chrome browser, the audio seems fine with only very occasional hiccups.
My hardwares:
  • Ryzen 3 2200G,
    Asrock A320M-HDV with ALC887 HD Audio,
    16GB DDR4 RAM,
    GTX 750 Graphic Card.
Things I have tried:
Installing VoodooHDA,
Changing output settings in Audio MIDI Setup,
Using USB sound cards,
Editing CPU Busratio, Bus speed, Frequency. ( after some research, I think my CPU's Busratio is 35, bus speed at 100,000 KHZ and Frequency at 3,500 MHZ)

Still I am getting distorted audio. I am totally stuck now. Are there any other solutions I haven't tried yet?
Post Merged
I just found another strange thing. With the same MP3 file, if I play it with Quicktime player, the sound is fine without distortions. But play it with iTunes or Preview or VLC, I get very distorted audio. I am so confused now.
Post Merged
Just tried another method to get my music playback working. I have a pair of Airplay speakers and when connected with my Hackintosh the sound is distorted as well! This is driving me crazy.
Post Merged
Just some more information.
I used xlnc's HighSierra installer V2 to install the system.
bloodsucker liked this

 Advertising

#41649
I'm having the same issue on my Ryzen 5 2400g.

VoodooHDA is the only driver I can get any audio output from, audio through safari is fine, but play through iTunes and I get pops and skips and distortion. I also used the v2 installer and I've tried both builds.

Have you overclocked your 2200 in BIOS?

--

Ryzen 5 2400g o/c to 3.8Ghz
MSI B350M Gaming Pro
8GB Corsair 3000Mhz DDR4
NVIDIA GeForce GT 710 1GB
User avatar
by: lexx
#41795
RossNeely wrote:I'm having the same issue on my Ryzen 5 2400g.

VoodooHDA is the only driver I can get any audio output from, audio through safari is fine, but play through iTunes and I get pops and skips and distortion. I also used the v2 installer and I've tried both builds.

Have you overclocked your 2200 in BIOS?

--

Ryzen 5 2400g o/c to 3.8Ghz
MSI B350M Gaming Pro
8GB Corsair 3000Mhz DDR4
NVIDIA GeForce GT 710 1GB
could the overclock be the issue?

im having a similar issue and I have used the bios to overclosk on a asus sabertooth 990fx

thanks
#41807
We think it's an issue in the kernel. The same issue relating to Nvidia performance issues. We are looking into it.
#48342
RossNeely wrote:I'm having the same issue on my Ryzen 5 2400g.

VoodooHDA is the only driver I can get any audio output from, audio through safari is fine, but play through iTunes and I get pops and skips and distortion. I also used the v2 installer and I've tried both builds.

Have you overclocked your 2200 in BIOS?

--

Ryzen 5 2400g o/c to 3.8Ghz
MSI B350M Gaming Pro
8GB Corsair 3000Mhz DDR4
NVIDIA GeForce GT 710 1GB
How did you install VoodooHDA?
#50931
Any updates on this? Would love to have normal audio with my build.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]