Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
User avatar
by: abort
#56011
Hardware:
  • CPU: AMD Ryzen 3900X
  • GPU: Geforce GTX 1070
  • RAM: G.Skill Ripjaws V F4 3600C16D-32GVKC (2x16GB)
  • SSD: Samsung 970 EVO 1TB M.2 NVME (2x)
  • Motherboard: Gigabyte X570 I Aorus Pro Wifi (ITX)
  • Audio Codec: Realtek ALC1220-VB w/ AppleALC (works except for mic as usual)
  • Ethernet Card: Intel i211AT GbE
  • Wifi/BT Card: Intel Wifi 6 802.11ax 2TR2 & BT5 (not using this)
What guide/tool I followed:
OpenCore Vanilla Desktop AMD guide using latest versions and patches for 17h on High Sierra 10.13.6 (due to Geforce).

What part I got an issue with:
Everything works fine except for USB Audio. I have two USB Audio devices (Apogee Duet 2 and Fractal Axe-FX III) and both stutter. All other USB devices work fine and charging works as well. Errors for both devices are similar:
Code: Select all
error	20:44:27.508459 +0100	coreaudiod	HALS_IOA1Engine.cpp:365:EndWriting:  HALS_IOA1Engine::EndWriting: got an error from the kernel trap, Error: 0xE00002D7
default	20:44:27.508510 +0100	QuickLookUIService	HALC_ProxyIOContext.cpp:1068:IOWorkLoop:  HALC_ProxyIOContext::IOWorkLoop: skipping cycle due to overload
default	20:44:27.509882 +0100	kernel	+-IOAudioEngine[<private>]::setState(0x1. oldState=0x3)
default	20:44:27.509887 +0100	kernel	- IOAudioEngine[<private>]::getTimerInterval()
default	20:44:27.509893 +0100	kernel	- IOAudioEngine[<private>]::startAudioEngine() returns 0x0
default	20:44:27.509894 +0100	kernel	- IOAudioEngine[<private>]::incrementActiveUserClients() - 1 returns 0
default	20:44:27.509895 +0100	kernel	- IOAudioEngine[<private>]::startClient(<private>) returns 0x0
default	20:44:27.509897 +0100	kernel	  engine started
default	20:44:27.509897 +0100	kernel	  bufferSet <private>
default	20:44:27.509898 +0100	kernel	  output clientBuffer <private>
default	20:44:27.509899 +0100	kernel	+ IOAudioStream[<private>]::addClient(<private>)
default	20:44:27.509901 +0100	kernel	- IOAudioStream[<private>]::addClient(<private>) returns 0x0
default	20:44:27.509903 +0100	kernel	- IOAudioEngineUserClient[<private>]::startClient() - 1 returns 0x0
default	20:44:27.509904 +0100	kernel	- IOAudioEngineUserClient::externalMethod returns 0x0
default	20:44:27.519269 +0100	kernel	IOAudioEngineUserClient[<private>] - AUDIO OFFLINE. online=1. state=1. loopCount=0, lastLoopTime=0
error	20:44:27.519284 +0100	coreaudiod	HALS_IOA1Engine.cpp:365:EndWriting:  HALS_IOA1Engine::EndWriting: got an error from the kernel trap, Error: 0xE00002D7
default	20:44:27.519324 +0100	QuickLookUIService	HALC_ProxyIOContext.cpp:1068:IOWorkLoop:  HALC_ProxyIOContext::IOWorkLoop: skipping cycle due to overload
default	20:44:27.530018 +0100	kernel	IOAudioEngineUserClient[<private>] - AUDIO OFFLINE. online=1. state=1. loopCount=0, lastLoopTime=0
error	20:44:27.530033 +0100	coreaudiod	HALS_IOA1Engine.cpp:365:EndWriting:  HALS_IOA1Engine::EndWriting: got an error from the kernel trap, Error: 0xE00002D7
default	20:44:27.530069 +0100	QuickLookUIService	HALC_ProxyIOContext.cpp:1068:IOWorkLoop:  HALC_ProxyIOContext::IOWorkLoop: skipping cycle due to overload
default	20:44:27.540772 +0100	kernel	IOAudioEngineUserClient[<private>] - AUDIO OFFLINE. online=1. state=1. loopCount=0, lastLoopTime=0
error	20:44:27.540786 +0100	coreaudiod	HALS_IOA1Engine.cpp:365:EndWriting:  HALS_IOA1Engine::EndWriting: got an error from the kernel trap, Error: 0xE00002D7
default	20:44:27.540822 +0100	QuickLookUIService	HALC_ProxyIOContext.cpp:1068:IOWorkLoop:  HALC_ProxyIOContext::IOWorkLoop: skipping cycle due to overload
default	20:44:27.551693 +0100	coreaudiod	HALS_OverloadMessage.cpp:159:perform:  Audio IO Overload inputs: '' outputs: 'AppleUSBAudioEngine:Fractal Audio Systems:Axe-Fx III:000:1,2' cause: 'Unknown' prewarming: no recovering: no
What files/config I am using:
OpenCore 0.5.6 with latest patches for Threadripper and completely according to the guide. All Kexts are up to date. Dumped DSDT in windows using acpitool. OpenCore EFI OC folder structure:
Code: Select all
├── ACPI
│   ├── DSDT.aml
│   ├── SSDT-EC-USBX-AMD.aml
│   ├── SSDT-HPET.aml
│   ├── SSDT-NVME.aml
│   ├── SSDT-PLUG.aml
│   ├── SSDT-SBRG.aml
│   ├── SSDT-UIAC.aml
│   ├── SSDT-XHC.aml
│   ├── SSDT-XOSI.aml
├── Drivers
│   ├── ApfsDriverLoader.efi
│   ├── AudioDxe.efi
│   ├── FwRuntimeServices.efi
│   └── VBoxHfs.efi
├── Kexts
│   ├── AppleALC.kext
│   ├── Lilu.kext
│   ├── NVMeFix.kext
│   ├── SMCAMDProcessor.kext
│   ├── SmallTreeIntel82576.kext
│   ├── USBPorts.kext
│   ├── VirtualSMC.kext
│   └── WhateverGreen.kext
├── OpenCore.efi
├── Tools
└── config.plist
What I have tried:
  • My mainboard has no EC device, hence create a fake EC device using an SSDT file and the USBX device so that USB power is sufficient.
  • Use (and not use) default SSDT-EC-USBX-AMD
  • With and without SSDTs (different permutations)
  • With and without custom USB port mapping following the Vanilla AMD USB Mapping Guide
  • Remove Bluetooth/Wifi from custom USB port mapping
  • Map all USB3 ports to only USB2
  • Enable/disable XHCI port limit
  • Enable/disable 4g decoding (and then adding npci=0x2000 bootflag)
  • Enable/disable Ethernet
  • Enable/disable automatic time synchronization
  • Disable and remove bluetooth stack from OS
  • Replace AppleUSBAudio.kext with one from Mojave
  • Enable/disable XHCI Handoff
  • Enable/disable Legacy USB
  • Enable/disable Turbo / PBO
  • Enable/disable CPU Spread Spectrum
  • Fix CPU/memory multipliers rather than auto
  • Disable/Enable XMP
  • Use different memory frequencies
  • Force cpu frequency in bootargs
  • Increase voltages (SoC, VDDG, VDDP)
  • Switch format in midi setup to 44,1KHz and 48KHz
  • Reinstall High Sierra
  • Switch SMBios to various different ones (currently on iMac14,2)
  • Clear kext cache/nvram
  • Disabled serial port (don't have one ;))
  • Tried two latest BIOS versions (F11 and F12e)
  • Try different USB ports
Is there anybody with any ideas on how to solve this, given the extensive list above? Thanks in advance.

 Advertising

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]