Welcome to AMD OS X

Why not register now to gain full access.

General chat and support for running on a Virtual Machine.
This works with VMware Player 14, a free download from VMware, you can get it here:
Code: Select all
Download Links
Code: Select all
   VMDK https://drive.google.com/file/d/1vffD6q_fr-AAUYQ_DX3DLR-aLCnMsZkg/view?usp=sharing
The new VMWare tools from a good poster zzmadd is attached to the bottom of this post:

You need to enable root to run the vmware utility, here's how:
Code: Select all

Then you need to add the following to your VMs VMX file at the bottom:
Code: Select all
 svga.minVRAMSize = 8388608 

Now you need to change the resolution and here's how:

Code: Select all
Open Terminal, then change directory by entering cd "/Library/Application Support/VMware Tools/", include the ""s because the directory names have spaces in them.

Now you need to enter SU and then enter the password you set for root.
Once you do that you enter:  ./vmware-resolutionSet 1920 1080.

The 1920 is the height and the 1080 is the width.  Set it to what you need.

You will not want to go full screen, in my testing full screen resets the resolution back to default.

Now shutdown and restart the VM to test your new resolution.
(2.44 MiB) Downloaded 1137 times
Shaneee, Bloo, fsagent and 1 others liked this


User avatar
by: Chengzhir
Hi, I installed on my virtual machine failed.After creating a virtual machine,it does not open normally.(The above is Google translation, I do not understand English)
CPU:ryzen5 1600x
GPU:GTX 1080
User avatar
by: Norton287
Did you configure it according to the post for the VM?
User avatar
by: DragonSky
Same here. I've followed the instructions carefully but VMWare keeps restarting and never goes to the setup screen. I have an Ryzen 3 1300X if that helps.
User avatar
by: Norton287
Where does it restart at can you give me an example to troubleshoot.
Post Merged
Are you using VMWare Player 12 or VMWorkstation? Did you upgrade the hardware on the VM if you're using Workstation?
User avatar
by: skazord
Doesn't work for me.
Code: Select all
2017-11-28T00:40:10.803Z| vcpu-0| I125: AHCI: Tried to enable/disable IO space.
2017-11-28T00:40:10.803Z| vcpu-0| I125: AHCI-VMM:HBA reset issued on sata0.
2017-11-28T00:40:10.816Z| vcpu-1| I125: CPU reset: soft (mode 2)
2017-11-28T00:40:10.835Z| vcpu-0| I125: BIOS-UUID is 56 4d d5 8b e2 15 82 07-6c ae f5 70 d8 28 eb 4e
2017-11-28T00:40:11.360Z| vcpu-0| I125: Triple fault.
2017-11-28T00:40:11.360Z| vcpu-0| I125: MsgHint: msg.monitorEvent.tripleFault
2017-11-28T00:40:11.360Z| vcpu-0| I125+ A fault has occurred causing a virtual CPU to enter the shutdown state. If this fault had occurred outside of a virtual machine, it would have caused the physical machine to restart. The shutdown state can be reached by incorrectly configuring the virtual machine, a bug in the guest operating system, or a problem in VMware Player.---------------------------------------
2017-11-28T00:40:12.341Z| vmx| I125: Stopping VCPU threads...
2017-11-28T00:40:12.341Z| vcpu-0| I125: CPU reset: hard (mode 2)
2017-11-28T00:40:12.342Z| vcpu-1| I125: CPU reset: hard (mode 2)
2017-11-28T00:40:13.343Z| svga| I125: SVGA thread is exiting
Ryzen 5 1600
Gigabyte AB350 Gaming 3
R9 390
Using VMWare Player 12

Followed the guide provided line by line, even used the exact same parameters (RAM, CPUs, etc). It's worth noting that this is the exact same error I got with the 10.12.6 versions floating around.
Really bummed that this doesn't work, I needed an updated Xcode to work on my main PC, and will be instead forced to use it on a 5 year old laptop with little memory that struggles to emulate the phone :/ Thanks for the effort though, if you need more info, I can post the full log.
User avatar
by: petrigno
Hi, please split the file into several parts because it's the 6th time i unload it and I always get some decompression errors at different points of the file if you divide it if anything else we should just download the corrupt part, thank you
User avatar
by: Norton287
I'm trying a fix for ryzen users, will give an update tomorrow
Post Merged
I need someone to download VMware Player 14 and install the VM but when asked to upgrade the VM choose Yes and then try to run.
skazord liked this
User avatar
by: skazord
Norton287 wrote:I'm trying a fix for ryzen users, will give an update tomorrow
Post Merged
I need someone to download VMware Player 14 and install the VM but when asked to upgrade the VM choose Yes and then try to run.
I'm not home right now, but I'll try later tonight and give feedback.
User avatar
by: Norton287
Ok thanks very much
  • 1
  • 2
  • 3
  • 4
  • 5
  • 15
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]