Welcome to AMD OS X

Why not register now to gain full access.

Important News and Announcements are found here.
User avatar
by: whid0t
@Shaneee can you help me please!
Can i install macOS on my Windows 10 laptop.
CPU: AMD A6-9220 APU with radeon r4


User avatar
by: AlGrey
@whid0t, off topic. Make a new thread next time. Answer is no you can't. iGPUs are not supported.
User avatar
by: carloscheddar
I'm also experiencing the IOService.cpp:2289 panic that 34313 reported. It happens whenever I disconnect devices from the front USB ports.
Code: Select all
Anonymous UUID:       195D565C-E1BA-3555-DA7F-F287432FFA8D

Sat Jul 28 18:20:23 2018

*** Panic Report ***
panic(cpu 4 caller 0xffffff8010892b3c): "Razer BlackWidow Ultimate 2013[0x10000039d]::terminate(kIOServiceSynchronous) timeout\n"@/xnu-4570.41.2/iokit/Kernel/IOService.cpp:2289
Backtrace (CPU 4), Frame : Return Address
0xffffff81f61aba30 : 0xffffff80102ea2e6 
0xffffff81f61aba80 : 0xffffff8010415f74 
0xffffff81f61abac0 : 0xffffff8010407974 
0xffffff81f61abb30 : 0xffffff801029d120 
0xffffff81f61abb50 : 0xffffff80102e9d1c 
0xffffff81f61abc80 : 0xffffff80102e9a9c 
0xffffff81f61abce0 : 0xffffff8010892b3c 
0xffffff81f61abd30 : 0xffffff80108965e7 
0xffffff81f61abdb0 : 0xffffff7f910b0808 
0xffffff81f61abdd0 : 0xffffff7f92fe7f2b 
0xffffff81f61abe10 : 0xffffff7f92fee271 
0xffffff81f61abe50 : 0xffffff7f92feee1d 
0xffffff81f61abeb0 : 0xffffff7f92fe6e99 
0xffffff81f61abed0 : 0xffffff8010323ab4 
0xffffff81f61abf40 : 0xffffff80103235a5 
0xffffff81f61abfa0 : 0xffffff801029c4f7 
      Kernel Extensions in backtrace:
            dependency: com.apple.iokit.IOPCIFamily(2.9)[8E6C654E-4A8F-3C6B-BBFE-BA8A68C9C146]@0xffffff7f90a85000
            dependency: com.apple.iokit.IOUSBHostFamily(1.2)[8398A8CC-6560-38E5-B061-C4EEB6B2E1D9]@0xffffff7f90fca000
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[E768F6C8-F7ED-3AA5-AB26-03284841965E]@0xffffff7f90fc2000
            dependency: com.apple.iokit.IOUSBFamily(900.4.1)[FD04D3BC-D376-36FD-924C-DD5DF51B0509]@0xffffff7f91073000

BSD process name corresponding to current thread: kernel_task
Boot args: -gux_defer_usb2 busratio=39 npci=0x3000 -xcpm -v darkwake=1 

Mac OS version:

Kernel version:
Darwin Kernel Version 17.4.0: Tue 24 Jul 2018 13:55:36 BST; ~ Shaneee ~ :xnu-4570.41.2/BUILD/obj/RELEASE_X86_64
Kernel UUID: AF028794-8DED-3A11-A261-E4E26558FAAD
Kernel slide:     0x0000000010000000
Kernel text base: 0xffffff8010200000
__HIB  text base: 0xffffff8010100000
System model name: iMac17,1 (Mac-B809C3757DA9BB8D)

System uptime in nanoseconds: 4501159396089
last loaded kext at 3475012839607: com.apple.driver.AudioAUUC	1.70 (addr 0xffffff7f95893000, size 28672)
last unloaded kext at 3962587728663: com.apple.driver.AppleXsanScheme	3 (addr 0xffffff7f9588b000, size 32768)
loaded kexts:
org.virtualbox.kext.VBoxNetAdp	5.2.8
org.virtualbox.kext.VBoxNetFlt	5.2.8
org.virtualbox.kext.VBoxUSB	5.2.8
org.virtualbox.kext.VBoxDrv	5.2.8
com.tuxera.filesystems.tuxera_ntfs	2017.12.18
com.insanelymac.AtherosE2200Ethernet	2.2.1
org.voodoo.driver.VoodooHDA	2.9.0d10
net.osrom.kext.Disabler	1.0.1
net.osx86.kexts.GenericUSBXHCI	1.2.11
as.vit9696.AppleALC	1.3.0
as.vit9696.WhateverGreen	1.1.6
as.vit9696.Lilu	1.2.5
com.rehabman.driver.USBInjectAll	0.6.4
org.netkas.driver.FakeSMC	1723
org.tgwbd.driver.NullCPUPowerManagement	1.0.0d2
com.apple.driver.AppleUpstreamUserClient	3.6.4
com.apple.driver.AppleMCCSControl	1.5.3
com.apple.kext.AMDFramebuffer	1.6.0
com.apple.filesystems.msdosfs	1.10
com.apple.filesystems.exfat	1.4
com.apple.kext.AMDRadeonX4250	1.6.0
com.apple.AGDCPluginDisplayMetrics	3.16.2
com.apple.driver.AppleHV	1
com.apple.iokit.IOUserEthernet	1.0.1
com.apple.iokit.IOBluetoothSerialManager	6.0.2f2
com.apple.kext.AMD9500Controller	1.6.0
com.apple.Dont_Steal_Mac_OS_X	7.0.0
com.apple.driver.AppleOSXWatchdog	1
com.apple.driver.AppleIntelSlowAdaptiveClocking	4.0.0
com.apple.driver.ACPI_SMC_PlatformPlugin	1.0.0
com.apple.filesystems.hfs.kext	407.30.1
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless	1.0.0d1
com.apple.BootCache	40
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0
com.apple.filesystems.apfs	748.41.3
com.apple.driver.AppleUSBLegacyHub	900.4.1
com.apple.driver.AppleAHCIPort	329
com.apple.driver.AppleACPIButtons	6.1
com.apple.driver.AppleRTC	2.0
com.apple.driver.AppleSMBIOS	2.1
com.apple.driver.AppleAPIC	1.7
com.apple.nke.applicationfirewall	183
com.apple.security.TMSafetyNet	8
com.apple.security.quarantine	3
com.apple.IOBufferCopyEngineTest	1
com.apple.driver.AppleIntelCPUPowerManagement	220.0.0
com.apple.iokit.IOUSBMassStorageClass	4.0.4
com.apple.iokit.IOUSBUserClient	900.4.1
com.apple.driver.AppleUSBHostMergeProperties	1.2
com.apple.driver.AppleSMBusController	1.0.18d1
com.apple.iokit.IOSMBusFamily	1.1
com.apple.kext.triggers	1.0
com.apple.driver.AppleSSE	1.0
com.apple.iokit.IOSerialFamily	11
com.apple.iokit.IOBluetoothFamily	6.0.2f2
com.apple.kext.AMDRadeonX4000HWLibs	1.0
com.apple.iokit.IOAcceleratorFamily2	376.6
com.apple.iokit.IOSurface	209.2.2
com.apple.kext.AMDSupport	1.6.0
com.apple.AppleGPUWrangler	3.16.2
com.apple.AppleGraphicsDeviceControl	3.16.21
com.apple.kext.AMDRadeonX4000HWServices	1.6.0
com.apple.iokit.IOSlowAdaptiveClockingFamily	1.0.0
com.apple.iokit.IOGraphicsFamily	517.22
com.apple.driver.IOPlatformPluginLegacy	1.0.0
com.apple.driver.IOPlatformPluginFamily	6.0.0d8
com.apple.iokit.IOUSBHIDDriver	900.4.1
com.apple.driver.CoreStorage	546
com.apple.driver.AppleLegacyUSBAudio	2.9.5f19
com.apple.driver.AppleUSBComposite	900.4.1
com.apple.filesystems.hfs.encodings.kext	1
com.apple.driver.usb.AppleUSBHostPacketFilter	1.0
com.apple.iokit.IOAHCIBlockStorage	301.40.2
com.apple.iokit.IOAudioFamily	206.5
com.apple.vecLib.kext	1.2.0
com.apple.iokit.IOUSBFamily	900.4.1
com.apple.iokit.IOAHCIFamily	288
com.apple.driver.AppleEFINVRAM	2.1
com.apple.driver.AppleEFIRuntime	2.1
com.apple.iokit.IOHIDFamily	2.0.0
com.apple.security.sandbox	300.0
com.apple.kext.AppleMatch	1.0.0d1
com.apple.iokit.IOBufferCopyEngineFamily	1
com.apple.driver.DiskImages	480.30.2
com.apple.driver.AppleFDEKeyStore	28.30
com.apple.driver.AppleEffaceableStorage	1.0
com.apple.driver.AppleKeyStore	2
com.apple.driver.AppleUSBTDM	439.30.4
com.apple.driver.AppleMobileFileIntegrity	1.0.5
com.apple.iokit.IOUSBMassStorageDriver	140.30.1
com.apple.iokit.IOSCSIBlockCommandsDevice	404.30.2
com.apple.iokit.IOSCSIArchitectureModelFamily	404.30.2
com.apple.iokit.IOStorageFamily	2.1
com.apple.driver.AppleCredentialManager	1.0
com.apple.driver.KernelRelayHost	1
com.apple.iokit.IOUSBHostFamily	1.2
com.apple.driver.usb.AppleUSBCommon	1.0
com.apple.driver.AppleBusPowerController	1.0
com.apple.driver.AppleSEPManager	1.0.1
com.apple.driver.IOSlaveProcessor	1
com.apple.iokit.IOReportFamily	31
com.apple.iokit.IOTimeSyncFamily	650.5
com.apple.iokit.IONetworkingFamily	3.4
com.apple.driver.AppleACPIPlatform	6.1
com.apple.driver.AppleSMCRTC	1.0
com.apple.driver.AppleSMC	3.1.9
com.apple.iokit.IOPCIFamily	2.9
com.apple.iokit.IOACPIFamily	1.4
com.apple.kec.pthread	1
com.apple.kec.Libm	1
com.apple.kec.corecrypto	1.0

Model: iMac17,1, BootROM IM171.0148.B00, 16 processors, 3.9 GHz, 16 GB, SMC 2.33f10
Graphics: Radeon RX 580, Radeon RX 580, PCIe, 8 GB
Memory Module: BANK 0/DIMM0, 8 GB, DDR4, 3200 MHz, Unknown, F4-3200C14-8GTZR
Memory Module: BANK 1/DIMM0, 8 GB, DDR4, 3200 MHz, Unknown, F4-3200C14-8GTZR
Network Service: Ethernet, Ethernet, en0
Serial ATA Device: SAMSUNG HM100UI, 1 TB
Serial ATA Device: WDC WD1002FAEX-00Z3A0, 1 TB
Serial ATA Device: WDC WD2002FAEX-007BA0, 2 TB
Serial ATA Device: Samsung SSD 850 EVO 500GB, 500.11 GB
USB Device: HD Pro Webcam C920
USB Device: Keyboard - MDErgo1 PartialMap pjrcUSB full
USB Device: USB Modi Device
USB Device: Gaming Mouse G502
Thunderbolt Bus: 
Edit: Fixed it by removing generic usb and using native usb from this post.
User avatar
by: tikizondo94
@Shaneee Your latest Ryzen kernel is killing it! Updated to 10.13.5 without a stutter. Some of the best performance my machine has had on OSX to date. Even Sleep is working properly! Amazing! Again, Thank you for all your hard work. Its much appreciated!
Shaneee liked this
User avatar
by: hoeman
tikizondo94 wrote: Mon Jul 30, 2018 7:47 pm @Shaneee Your latest Ryzen kernel is killing it! Updated to 10.13.5 without a stutter. Some of the best performance my machine has had on OSX to date. Even Sleep is working properly! Amazing! Again, Thank you for all your hard work. Its much appreciated!
Could you detail the steps to update to 10.13.5? I installed using highsierrav3 unofficial and I'm using 10.13.3 but I'm keen to update to 10.13.5 with the new kernel. Could you teach me?
User avatar
by: tikizondo94
hoeman wrote: Tue Jul 31, 2018 9:28 am
tikizondo94 wrote: Mon Jul 30, 2018 7:47 pm @Shaneee Your latest Ryzen kernel is killing it! Updated to 10.13.5 without a stutter. Some of the best performance my machine has had on OSX to date. Even Sleep is working properly! Amazing! Again, Thank you for all your hard work. Its much appreciated!
Could you detail the steps to update to 10.13.5? I installed using highsierrav3 unofficial and I'm using 10.13.3 but I'm keen to update to 10.13.5 with the new kernel. Could you teach me?

Sure. Update to the Shaneees latest kernel first. Then i followed the instructions posted here ...
User avatar
by: myname71
Installed today the new kernel provided by Shanee, everything works fine.
Many thanks Shanee for your work

Inviato dal mio WAS-LX1A utilizzando Tapatalk

User avatar
by: collector43
Hi so I was trying to update from V3 - 10.13.3 to 10.13.4.

Steps I took

1 I updated to the newest kernel according to instruction in the first post.

2. I run the 10.13.4 combo update from the desktop.

3. Installation started and did soft reset.

4. I booted into AMD high sierra USB .

5. Get stuck on kextd stall (picture attached)
232A3E82-9BD9-4853-9587-17E2D1E3D86D.jpeg (2.83 MiB) Viewed 975 times
232A3E82-9BD9-4853-9587-17E2D1E3D86D.jpeg (2.83 MiB) Viewed 975 times
....Ohh wait sorry it just went through .

1 . Ok so since it went through I went to the terminal and did preinstall and restarted.

2. I went to “installation from YOUR HDD/SSD name” NOT from “boot from YOUR HDD/SSD name)

3. I booted to start from YOUR HD/SSD name

This just rebooted itself

4. Booting to AMD High sierra usb again. It is stalling again but went through.

5. I went to the terminal and did the “amd” command. It saying current is 10.13.2
And Targeted 10.13.3

Did update not install?
Post Merged
Ok great I f***** my system again

Can someone post a proper step by step way to update from 10.13.3 to 10.13.4 or .5 please
User avatar
by: AlGrey
@collector43, 10.13.4 and 10.13.5 need kexts rolled back. Better to wait on updated kernel.
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 8
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]