Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
#29119
I have the ASRock A88M-G/3.1 with the Realtek ALC1150 audio chip. It worked fine with Yosemite and VoodooHDA 2.88. With Sierra the sound is choppy and stutters regardless of what audio program (VLC/JRivers/itunes etc). I tried VoodooHDA 2.88, 2.89 and 2.90R10 and all do the same thing. And yes AppleHDADisabler.kext is installed and its prefpane.
Got everything working great except this!
Any ideas?

Thanks!

 Advertising

#29169
Tried the fix on that video and it made no difference at all. What I am getting is not a 'crackly' sound as described in that fix. I am getting a skipping/choppy/stuttering sound as if it can't fill a buffer fast enough to keep up.
The problem doesn't seem to even be in VoodooHDA as I tried my EMU USB sound card and its own driver and it does the same thing also. It doesn't matter what program or source. Does the same if the sound file is locally on the hard drive or off the net such as Youtube.
So I have a 2nd computer with a different Motherboard, CPU and sound chip and tried it there and it does the same thing also. So its not something peculiar to the hardware.
I also tried installing Bronya's new kernel and system.kext and that didn't change it either.
This sucks because one of the computers is my music server so this problem makes it useless.
Any ideas would be greatly appreciated.
#29171
Forgot you're using enoch or I'd say its busratio is off, the only audio bootflag I can find is HDAEnabler=Yes. This does automatic device-properties generation for audio controllers.
#29190
I have it so I can boot it either with Clover or Enoch. Its just Clover won't boot Linux.
When I boot it with Clover it still does the same thing. No change at all.
The busratio should be ok as the clock keeps proper time even after several days running.
The audio was fine with Yosemite and I used it daily for music.
HDAEnabler=Yes was already present and removing it made no difference.
#29193
Try copying the AppleHDA.kext from El Capitan and installing it with kext utility and see if that helps.
Post Merged
Here's the kext from my el capitan install. uninstall VoodooHDA and install this with kext utility and see if helps.
Attachments
(1.64 MiB) Downloaded 18 times
#29268
That didn't help either. I also tried one from Yosemite and that didn't work either. I tried removing AppleHDDisable and all the VoodooHDA stuff and tried it with just my USB EMU card and its drivers and still same problem.
This is repeatable on 2 computers, both AMD but different Motherboards, CPU's and sound chips but exact same problem.


Dave
#29272
VLC, JRivers MediaCenter22, iTunes. Browsers play video properly but same problem with audio. Tried Safari, Chrome and Vivaldi. Same problem whether streaming online or playing MP3 or Flac etc from the local hard drive etc. Problem also occurs running Foobar2000 under Wine. Never had this problem with Yosemite.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]