Page 3 of 4

Re: AMD APU A8 Graphics Problem - R7 Graphics and Radeon RX570

Posted: Sun May 21, 2017 4:51 pm
by vitorlage
That's cause graphic card still has no acceleration. And showing RX 470 is normal too
Have you replaced AMD9510Controller.kext again with Kext Utility ?
Can you attach your config.plist please ?

Re: AMD APU A8 Graphics Problem - R7 Graphics and Radeon RX570

Posted: Sun May 21, 2017 6:53 pm
by Shaneee
You're booting with the cable connected to the integrated and once boot has completed swap over to the RX card?

Re: AMD APU A8 Graphics Problem - R7 Graphics and Radeon RX570

Posted: Mon May 22, 2017 2:03 am
by DiegoPaidjo
@vitorlage, i have to try installed kext several times, but still showing vram 3 or 4 mb.
yes, i'll upload my config.plist soon, wheres i found config.plist ? im using enoch bootloader .is in EFI/Boot/config.plist ?

@Shaneee, i have to trying as your suggestion, when i switch card from integrated to RX card monitor have no signal.

Re: AMD APU A8 Graphics Problem - R7 Graphics and Radeon RX570

Posted: Mon May 22, 2017 7:44 am
by vitorlage
DiegoPaidjo wrote: @Shaneee, i have to trying as your suggestion, when i switch card from integrated to RX card monitor have no signal.
Try to change settings in BIOS to boot from RX 570, even if you have to boot blind (memorise the steps you have to do in the dark. lol

Question: Is your connection to the monitor VGA ?
I use my TV as monitor on HDMI
and the other monitor i have is VGA.
don't know how I am going to manage if i have to set IGFX as primary.


Connect your tv to the motherboard (primary) before you hit the enter command to boot up, switch the hdmi to the card slot and then hit enter. It will be a black screen until it gets to log in. You should be able to use your board HDMI to get in and get support if its working. It just won't get acceleration unless its connected to the card during the boot up. Do you have a HDMI port on the motherboard? If you do, use the board slot until you get the "supported" status through experimentations on/with the card and then boot with the card connected to HDMI.

I don't have a HDMI port on motherboard
only 1 VGA port.
When I boot with VGA connected AMDRadeonX4000 kext is loaded but cant hotswitch to hdmi

BEFORE you hit enter switch the cable to the card THEN hit enter. If you try switching the cable after boot you probably won't get detection to load the card bios in Sierra and won't get any results.

If you have the VGA connected to a monitor and the TV HDMI to the card you may want to try disconnecting the VGA plug before you hit enter to boot.

Re: AMD APU A8 Graphics Problem - R7 Graphics and Radeon RX570

Posted: Tue May 23, 2017 2:47 am
by DiegoPaidjo
@vitorlage, Im using HDMI Cable to TV Monitor.
In motherboard have HDMI port for IGFX,
Im trying your advice, setting bios to IGFX as primary. --> hdmi cable connected to motherboard --> show up hardisk boot selection (osx selected) --> switch hdmi cable from motherboard to rx card --> i hit enter ----> waiting for 1 hour still no signal , and i try to switch again from rx card to motherboard has no signal too.
is my steps right ?

Re: AMD APU A8 Graphics Problem - R7 Graphics and Radeon RX570

Posted: Tue May 23, 2017 1:42 pm
by vitorlage
@DiegoPaidjo, Oh well, I've tried to understand what other users with the same issue managed to do. Because I don't have one of those cards I can't test.
You can try this
Code: Select all
Good news at least :)

I reinstalled sierra 10.12.3 last night. And I did the process like you said step by step. It works now without problem. Sooo smooth. Thank you for share and help.

I want to warn fellas about my mistakes which are possible to make for everyone.

1) before the process, you should remove your graphics card completely and plug your monitor with output of mobo. Thats important.
2) open your OSX with your Integrated graphics processor NOT PEG!
3) do the process and after complete don't restart. Turn your pc off.
4) install graphics card. and put your cable to GPU, don't change IGP to PEG!, do the rest.

Now I have just one question left. When I move mouse cursor to right of the screen, It disappers. Probably It goes to the second screen. When I try to make monitors as mirror, Black screen comes. How can I put limit to right side of the monitor to block cursor?

Re: AMD APU A8 Graphics Problem - R7 Graphics and Radeon RX570

Posted: Tue May 23, 2017 7:14 pm
by Shaneee
Let the system boot with the iGPU connected. Once it's booted swap the cable over.

Re: AMD APU A8 Graphics Problem - R7 Graphics and Radeon RX570

Posted: Tue May 30, 2017 7:38 pm
by DiegoPaidjo
Finally,
my Graphics can detected with full VRAM.
Thank you @Shaneee and @vitorlage for helping. :thumbup: :thumbup:

but, i get this error :
Code: Select all
Kernel overflows available space
This is a non recoverable error! SYSTEM HALTED!
i think i need to install again, but i hope my graphics can work again.

btw, my sound (HDMI) not working. and can i using TP-LINK WN727n on hackintosh ??

Re: AMD APU A8 Graphics Problem - R7 Graphics and Radeon RX570  Topic is solved

Posted: Tue May 30, 2017 7:58 pm
by vitorlage
@DiegoPaidjo, For the HDMI try this fix
For TP-LINK WN727n download Bear Extender
Code: Select all
http://www.mediafire.com/file/sxlch8w8zxl0o8i/BearExtender-5.4.dmg
Has no official drivers, so I followed those steps and it works very well now.
1- Disable SIP. (boot into recovery mode -> open a terminal -> enter "csrutil disable" -> reboot )
2- Install Bear extender wifi utility (BearExtender-5.4.dmg), It has 3 packages inside the DMG, u will have to reboot twice in the process, but don't reboot the third time. wait till u do the next step then reboot.
3- Install RT2870 USBWirelessDriver KExt using "Kext Utility" or a similar app.
4- Reboot.
After that u will notice there is an icon of 5 dots on the top bar like this picture:
Screen%2BShot%2B2015-10-17%2Bat%2B7.55.1
click on it to open the "bear extender" wifi utility, and u can search for networks, add them to favorites, connect, disconnect and everything. B)
If u want to add a static IP or a custom DNS, u're gonna have to do it from System preferences -> Network -> 802.11n wlan USB. then edit whatever u want and click apply. I will upload screenshots for this step when I boot back into OSX.

Re: AMD APU A8 Graphics Problem - R7 Graphics and Radeon RX570

Posted: Thu Jun 01, 2017 9:36 am
by DiegoPaidjo
vitorlage wrote: Tue May 30, 2017 7:58 pm @DiegoPaidjo, For the HDMI try this fix
For TP-LINK WN727n download Bear Extender
Code: Select all
http://www.mediafire.com/file/sxlch8w8zxl0o8i/BearExtender-5.4.dmg
Has no official drivers, so I followed those steps and it works very well now.
1- Disable SIP. (boot into recovery mode -> open a terminal -> enter "csrutil disable" -> reboot )
2- Install Bear extender wifi utility (BearExtender-5.4.dmg), It has 3 packages inside the DMG, u will have to reboot twice in the process, but don't reboot the third time. wait till u do the next step then reboot.
3- Install RT2870 USBWirelessDriver KExt using "Kext Utility" or a similar app.
4- Reboot.
After that u will notice there is an icon of 5 dots on the top bar like this picture:
Screen%2BShot%2B2015-10-17%2Bat%2B7.55.1
click on it to open the "bear extender" wifi utility, and u can search for networks, add them to favorites, connect, disconnect and everything. B)
If u want to add a static IP or a custom DNS, u're gonna have to do it from System preferences -> Network -> 802.11n wlan USB. then edit whatever u want and click apply. I will upload screenshots for this step when I boot back into OSX.
I try install hdmi sound and still not working for me,
can you tell me how to boot into recovery mode ?
i have disk named recovery hd, but i cant boot into these drive.