Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.

- NZXT H210i
- Ryzen 3600X
- Aorus X570i pro wifi (replaced wifi with DW 1560 Broadcom card)
- Sabrent Rocket 500GB NVME 4.0
- MSI RX 5500 XT OC
- Corsair LPX DDR4 3200 2x16gb
- Corsair SFX 450

Still running F5, need to update to latest (F11)

Clover was an utter failure, I could never get it to boot past a cryptic "AMFonly 175/256 slide values are usable" error.
Did some reading and found that Clover doesn't support 10.15.2 yet.

Found some online resources for setting up OC and took off. Right out of the box I had install issues with the NVME drive in the M.2 prime slot under the the heat sink, I had to move it to the secondary slot on the back. I kept getting errors saying it an external drive. Once I did that install completed without issues.

Took a while to the get WiFi and BT working, but with the addition of some kexts it was up and running by last evening, and works great...

Radeon 5500!


Boot Options:
-v npci=0x2000 debug=0x100 keepsyms=1 agdpmod=pikera

WHAT's Busted:
-NVME on slot A shows up as external
-After a few minutes of inactivity, maybe 5-10, I get a kernel panic :( . Its the last issue to get sorted before I can call it a success.

Here's the Panic:
panic(cpu 4 caller 0xffffff801aa6520a): Kernel trap at 0xffffff7f9be47adf, type 14=page fault, registers:
CR0: 0x0000000080010033, CR2: 0x0000000000000040, CR3: 0x00000006cee82000, CR4: 0x00000000003406e0
RAX: 0xffffff835bb84260, RBX: 0x0000000000000000, RCX: 0x0000000000000000, RDX: 0xffffff835bb84260
RSP: 0xffffff83d1b1b870, RBP: 0xffffff83d1b1b8b0, RSI: 0xffffff8063922e00, RDI: 0x0000000000000000
R8: 0x0000000000000000, R9: 0x0000000000000000, R10: 0xffffff7f9bd62104, R11: 0xffffff806c99060c
R12: 0xffffff801b41cae8, R13: 0xffffff8063922e00, R14: 0xffffff8063922000, R15: 0x0000000000000000
RFL: 0x0000000000010282, RIP: 0xffffff7f9be47adf, CS: 0x0000000000000008, SS: 0x0000000000000010
Fault CR2: 0x0000000000000040, Error code: 0x0000000000000000, Fault CPU: 0x4, PL: 0, VF: 0

Backtrace (CPU 4), Frame : Return Address
0xffffff83d1b1b2d0 : 0xffffff801a93bb1b mach_kernel : _handle_debugger_trap + 0x47b
0xffffff83d1b1b320 : 0xffffff801aa733e5 mach_kernel : _kdp_i386_trap + 0x155
0xffffff83d1b1b360 : 0xffffff801aa64e5e mach_kernel : _kernel_trap + 0x4ee
0xffffff83d1b1b3b0 : 0xffffff801a8e2a40 mach_kernel : _return_from_trap + 0xe0
0xffffff83d1b1b3d0 : 0xffffff801a93b207 mach_kernel : _DebuggerTrapWithState + 0x17
0xffffff83d1b1b4d0 : 0xffffff801a93b5eb mach_kernel : _panic_trap_to_debugger + 0x21b
0xffffff83d1b1b520 : 0xffffff801b0d24f9 mach_kernel : _panic + 0x61
0xffffff83d1b1b590 : 0xffffff801aa6520a mach_kernel : _sync_iss_to_iks + 0x2aa
0xffffff83d1b1b710 : 0xffffff801aa64f08 mach_kernel : _kernel_trap + 0x598
0xffffff83d1b1b760 : 0xffffff801a8e2a40 mach_kernel : _return_from_trap + 0xe0
0xffffff83d1b1b780 : 0xffffff7f9be47adf com.apple.kext.AMDRadeonX6000 : __ZN31AMDRadeonX6000_AMDAccelResource18fillUBMSurfaceInfoEP13_UBM_SURFINFOP22_sMASK_MEMORY_SETTINGSjjj + 0x17
0xffffff83d1b1b8b0 : 0xffffff7f9be586d0 com.apple.kext.AMDRadeonX6000 : __ZN35AMDRadeonX6000_AMDAccelVideoContext22processGraphicsCommandER24IOAccelCommandStreamInfo + 0x680
0xffffff83d1b1b9d0 : 0xffffff7f9bd6502e com.apple.iokit.IOAcceleratorFamily2 : __ZN15IOAccelContext221processSidebandBufferEP24IOAccelCommandDescriptorb + 0x10c
0xffffff83d1b1ba10 : 0xffffff7f9bd65561 com.apple.iokit.IOAcceleratorFamily2 : __ZN15IOAccelContext218processDataBuffersEj + 0x5d
0xffffff83d1b1ba40 : 0xffffff7f9bd62adb com.apple.iokit.IOAcceleratorFamily2 : __ZN15IOAccelContext219submit_data_buffersEP33IOAccelContextSubmitDataBuffersInP34IOAccelContextSubmitDataBuffersOutyPy + 0x9d7
0xffffff83d1b1bac0 : 0xffffff801b068ea0 mach_kernel : _shim_io_connect_method_structureI_structureO + 0x1b0
0xffffff83d1b1bb10 : 0xffffff801b067121 mach_kernel : __ZN12IOUserClient14externalMethodEjP25IOExternalMethodArgumentsP24IOExternalMethodDispatchP8OSObjectPv + 0x331
0xffffff83d1b1bb60 : 0xffffff801b070083 mach_kernel : _is_io_connect_method + 0x223
0xffffff83d1b1bca0 : 0xffffff801aa22c22 mach_kernel : _iokit_server_routine + 0x4e62
0xffffff83d1b1bdb0 : 0xffffff801a941998 mach_kernel : _ipc_kobject_server + 0x238
0xffffff83d1b1be10 : 0xffffff801a918625 mach_kernel : _ipc_kmsg_send + 0x135
0xffffff83d1b1be70 : 0xffffff801a92f0d5 mach_kernel : _mach_msg_overwrite_trap + 0x2e5
0xffffff83d1b1bf00 : 0xffffff801aa4b485 mach_kernel : _mach_call_munger64 + 0x205
0xffffff83d1b1bfa0 : 0xffffff801a8e3226 mach_kernel : _hndl_mach_scall64 + 0x16
Kernel Extensions in backtrace:
dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[2FAEE793-59BC-3ADF-A5E2-3BC8760AFE0B]@0xffffff7f9b992000
dependency: com.apple.iokit.IOPCIFamily(2.9)[1286D5E5-A6A1-3C44-A244-04C068903DB2]@0xffffff7f9b32f000
dependency: com.apple.iokit.IOSurface(269.6)[640503DC-6033-3EF6-85F4-F48282EF48DD]@0xffffff7f9bd2b000
dependency: com.apple.iokit.IOGraphicsFamily(569.3)[7B5CA52B-0BD1-34AB-BFC9-7D5C3A0DBE7C]@0xffffff7f9bccc000
dependency: com.apple.iokit.IOReportFamily(47)[E3C37E96-3AFA-301F-B89C-719FB3D4DA53]@0xffffff7f9b6c8000
dependency: com.apple.iokit.IOPCIFamily(2.9)[1286D5E5-A6A1-3C44-A244-04C068903DB2]@0xffffff7f9b32f000
dependency: com.apple.iokit.IOSurface(269.6)[640503DC-6033-3EF6-85F4-F48282EF48DD]@0xffffff7f9bd2b000
dependency: com.apple.iokit.IOGraphicsFamily(569.3)[7B5CA52B-0BD1-34AB-BFC9-7D5C3A0DBE7C]@0xffffff7f9bccc000
dependency: com.apple.iokit.IOAcceleratorFamily2(438.2.8)[9176E894-E24A-36BA-AFDA-0DB11F3F512A]@0xffffff7f9bd5c000

BSD process name corresponding to current thread: VTDecoderXPCServ
Boot args: -v npci=0x2000 debug=0x100 keepsyms=1 agdpmod=pikera

Mac OS version:

Kernel version:
Darwin Kernel Version 19.2.0: Sat Nov 9 03:47:04 PST 2019; root:xnu-6153.61.1~20/RELEASE_X86_64
Kernel slide: 0x000000001a600000
Kernel text base: 0xffffff801a800000
__HIB text base: 0xffffff801a700000
System model name: iMacPro1,1 (XXXXXXXXX)
System shutdown begun: NO
Panic diags file available: YES (0x0)

System uptime in nanoseconds: 522124184583
Brandon Moore liked this


Hey @MDWingsFan , thanks for sharing!

To fix the inactivity crash just update the SMBIOS to match the iMac19,1 model.

Can I ask you how come you used the W836x which is supposed to work with Asus Mobo instead of ITEIT87x (gigabyte)?
Are your sensor working fine? What temps do you manage to get?

Also, I have the same board and same BT/wifi replacement (BCM94352Z DW1560). Do you have any lag when connecting more than 1 device to the BT?

My wifi works perfectly but with BT only the first device I connect works fine, the second will lag terribly...

I'm using BRCM kexts, I tried both "Data" and "Repo" and the result is the same.
I used another config.plist, and didn't realize that ITEIT87x was for Gigabye MBs. That would explain why I have no temps :lol: ;p. I've made the SMBIOS change to turn my box into a 19,1. Hopefully that cures the kernel panics! I really haven't tried more than my bluetooth mouse at this point, but will try a keyboard as the 2nd device and see what happens!
Yep, the 19,1 fix took care of the stability issue 100%. The NVME drive that shows up as external is the one on the front of the board, under the heatsink. I'd love to get it to show up as internal, but have no idea how to pull that off. No go on any temperatures other than the SSD and a spinning disk. I have the right kexts, but no temps...
Post Merged
Using Hackintool I was able to load the kexts for the AMDCPUMonitoring, Radeon Monitor, and ITEIT87x into the S/L/E folder. Following a reboot I now have fan speed, NorthBridge Temp, Ambient Temps, and VRM voltages. I get GPU utilization, but no fan speed or temps... Better than nothing, but I think these kexts will need updates to get more info, especially the Radeon Monitor, and AMD CPU Monitor
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]