Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#56426
Almost ready to post my final update with my system but there is one issue I am having currently. I believe I have really good news for music producers or anyone doing this for music production needing TB3 as well...

My current issue is with my Samsung SSD 850 Evo 2 TB. For some reason when I try to connect this drive using any of the sata ports on the motherboard it does not show up at all. I tried reset but nothing. But when I disconnect it and plug it into my adapter the drive shows up in MacOS disk utility no problem. The drive even shows on my desktop. I ran first aid from disk utility and it says drive is fine.

So why is it I cannot see this drive in the bios using the SATA ports (tried all 4 and even swapped the cable for a different one) but I can connect it to my adapter and plug into USB and it shows up fine?

I’m sure I’m missing something but my goal is to be able to have this drive host all the music samples, song files, and content libraries using one of the internal sata connections and this way keep my NVME drive that I boot from relatively clear of the above mentioned items.

Apophis, or anyone for that matter, why is this not working or am I missing something?

 Advertising

#56435
@toure14, I don’t have anything else than the NVMe SSD installed. But recently I’ve connected an old 3TB HDD temporarily through SATA to test something and it worked fine. I know that some Samsung SSD have issues with MacOS and at least a firmware upgrade is necessary. But I never read up on the details.

@Rickyandika, I’ve never tested Sidecar since I’ve no use for it. Maybe I’ll find some time to try it. OpenCL performance seems as expected. I’ve copied Terabytes of files from one external drive to another for backup, no issues there.
#56439
@ Apophis. Thanks I will try to hookup a regular HDD to the SATA port like you did and if it shows up then I know something is up with the SSD drive itself.

The short history behind the drive is I initially installed it into my iMac as an upgrade. But I didn’t want to buy a new SSD for this build so I cloned it and put the original iMac drive back in there. Wiped the SSD reformatted to APFS and you know the rest... anyways

I attached a picture. How did you change the info for your Mac system to say Ryzen Mac Pro? I went through the open core guide again but I didn’t see anything directly related to this little feature?
Attachments
4F618773-6F35-4CF5-A10E-55703FB3F9DB.jpeg
4F618773-6F35-4CF5-A10E-55703FB3F9DB.jpeg (198.23 KiB) Viewed 953 times
#56470
Thanks for that. I found a full guide on it.

Question. Do you ever experience random reboots? It doesn't happen often but I would say today marks the 3rd time the system just randomly rebooted on me and I don't know why it does that.

My only guess is that my HDMI cable I am currently using isnt plugged in all the way because of the case I am using. But it is in as far as it can go. The cable needs to be shaved a bit at the top where the rubber plastic meets the computer case or I maybe need a slim cable. But this is only my guess.

I also tried the sata drives again using a different drive and nothing shows up. I really hope I didn't do all of this work only to have faulty MOBO sata ports. I will copy my EFI folder this week and try a new fresh install of windows to see if the drive shows up in the very begginig. This is the only thing I can find on the net that is recommended before reaching out to vendor.
Post Merged
Welp. Just got off the phone with ASrock tech support. Turns out I have a faulty SATA controller. Translation FAULTY MOBO :sick:

I was so close to being done with this build and the vision I had for it. So close.... :oops:

Well anyways I'll share a small update later of where I was at and what works. My build is primarily aimed at music production and minor video editing with the ability to go into heavy video editing if needed down the road.

I will also be starting my own success build log. Mainly because I know I have several other producers following this thread who want to copy my exact build. plus I went off script with a few of the things I did like the cooler I installed, M.2, and TB3 setup for Universal Audio Rig. All sources like this thread and any youtube videos that were pivotal in my build will be linked and heavily credited.

Thanks Apophis for all your help. Hopefully my new board will allow me to pick up right where I'm leaving off, at 98%.
#56487
Oh, that really sucks... when I had issues with my GPU that was my biggest fear, luckily it was just issues with the riser cable. I don’t have random reboots so I guess this is also caused by the faulty mobo.
#56532
So while I am waiting on a RMA from ASrock I decided to tackle one of the last remaining issues with my build which is the fan curve/speed setup. I ran across some interesting info on my system. the BIOS info for the fans does not match the info in the AMD Gadget APP. The motherboard BIOS CPU temp hovers around 54C degrees while the AMD Gadget says it hovers around 44ish. When I engage the power management button frequency drops to 2.20 GHz and the temp drops to 36C degrees. SO I ran the Logic Pro X test that many seem to use which can be found for download here https://www.logicprohelp.com/forum/view ... p?t=138612

I was able to successfully run all 128 tracks for at least 10 minutes easily. The CPU performance meter in Logic was somewhere around 70% maybe lower because one thread remained below 50%. But seeing as how my build is primarily for music production apps like Logic, Pro Tools, etc.. would be the most CPU intensive apps being run most times. The AMD Gadget reported the CPU temp to be constant at 63C degrees with power management engaged.

So here is my questions at this point, what are you guys seeing for normal idle temps with the 3900X and this board? Also, if you guys are using the AMD power Gadget tool what type of temps are you guys seeing? Last, what type of Fan curves are you guys using with this CPU and Board if you don't mind sharing?

I currently have the fans running in silent mode through the BIOS. Do you think I need a custom fan curve or I can get by with the 4 options ASrock offers?
Attachments
Screen Shot 2020-04-12 at 10.16.17 AM.png
Screen Shot 2020-04-12 at 10.16.17 AM.png (1.22 MiB) Viewed 928 times
Screen Shot 2020-04-12 at 10.14.55 AM.png
Screen Shot 2020-04-12 at 10.14.55 AM.png (1.21 MiB) Viewed 928 times
Screen Shot 2020-04-12 at 10.13.02 AM.png
Screen Shot 2020-04-12 at 10.13.02 AM.png (729.95 KiB) Viewed 928 times
IMG_2767.JPG
IMG_2767.JPG (2.58 MiB) Viewed 928 times
#56534
@toure14, Accidentally I've been playing around with my fan curves over the last couple of days. What I noticed already in the past that while in BIOS, the CPU seems to run with much more power than it would usually do (disabling Core Performance Boost would bring it down to a reasonable level). So it's hard to compare temperatures while in BIOS.

My CPU was usually idling between 30 and 32 degrees so I lowered the minimal speed a little for them to be more quiet but still keeping idle temps at around 36 degrees.

I've set up an USB stick with a bootable Windows on it to control the RGB on my Corsair RAMs, while at it I've also installed ASRock's tuning apps to test fan curves with live temperatures. I ended up with a somewhat exponential curve for CPU and Case fans, and a rather flat one for the Chipset fan. Also I set the case fans to be controlled by the CPU temp since the Mainboard temp seems relatively stable but the air in the system still got quite warm under longer heavy load.
I could give you my exact settings if you like, but they are very bound to my case (the Evolv Shift) and the top speed of my fans (2300 rpms for the AIO fans, 1500 for the case fans).
#56541
@Apophis, So if I understand you correctly, you boot into windows from USB, run the Asrock software, setup your fans and curve, then transfer that info respectively to the motherboard BIOS? Or you are able to boot into windows and setup the fans and curve and it stays that way once you boot back into macOS? I'd love to take a look at your fan curve if you don't mind uploading.

Was finally able to mod my info tab as well but it I cant change anything else like the guide says. I followed a few different guides actually trying to get a full custom info tab but I am only able to change the name as you were able to as well. Can't change the catalina picture and edit the CPU processor info or change the OS. Maybe it is different for Catalina. Here is the link to the guide I am referring to :https://github.com/Haru-tan/Hackintosh- ... cMojave.md This guide has a complete custom info tab but I believe he is using Mojave. I uploaded a picture of his.

A different link for a different way to try and mod the info tab:https://www.idownloadblog.com/2017/01/1 ... ackintosh/

Biggest issue is on Catalina I can't change the permissions for my main Drive. there is a terminal command you can run to disable the permissions on the main drive but you have to boot into recovery mode and run it from there. Not sure how to do this on a hackintosh. I tried restarting and holding command + R but it just boots back into the profile. If I could change the permissions on this system then We could truly customize the entire info tab.
Post Merged
In case you were wondering where the name "Ryzen Pro BLACK Edition came from...
Attachments
Black Edition 2.jpg
Black Edition 2.jpg (2.81 MiB) Viewed 921 times
Black Edition 1.jpg
Black Edition 1.jpg (2.09 MiB) Viewed 921 times
Ryzen Pro BLACK .png
Ryzen Pro BLACK .png (80.62 KiB) Viewed 921 times
custom OS.png
custom OS.png (144.47 KiB) Viewed 921 times
  • 1
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]