Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#53427
Image
Build
Motherboard: Gigabyte X570 Aorus Elite
CPU: AMD Ryzen 7 3700X
CPU Cooler: bequiet! Dark Rock 4
GPU: Sapphire Radeon RX 5700 8 GB
Memory: HyperX Black Fury 32 GB (4 x 8 GB) DDR4-3200
Storage: Samsung 970 EVO Plus 500GB NVME
Bluetooth: Asus BT400 usb dongle
Wifi: None
Case: NZXT H500
Power Supply: Cougar CMX700
Monitor: LG 27UL500

MacOS: 10.15.4
OpenCore: 0.5.7
BIOS: F12

Benchmarks
Spoiler:
Image
Image
Image
Bios Settings:
- Load Optimized Defaults
- XMP profile
- CSM Support: Disabled
- Above 4G Decoding: Enabled

OpenCore
Spoiler:
ACPI
- SSDT-PLUG.aml (fix CPU PM)
- SSDT-HPET.aml
- SSDT-ALS.aml
- SSDT-SBRG.aml (fix EC and USB power)
- SSDT-NVME.aml (show SSD as internal)
- SSDT-XHC.aml (rename USB controllers and port mapping)
Kexts
- Lilu.kext
- VirtualSMC.kext
- AppleALC.kext (for sound ALC1200 —  layout 1)
- SmallTreeIntel82576.kext (for Intel I211 ethernet)
- SMCAMDProcessor.kext (for monitor and manage CPU power https://github.com/trulyspinach/SMCAMDProcessor)
- AMDRyzenCPUPowerManagement.kext
- Kernel 17h patches (added patch for 10.15.4 correct working)

SMBIOS
MacPro7,1 for DRM working

Boot Args
alcid=1 (moved to device properties)

Drivers
- ApfsDriverLoader.efi
- VBoxHfs.efi
- OpenRuntime.efi

Everything works except sleep.
If you want to use attached EFI folder you need to generate your own SMBIOS SN. I recommend to use MacPro7,1.
Attachments
(1.64 MiB) Downloaded 204 times
Last edited by anti on Tue Apr 07, 2020 2:29 pm, edited 21 times in total.
c4orbi, Fryinfarmer, iGPU and 2 others liked this

 Advertising

#53464
Hi Anti,

First I want to say INFINITELY thank you for posting your EFI. I finally managed to get the system installed after being stuck for more than a week.

My system is 2700X / X570i Aorus Pro Wifi / MSI 5700 XT

Everything is working except the BT/WIFI card. My MB (Aorus x570i pro wifi) had one on board that I swapped with another confirmed supported (Broadcom BCM94352Z DW1560 6XRYC).

Could you tell me if in your EFI you added any setting/kext to disable the onboard card?

Do you have any suggestions about what could be preventing it to work properly?
#53473
enra enra wrote:Shutdown works but I had an issue also experienced by other users on this forum with the system freezing and rebooting after 5 or more minutes of inactivity.

Seems like changing the SMBIOS model to "iMac9,1" fixes it and in some cases also enable sleep/wake.
You mean iMac19,1? Yeah I'm on it, no sleep and the shutdown still doesn't work. (I have tried removing all the USB devices as well)
About the 5/10 min idle reboot, I've "fixed" with amphetamine.
enra enra, MadMax1998 liked this
  • 1
  • 2
  • 3
  • 4
  • 5
  • 7
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]