Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
First AMD build, followed the guide as best I could! Overall my biggest challenges are 1) fixing Lightroom CC and 2) knowing if I'm configured correctly based on the Geekbench v5 scores below and 3) Benchmarking the Radeon VII to see if I'm getting what I'm supposed to out of it

CPU: Ryzen 3900X
MB: Gigabyte x570 Aorus Ultra
HD: 970 Evo NVMe 1TB
GPU: Power Color Radeon VII

Other Kexts:

Geekbench 5 scores: 1323 single; 12198 multi (I have no idea if this is good or bad for this setup. need to research). Would love anyone's input on this!

-Still trying to figure out how to get Lightroom CC working. Tried to downgrade the RAW version, but still crashing :evil: This is my biggest issue as I use Lightroom a lot. If anyone has found other fixes to try please let me know!
-Photoshop fixed using one of the terminal patches
-Processor displays as 3.79 GHz Unknown. Sounds like this is purely cosmetic so not a big concern
Post Merged
Opps!! forgot to add, when Geekbench 5 I can only run CPU tests, the "Compute" test says: No compatible compute devices found. I don't have enough experience with version 5 to know if this is normal or not.

I've attached a screen shot of what the Radeon VII looks like. it still looks like I'm missing something in terms of hardware acceleration?
Screen Shot 2019-09-08 at 6.45.48 PM 1.png
Screen Shot 2019-09-08 at 6.45.48 PM 1.png (63.65 KiB) Viewed 729 times
amdpush liked this


Hi, I have also the Lightroom Problem....so if you find some solutions somehow....please let me know.

I've heard that some guys got it running by downgrading Lightroom Classic CC to 7.0.1 or lower....and CC to 1.0

But my real problem is ....Lightroom Classic CC 6.0 does not work (just shows splash screen very short and then nothing...no crash just disapearing) and i can't find CC 1.0 version anywhere....if you can find it....let me know...i wanna give it a try.

Oh and let me know how exactly you managed to downgrade ACR - as with the cloud it seems impossible for me.

goin3d wrote:I've attached a screen shot of what the Radeon VII looks like. it still looks like I'm missing something in terms of hardware acceleration?
Yeah, it looks like you're missing hardware acceleration entirely (which the Radeon VII definitely supports, and you definitely want working). I would suggest going into your BIOS and manually setting the PCI-E slots to Gen 3; that's all it takes on my system (X570 Taichi for the moment). The Radeon VII only supports Gen 3 anyways (and frankly, even with a 5700 series, which supports Gen 4, I don't think it's really necessary to get the full performance out of it)
Hi, great job!

Yours benchmarks are OK.

If doesn't work what FriedEngineer try with the link below. It works on 2012 MacPros. Let us now your solution.


https://forums.macrumors.com/threads/ac ... n.2180095/
Code: Select all
[quote]I have the same config, but i am struggling to get internet connection. The installer fails with Catalyna and Mojave with no internet error.
I tried all of the intel network kext-s, but no success. 
Did you have issues with it?[/quote]
Nevermind, i finally fixed it. For the record, the only issue was that i need to use the patched network kext.
Also, i made an offline installer if thats count, but with the new kext i had internet too.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]