Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
User avatar
by: theodorton
#50460
Specs:
CPU: AMD Ryzen 7 3900x
Motherboard: ASRock Taichi X570
RAM: G.SKILL Trident-Z 32GB DDR4 3200MHZ
HDD: Samsung 970 EVO Plus 1TB + External 1TB USB
USB : 3.0 | 3.1
GPU: Sapphire Nitro+ Vega 64 8GB
LAN: Intel I211-AT (onboard)
Sound: Motherboard / Universal Audio Arrow TB3 interface
Sleep: Kinda works
Monitor: LG Ultrafine 5K 27"
Bootloader: Clover
Other OS: None
Thunderbolt: ASRock TB3 AIC (revision 1)

Working:
Basically everything, haven't found anything specific that hasn't worked yet... except

not working:
The NVMe Samsung drive wouldn't get past installation. I suspect there might have been some issues formatting the drive.

sort of working:
When putting the machine to sleep, it just seems to put the display to sleep.

I'm trying to use Carbon Copy Cloner now to clone to the NVMe drive and see if I'm able to boot from Clover. Then I'll install Clover on the disk to avoid using the thumb drive.
Egress liked this

 Advertising

User avatar
by: 4Eyes
#50462
I have the same SSD - works fine after updating FW on 970 Evo plus :thumbup:
theodorton liked this
User avatar
by: Bioraft
#50466
Hello, I have a similar config, Ryzen 3900X, Asrock X570 Extreme4, RX 570. One question, how did you make your audio work? VoodooHDA? AppleALC with native audio?, I am using VoodooHDA + AppleGFXHDA configuration for HDMI audio, but it would be nice to have all with AppleALC for native audio. How is the performance of the VideoCard? in my case in some scenarios the performance is really bad (like some games o 3D Apps). You USB 3.2 Gen 2 are Working? mine not, how did you make it work?, please it would be nice to have some information from your side and maybe we can share some tips...
User avatar
by: amdpush
#50478
Hi, very nice to share with us this configuration. Have you already tested the thunderbolt connection with an audio interface a storage or a screen . Have you tested FCPX or Premiere on it ? Do you use this hack daily is it a reliable build . Thanks. Have already do benchmark to know if your config perform well ? bye
#50499
Update here:
The bluetooth stopped working unfortunately. I’m not completely sure why, I must have messed up kexts/drivers. Wifi doesn’t work either, but I have ethernet so not sure if I’ll be getting a broadcom module.

Thunderbolt has been a debugging nightmare that finally ended today. I’ve had issues getting my TB3 audio interface to get identified in both windows and macos, but I seemed to have a missed a BIOS setting. It’s not very obvious where the setting is, but under Advanced > AMD PBS > Thunderbolt (the last option) must be set to Enabled.

This is confusing because the Ultrafine works (somewhat without enabling TB), but the USB hub doesn’t work (which makes sense now that I know why).

If anyone else has figured out how to get Intel Wifi/Bluetooth working I’d be happy to get some advice. I’m 100% sure I was able to use it in one of my first boots. I connected my Apple Keyboard and was able to use it in the first sessions.

Audio Interface seems to work fine, but I ran into some clock sync issues. In the controller software I couldn’t see that the device clock was enabled. Changing the sample rate back and forth in Logic seems to solve the problem though, clock is now indicated as enabled.
Post Merged
I’ll post my kexts and drivers on sunday when I’m back home.
User avatar
by: amdpush
#50702
Hi Theodorton. I happy to see how you doing continous improvements in your very nice hackintosh ! But, I would like you to do this test with Premire Pro, just a single one ; now that i a knowing the results seem are awful in FCPX. Because i can't understand what that's mean to have a hackintosh if you can't use the power of the Ryzen 3000, If it's not working as an intel CPU. Really i would like this AMDHackintosh works well because i think it will be better to have RYZEN in the real MAC. Thanks.
https://www.pugetsystems.com/labs/artic ... mark-1519/
#50777
All my parts arrived and I built the system, but I’m getting some strange behavior. @theodorton are you having any issues with the system rebooting during POST when you enable thunderbolt support in the bios or seeing the display flickering/ disconnecting when running at full 5k res? I’m experiencing both of those issues.

The first issue, rebooting during POST only happens when I enable thunderbolt support in the bios. It reboots a few times before the display comes on and the system loads the OS. The second issue, in Windows (Haven’t installed Mac OS yet. Soon!) The 5k display randomly disconnects / flickers. I’ve tried different cables, to no avail.

Are you experiencing any of these issues?

@CaseySJ , I also using liquidctl for both Wind[…]

@CaseySJ , Fenvi FT-T919 would also be my 1st p[…]

Hi, I really wish this topic could get more light […]

Congrats and tell me about the installation, if us[…]