Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
Most important thing: Tried multiple ways to set it up, in the end it was the BIOS version. I always got Kernel Issues (OPEMU errors). Updating my BIOS from F4 to F5g was the trick.


I followed this guide: https://kb.amd-osx.com/guides/HS/
But I skipped the part with inserting the AMD Kernels into System/Library/Kernels.
Instead I used the config.plist provided here with the Kernel patches: https://github.com/AMD-OSX/AMD_Vanilla/tree/master/17h


https://github.com/SchmockLord/Hackinto ... ree/master

Best, Chris
Post Merged
Update 14.06.2019:
- Added a MSI Airboost RX Vega 56*
- changed to SMBIOS iMacPro1,1
- fixed Audio/Video Sync issues by changing Overclocking from 4.1 to 4.0Ghz and by creating a custom TCSyncAMD.kext
- installed Mojave 10.14.5 but switched back to 10.14.3 as the RX Vega 56 is not utilised properly in 10.14.5, the Luxmark and Geekbench Scores were too low and the Clockspeeds were jumping a lot from 1.5Ghz down to 800Mhz
- fine-tuned Drivers and Kext-folder
- added a customized VegaTab_56.kext that has a nice fan, voltage and clock speed curve. Remove that when the system won't boot or you have issues with graphics

Best, Chris
Post Merged
Update 04.10.2019:
- replaced my 1080Ti and Vega 56 by one Radeon VII
- upgraded to 10.4.6
- Optimisation: reduced the amount of Drivers and Kexts to the really required ones
Last edited by SchmockLord on Fri Oct 04, 2019 8:32 am, edited 1 time in total.
tigerii liked this



I'm running a NEARLY identical setup, but I can't get it to boot. It's getting a Kernel Panic on the ACPI kext.

I have a TR 1950X with a Gigabyte X399 board, 64GB RAM, and a 1080Ti + RX580. I've tried both with and without the Vega kext. Is there something else I'm missing here? Are you SURE that there is nothing about the install itself that's modified beyond your linked Clover files?

My install is 10.14.4, and I'm running a newer BIOS build, but I can't imagine that should make a difference. I've tried booting the drive as both internal and external. Any help would be great. Thanks!
SchmockLord liked this
Just noticed your post.

No, actually a plain vanilla USB-installer made on a MAC should work. You can try UniBeast 9.2. Move Mojave Installer into Applications folder, start UniBeast and install for UEFI only. No graphics injections. Then replace the EFI-folder on the mounted EFI-partition with my one.

Or use this command to create installer via terminal and then mount EFI-partition with clover configurator to paste the EFI-folder:

Command: sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume

But the most important thing: Check your BIOS version. It took me days to figure it out. Apart from that: Check your BIOS settings again.

I just compressed my current EFI-folder I am using right now to answer you. I have generated a new serial number, so you can use it without touching it.


long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]