Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#45943
My setup: Ryzen 2600, Gigabyte B450 I Auros Pro wifi, 16gb ram, Sandisk 512gb ssd, Sapphire Nitro Vega 64

Just wanna say thank you AMD-OSX.com. I tried Hackintosh years ago and it was just too much work and not stable, back in the days with Intel processor and tonymax86's guides.
After switching to AMD recently, I wanna try again last night because why not, and wow, you guys rock, successfully installed Mojave 10.14.1 at second try (first time failed due to misunderstanding instruction).
I follow this viewtopic.php?f=24&t=5902 and another one viewtopic.php?f=24&t=6029 , due to the fact the second tutorial also covers Clover bootloader installation.

If you have a similar setup, I advise you to follow the tutorials to the T, it should works out.

Edit1: add bootflag alcid=11 fix the mobo's native audio!

Working right after install: ethernet, USB ports, graphic card
Fixed: Native audio
Not working: wifi module, iCloud crash when attempt to login, iMessage



Image
Last edited by jaykittenman on Sun Mar 03, 2019 11:05 pm, edited 1 time in total.

 Advertising

#45945
jaykittenman wrote:My setup: Ryzen 2600, Gigabyte B450 I Auros Pro wifi, 16gb ram, Sandisk 512gb ssd, Sapphire Nitro Vega 64

Working right after install: ethernet, USB ports, graphic card

Not working: native audio, wifi module, iCloud crash when attempt to login, iMessage

Just wanna say thank you AMD-OSX.com. I tried Hackintosh years ago and it was just too much work and not stable, back in the days with Intel processor and tonymax86's guides.
After switching to AMD recently, I wanna try again last night because why not, and wow, you guys rock, successfully installed Mojave 10.14.1 at second try (first time failed due to misunderstanding instruction).
I follow this viewtopic.php?f=24&t=5902 and another one viewtopic.php?f=24&t=6029 , due to the fact the second tutorial also covers Clover bootloader installation.

If you have a similar setup, I advise you to follow the tutorials to the T, it should works out.

Image
As per my post here, viewtopic.php?p=45941#p45941

Please reply to this thread with what I've asked.
#50691
With Vanilla installation, my Ethernet is not working :crazy:
What KEXT did you use to live the Ethernet?

Without qualification to see those posts you providing, I’ve tried to inject different KEXT to fix it. (Intel / Realtek)

CPU AMD 3700X
M/B Gigabyte B450
GPU Asus RX570
#50795
Mine worked using this kext. SmallTree-Intel-211-AT-PCIe-GBE.kext this is available on repository provided by the guide for vanilla installation
Post Merged
Fiffy Wu wrote:With Vanilla installation, my Ethernet is not working :crazy:
What KEXT did you use to live the Ethernet?

Without qualification to see those posts you providing, I’ve tried to inject different KEXT to fix it. (Intel / Realtek)

CPU AMD 3700X
M/B Gigabyte B450
GPU Asus RX570
Mine worked using this kext. SmallTree-Intel-211-AT-PCIe-GBE.kext this is available on repository provided by the guide for vanilla installation
Egress liked this
#51704
i am having the same issue, I have the B450 ProWifi, the router and exthernet port lights are on and even show as connected in bios. I have the SmallTree kext but no luck, when I boot into the recovery and go to network utils there is no connection present.

You need the latest clover. Get it at the github u[…]

AMD Vanilla Tutorials

Hello, I'm trying to install Mojave on my desktop […]

Do you have acceleration with this web driver?

Thank you, all working now :)