Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#56119
Catalina 10.15.4, installed with OpenCORE v0.5.6
I made my own ACPI: DSDT exported on windows, also using SSDT-EC-USBX
SMBIOS: MacPRO 7.1 -> yes, i get the warning on the RAM but its working.
IMG_6354.jpg
IMG_6354.jpg (2.43 MiB) Viewed 1740 times
Full Spec:
  • CPU: Ryzen R9 3900X
  • Motherboard: Gigabyte Aorus Ultra X570
  • VGA: Gigabyte RX 5700 XT 8GB
  • RAM: 4*8GB 3200MHZ DDR4 RAM Kingston HyperX Predator RGB CL16
  • SSD: 500GB Samsung 970 EVO Plus M.2 + 128GB Intel SSDPEKKW128G7X1 M.2 SSD for Windows 10
  • PSU: Zalman 1000W ZM1000-ARX
  • WIFI+BT: BCM94360CD + BCM94360CD/BCM943602CDP WIFI WLAN module to PCI-e 1x 16x
  • PC Case: Cooler Master MasterCase H500
  • CPU cooler: Be Quiet! Dark Rock Pro 4
  • Main monitor: BENQ EL2870U (on DVI)
  • Secondary monitor: LG 27" 21:9 (on HDMI)
  • Behringer U-Phoria UMC22 USB sound card + NEEWER NW-700 XLR mic
  • LG 3D BLU-RAY HX806CM 2.1 sound (on OPTICAL)

Kext:
  • Lilu
  • Whatevergreen
  • VirtualSMC
  • AppleALC
  • AppleMCEReporterDisabler
  • SmallTree-Intel-211-AT-PCIe-GBE
  • AirportBrcmFixup
  • SMCAMDProcessor
Screenshot 2020-04-01 at 12.45.24.png
Screenshot 2020-04-01 at 12.45.24.png (157.28 KiB) Viewed 1741 times

Boot arguments:
keepsyms=1 agdpmod=pikera npci=0x3000 alcid=1

Performance
  • Cinebench R20:
    Screenshot 2020-04-01 at 12.59.09.png
    Screenshot 2020-04-01 at 12.59.09.png (107.55 KiB) Viewed 1741 times
Whats NOT working:
  • sleep
  • sidecar - no chip, but Duet display is working ;)
Whats working as an extra:
Last edited by freeubi on Wed Apr 15, 2020 9:04 am, edited 1 time in total.
VenimK, ccphuc, hayskeys liked this

 Advertising

#56121
Oh, i didn't known that - i will check it up.
Definitely strange, as when the output is on an another device, or monitor the its working...
#56148
@Edo, i am not using any NVME fix. I didn't really measure it , but from the OpenCORE selection to OSX login screen it takes about 5 seconds. Its not blazing fast but faster than my MacbookPro :D

@littlejon, This is my first OpenCORE install. The documentation is not 100% clear and sometimes confusing, but after a few reads i could manage to do it.
I had a Clover install on this PC before this, with 10.15.1 but the audio was buggy with VoodooHDA and the whole pc could froze sometimes. Now these issues are gone.
Overall the native wifi card helps a lot ;)

The clover used npci=0x2000, now i am using 3000. There is no real reason, it would work with 2000 too :)
#56207
@littlejon, i used the vanilla guide, but i struggled with the ACPI part. For that, I found this docs: https://khronokernel.github.io/Getting ... With-ACPI/ [its in the guide too but pretty hidden]. It not straightforward, but if you read the whole doc, then you can figure it out.

If you still cant do it, feel free to ping me :)
Post Merged
Update:
I fixed my microphone..

I am using an U-PHORIA UMC22, with a condenser mic with just the usb power. My issue was that if the input and output was this device, then it doesnt worked, but if its only one of them then it was fine.
Today i started using an AMD USB Power from SSDT-EC-USBX-AMD and its working now :)

TLDR: you wont get 48V without proper usb voltage ¯\_(ツ)_/¯
#56674
please give me your EFI folder download link ? thank

My PC ASUS X570-Pro + CPU AMD Ryxen 3600 + VGA Gigabyte AORUS 5700 XT
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]