Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#54664
Finally made it but with one major obstacle along the way that I want to warn everyone about. More info below.
Screenshot 2020-02-12 at 19.38.45.jpg
Screenshot 2020-02-12 at 19.38.45.jpg (831.91 KiB) Viewed 292 times
Thanks to this forum in particular for making this possible. Lot of great info! System seems fairly stable. I’ve been running 4k video while doing blackmagicspeedtest and yes dev/null x8 over a few nights and tried Geekbench 4 and 5.

Specs:
CPU: AMD Ryzen 7 2700X (runs at 4Ghz)
MB: Asus Prime B350-Plus
RAM: Corsair Vengeance LPX 2x16GB 3200 (runs at 3000)
GPU: Sapphire Radeon RX 580 8 GB
HDD: Corsair A2000 M2 1TB
PSU: Corsair RM 850x v2

OS: MacOS 10.15.3
Bootloader: OpenCore 0.5.5

Background
I’m an avid Apple user and have been using Macbook Pros for a long time. I’ve got a retina mid-2015. I work with app development (and development in general, Swift/iOS primarily) and my laptop has been struggling lately. I have avoided updating because of all the problems with 2016 generation of MBPs and now that the new 16” was released I was of course eying it. But the rumors point to a possible interesting upgrade to the 13” (to 14” or close) which I think is a better form factor. So I want to wait for that release.

Moreover, I built a powerful rig in 2018 to use for what may come up (heavier system development, I’m also involved in some audio and video production every now and then) that was pretty maxed out at the time.

Found myself mostly using the MBP though and the desktop only had Windows and Linux dual boot for the odd need.

With SwiftUI and a bigger project I’m involved in my MBP really struggled to the point where there’s been huge lag and all fans/temps rise on something as simple as building to the app simulator.

I’ve read about hackintoshes a bit over the years and AMD always seemed to struggle but I think I found something recently that made me think.

I went ahead and made a bit of research because of the need for more juice and seemed like many people had pretty stable rigs with similar hardware to mine.

Had a 1080ti earlier, got a cheap 2nd hand RSX580 instead (for like $80) and picked up an M2 disk that was also discount albeit not cheap. This was due to the current dual boot being on the available SSD.

Read the vanilla guide, Shanee’s guide, Snazzylabs famous video and made research, made notes and started building.


Process (with WARNING at the end)
The tools available make the build process fairly easy. I ran into many problems that were easy to google and often mentioned in the vanilla guide. And as mentioned above one major problem that’s described below.

Most errors involved making more edits to the config.plist. Got the require vault error and not supported on this mac error among others. Easily fixable. Went with some recommended bios settings btw that were straightforward but often required research because of different manufacturer’s ways of labeling settings in the bios.

Once I finally got the install GUI to start it was in Russian(!!). Apparently this something of an accepted internal joke now in the community so I’m not going to comment more on it other than that "Slavs rule the Hackintosh world".

Installed and got some RAM warning that was easy to fix with a kext. Did some stability testing and system seemed fine. Now to the good part of setting up triple boot…


My setup differed a bit from most tutorials as I had an existing dual boot that I wanted to keep.

I installed macOS to the newly acquired M2 disk and all was dandy. I also copied all OC files from the usb to the EFI partition. However I was only able to start macOS by selecting that disks EFI partition in bio as Grub, which lived on the dual boot SSD with Windows and Linux wouldn’t auto add anything.

WARNING - DO NOT DO THIS
In order to get the nice 3x boot setup I wanted I figured I’d just go to bios, change boot disk to the M2 with the EFI partition (with OC on it) and start tweaking it to include my other OS:s. The official guide and OC documentation is all adamant on having OC as the bootloader.

Big mistake.

This corrupted my motherboard’s bios. After setting the M2 to boot, it wouldn’t boot to the M2 nor would it find bios! I’ve never in my life experienced bios getting corrupted from such a seemingly mundane thing.

After many hours of research (essentially lost more than half a day, and I didn’t want to redo any installs as they were already done) with the only way of getting to my bios was disconnecting all drives (as it becomes the default) I found someone who wrote on some forum about a similar problem on a similar platform. The solution was to reflash the bios.

After the reflash it’s been working fine but I do NOT recommend using OpenCore as the sole bootloader. My main bootloader now loads OC when macOS is chosen. As it seems these kind of things can happen I’d just stay away from OC as a bootloader for the time being and until it’s matured.

I installed rEFInd with a nice custom theme which I configured to have 3 choices in a minimalistic dark screen.

Been my daily device and the same project in SwiftUI that I mentioned above giving my Macbook Pro a hard time works super smooth on this Hack Pro Ryzentosh. It doesn’t break a sweat!


Current issues/problems
-BIOS issue initially. Read more above. Warning!!
-NVME. Got 2 nvme related crashes early on. No crashes for a while, not sure if fixed...
-Video DRM issue. System crash when viewing some videos in safari. Also when logging in to plex.tv and then pressing “Launch” to get to the Plex dashboard it immediately freezes the entire computer. Audio will keep playing though. Hard reset is only solution.
-Razer Keyboard. Shitty macOS support. Doesn’t work well. Will probably throw it out for an Apple Magic Keyboard.
-Audio. Haven’t tried but probably works, Does not work. Only been using Airplay to Homepod. Works fine.
-Sensors. Would be nice to have them. I Hope this is coming in a future version of VirtualSMC. Have a few in iStat but CPU temp and fan speeds/control would be awesome. Don't think SMCSuperIO.kext has done any difference.
-BT/WIFI. Been using ethernet but have ordered a Fenvi T919 to get Bluetooth especially since I’d like to use a Trackpad. Received Fenvi T919. Works out of the box but am not able to get auto unlock with apple watch working and seems I can't get sidecar going either. Will continue to investigate and optimize. Hopefully it'll work eventually


This got long, sorry! Hopefully it has some information that'll be beneficial to ppl :)

edit feb. 17 2020 - made a few updates. nothing major, it's reflected in the text. Ill try and keep updating this post as stuff develops.

edit feb. 23 2020 - got fenvi 919. seems to work oob but am not able to get auto unlock with apple watch working. I also realized my audio doesnt work and has never worked. Investigation continues...
Last edited by davesmif on Sun Feb 23, 2020 1:23 pm, edited 4 times in total.
HackeyMac liked this

 Advertising

#55478
davesmif wrote:...nor would it find bios!
What do you mean by that? Were you unable to get into BIOS to change settings, or am I misunderstanding?
#55511
Yup, correct. Wasn't able to get into BIOS. Disconnecting all drives only thing that worked and then I was able to reflash it.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]