Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
#41842
Hello folks

m4a87td USB3
AMD Phenom(tm) II X6 1090T Processor
GTX 660 Ti

I am fairly new to OSX86, Please be kind :). All BIOS settings are set to default except AHCI is enabled.

I used Shanne's AMD V2 El Capitan DMG, it started to boot and then it hung at IOAPIC version 0x21 vectors 64:87 (after pushing any key on my keyboard it seemed to continue booting fine). I was able to boot the installer and successfully install El Capitan to my HDD.

I did Shanne's post install instructions (copying the AMD kernel and extra) from the OSX Installer terminal.

I ran into USB problems (AppleUSBEHCI stop and start repeatedly and HCHslted did not set as expected). I found Shanne's USB fixes (4 kexts that I installed from the OSX Installer). Then OSX finally booted from the HDD! I still need to push any key during the boot process though to skip the IOAPIC version bug.

Video seemed to work fine with hardware acceleration but I discovered that I had no audio or ethernet, so I installed the latest VoodooHDA kext and the latest Rehab man's RealtekRTL8111 Network driver. Ethernet works fine but the sound is very very choppy. I thought it might be the onboard sound chip so i tried HDMI sound and that is also choppy. I have tried changing to all different formats in Audio MIDI Setup - 44100 Hz (lower seems less choppy than the rest). I installed the VoodooHDA preference panel and reduced gain to 0.

Also there's a few weird things happening. My USB Drive (the one that contains the OSX installer) isn't recognised in any USB port but my USB mouse and USB keyboard work in any USB port.

I would appreciate any help on the above issues
Post Merged
UPDATE: The audio gets more choppy depending on how "busy" the CPU is. If I open a YouTube video and then start doing other things it gets noticeably worse.
UPDATE #2: I plugged in my USB Tritton ARK/Madcatz headset. The audio is perfect on this. I'd still like to use my speakers though.
Post Merged
UPDATE #3: Fixed all issues by adjusting BIOS cpu ratio and CPU settings to manual and turning cool n quiet off as well as C4 something. Only problem now is when the computer sleeps it doesn't wake up.

 Advertising

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]