Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
User avatar
by: Nimraynn
Hi all,

I'm running Mac OS X 10.11.6 and using iTunes but it's not really iTunes that is the issue.

I had a 6th generation iPod Classic which I've modified to swap the old ZIF HDD with an mSATA SSD. This has been working great for probably nearly 2 years. I primarily use it with my Windows 10 build and my Kenwood car headunit... but I have definitely used it on my MacBook in the past so I know Mac OS X is capable of reading it.

When I plug it into my AMD Mac OS X install, nothing appears to happen. If I open up a terminal and run diskutil list, I can see the disk is listed as /dev/disk6, but it has no labels or information. It takes a moment for it to come up if I've just plugged it in, but after running the command a few times, it does show up:
Code: Select all
/dev/disk6 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                                                   *256.1 GB   disk6
If I run diskutil mount /dev/disk6

It sits there for a while and eventually returns with "Volume on disk6 timed out waiting to mount"

I've done a small amount of Googling and found the following variant of that command: diskutil mountDisk /dev/disk6 That returns with "Volume(s) mounted successfully"

At this point, nothing else appears to happen. Nothing in Finder and oddly, viewing the list again shows /dev/disk6 has disappeared.

If I re-try either of the mount or mountDisk commands again, they both say "Unable to find disk for /dev/disk6"

This may or may not be unrelated, but if at this point I disconnect the iPod ready to reconnect it, the iPod screen changes from "Connected" to "Ejecting", then says "OK to disconnect" and then instantly reboots. The iPod OS can sometimes be flaky and needs a hard reset, but it doesn't normally reboot itself when I unplug it from the PC.

Interestingly, just as I'm typing this I've tried to plug it into my MacBook Pro running 10.13.3 and I get "The disk you inserted was not readable by this computer" with options to Initialize, Ignore or Eject... so macOS doesn't like something about it. I've clicked "Initialize" and Disk Utility opened. I selected "First Aid" and it said the operation was successful...

I checked the diskutil list again and I can see it (disk3 this time on my MacBook)... so I run diskutil mount /dev/disk3 and it returned "Volume on disk3 failed to mount; if it has a partitioning scheme, use "diskutil mountDisk". If the volume is damaged, try the "readOnly" option"

So I tried diskutil mountDisk /dev/disk3 and it returned "Volume(s) mounted successfully" but nothing could be found anywhere. Nothing in Finder to suggest it has actually mounted the disk.

Ejected it through Disk Utility and disconnected the iPod. It rebooted again at this point. Plugged it back in and I now don't get the disk not readable message, but Disk Utility isn't picking up the disk. If I run diskutil list I can see it again there as /dev/disk3, but it doesn't seem interested. I just tried diskutil mountDisk readOnly /dev/disk3 and it can't find it. Running diskutil list shows it has disappeared.

Any ideas why macOS adamantly won't read this disk? :cry:



User avatar
by: Shaneee
Are you using a USB 2.0 port? If you've got USB 3.0 available try that instead.
User avatar
by: Nimraynn
I was using a USB2.0 port and I do have USB3.0 available, but I was having the trouble even on my MacBook (I'm not sure the ports are different on that)

Either way, I just managed to put the iPod into "Disk Mode" by holding down the centre button and play/pause button while it was booting. Oddly, it picks it up straight away when I do that. No problem at all.

Weird. Not a big problem for me, I don't mind having to disk mode it every time. I'm going to try it again without disk mode once I'm done with it for this session.

Also typical of me to try things, post, then find the answer :lol:

Thanks :thumbup:
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]