Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: redband123
#362
Shaneee wrote:Glad you got your USB working :thumbup: As for your Audio. Because you have an AMD Chipset you can't use a patched AppleHDA but instead must use VoodooHDA. Install the kext in the archive below with the app Kext Wizard which I've also packaged.
redband123.zip
For your ethernet. Take a look at this page,
Code: Select all
http://lnx2mac.blogspot.co.uk/p/realtekrtl81xx-osx-driver.html
You want to download, "RealtekRTL81xx-0_0_90.pkg (Google Docs)"
Sound and Ethernet LAN both work.
Thank you very much for all your help - much appreciated. Just as a matter of interest what bootflags are essential for org.chameleon.plist. I have -f kext-dev-mode=1 dart=0 npci=0x3000 darkwake=0. Apart from npci=0x3000 are any of the rest required in particular -f and kext-dev-mode=1

Might I suggest that you post a video of how to install El Capitan with the USB Base System to inform everyone of the critical necessity to replace the kernel and to delete AppleTyMCEDriver.kext from system/library/extensions. I was not aware that you had to do this for the Installation. I don't recall having to do this for either Mavericks or Yosemite.

 Advertising

User avatar
by: Shaneee
#363
Upload your org.chameleon.boot.plist file and I'll edit in what you need. Will also add the option so it just boots straight into OS X. You can still access the boot screen if necessary though :thumbup:

Thanks for the suggestion. I will make a video when I get a chance. Replacing the kernel is a must for all installs on AMD just depends on how you install and where the kernel is located.
User avatar
by: redband123
#364
Shaneee wrote:Upload your org.chameleon.boot.plist file and I'll edit in what you need. Will also add the option so it just boots straight into OS X. You can still access the boot screen if necessary though :thumbup:

Thanks for the suggestion. I will make a video when I get a chance. Replacing the kernel is a must for all installs on AMD just depends on how you install and where the kernel is located.
Here is the org.chameleon.plist;
Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>CsrActiveConfig</key>
	<string>103</string>
        <key>EthernetBuiltIn</key>
	<string>Yes</string>        
        <key>GraphicsEnabler</key>
        <string>Yes</string>
        <key>USBBusFix</key>
        <string>Yes</string>
        <key>Timeout</key>
	<string>2</string>
	<key>Kernel Flags</key>
	<string>-f dart=0 npci=0x3000 darkwake=0</string>
</dict>
</plist>
Not much in it really for you to edit. However it would be nice if I could cut down the start-up time - it takes over 55 seconds to boot-up. I suppose I could boot with the -v flag and see what takes the most time to load. Nevertheless everything seems to work and so far have not experienced any programme or app crashes which others have experienced.
Once again thank you for your kind help.
User avatar
by: Shaneee
#368
No there isn't much to edit. Unless you can install to an SSD there isn't really much to speed it up I'm afraid.
Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Quiet Boot</key>
    <string>Yes</string>
   <key>CsrActiveConfig</key>
   <string>103</string>
   <key>EthernetBuiltIn</key>
   <string>Yes</string>        
   <key>GraphicsEnabler</key>
   <string>Yes</string>
   <key>USBBusFix</key>
   <string>Yes</string>
   <key>Kernel Flags</key>
   <string>npci=0x3000</string>
</dict>
</plist>
User avatar
by: NicoM4491
#4187
Same for me! i successfully installed Yosemite Zone without any problems on my AMD PC it runs sweet, but well like everyone else i want El Capitan! Have you solved the problem? have the exactly same problem, made the bootable stick in many diferent forms, and the error is still appearing, here are my specs:

motherboard: MSI 890GXM-G65
proccessor: AMD FX 6100
memory modules: 2x4GB kingston Hyper X 1866mhz (8GB TOTAL)
Graphics Card: Nvidia Geforce 8600GT

yosemite is running well with clover bootloader and some flags.
I build a lot of Hacks more Intel's than AMD, and never have this error...
if you solved this issue please tell me how you do!
:wtf:
User avatar
by: Valkiry
#4188
Could you make a new thread please so it will be easier to assist you and be detailed about what your issue is as much as possible :) Thanks
User avatar
by: NicoM4491
#4190
Shaneee wrote:
redband123 wrote:
Shaneee wrote:That error exists on all AMD El Capitan installs. Try this kernel instead,

kernel.zip
Well I tried the suggested kernel but got panic.

So it seems I am unable to install El Capitan
Thanks for your assistance
What was the panic? Don't give up your system should work fine with a bit of fine tuning.

Same for me! i successfully installed Yosemite Zone without any problems on my AMD PC it runs sweet, but well like everyone else i want El Capitan! Have you solved the problem? have the exactly same problem, made the bootable stick in many diferent forms, and the error is still appearing, here are my specs:

motherboard: MSI 890GXM-G65
proccessor: AMD FX 6100
memory modules: 2x4GB kingston Hyper X 1866mhz (8GB TOTAL)
Graphics Card: Nvidia Geforce 8600GT

yosemite is running well with clover bootloader and some flags.
I build a lot of Hacks more Intel's than AMD, and never have this error...
if you solved this issue please tell me how you do!
:wtf:
User avatar
by: Valkiry
#4191
Make a new thread dude, this is an old one. Dont reply or quote this. Better to start off fresh thread.
User avatar
by: Shaneee
#4202
NicoM4491 wrote:
Shaneee wrote:
redband123 wrote:
Well I tried the suggested kernel but got panic.

So it seems I am unable to install El Capitan
Thanks for your assistance
What was the panic? Don't give up your system should work fine with a bit of fine tuning.

Same for me! i successfully installed Yosemite Zone without any problems on my AMD PC it runs sweet, but well like everyone else i want El Capitan! Have you solved the problem? have the exactly same problem, made the bootable stick in many diferent forms, and the error is still appearing, here are my specs:

motherboard: MSI 890GXM-G65
proccessor: AMD FX 6100
memory modules: 2x4GB kingston Hyper X 1866mhz (8GB TOTAL)
Graphics Card: Nvidia Geforce 8600GT

yosemite is running well with clover bootloader and some flags.
I build a lot of Hacks more Intel's than AMD, and never have this error...
if you solved this issue please tell me how you do!
:wtf:
Make your own post please so I can best support you.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]