Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: Gemajlia
#220
Hi,
I dont know how long the support times are but I'll wait.

I currently have an amd system with the following specs:
CPU - AMD FX8320 Overclocked at 4.0GHz
MOBO - Asus M5A97 R2.0
GPU - MSI AMD Radeon R9 280 (According to Enoch, its a "Futomaki" or 7950)
HDD's = 1TB WD Caviar Blue 7200RPM
360GB Seagate 7200rpm

I have a small issue, I know that it wont take that long to fix. I was following a guide on reddit to install Yosemite because El Capitan was a little more unstable for AMD's, It told me to find the Yosemite 10.10.5 dmg and I did so and with the Pandora's Box thing. I added the correct kernel for the 10.10.5 ... I then let it do its thing and restarted the computer choosing the USB as the default boot. It got me into the Enoch Bootloader and I did the standard bootflags for my PC "npci=0x3000 -v" pretty much it. It goes through verbose up to the normal point to when you see the choose your language screen. Instead of going there, it just goes to a black screen. It does not restart. Just a stale black screen. I am guessing this has something to do with my graphics. I currently have Mavericks dual booted with windows 10 on my 1tb hard drive. Been wanting to install yosemite then delete mavericks on my 1tb and enlarge my windows partition. I saw the Yosemite zone thing but didnt want to do it. Would I have to do it? I would rather clean install a legit copy of Yosemite. I'll be here. I just need help with the black screen during the installation thats pretty much it. Thanks

 Advertising

User avatar
by: Shaneee
#221
From what I've read Clover EFI is the best solution to get it working but I'm not familiar with Clover. Since your using Enoch we will try to get it working :)

Now I'm assuming your Graphics are working in Mavericks? What steps did you take to get it working? Have you tried GraphicsEnabler=Yes ?
User avatar
by: Gemajlia
#222
I tried the GraphicsEnabler and all that on the Yosemite install but i guess it just wants to screw me over. My graphics are fully working in mavericks, all I had to do was modify the amd7000 kext with the 7950 id (679a1002). However, I decided to go with your El Capitan tutorial because it actually got me into the installer menu but it took a huge pain in the ass to get.

Feel free to change this to the El Capitan section as I gave up on Yosemite.

I did all the steps you did in the video with the correct Yosemite kernel for my AMD FX 8320. There was a huge error with USB busses restarting, stopping, and some other problem. There will be a video under this showing the issue I had then.
I then went to insanelymac and downloaded some sort of USB fix that contained kexts like AppleHIDMouse and IOUSBFamily etc. I replaced them into the S/L/E of the installer USB and then added them to the Extra/Extensions folder. Then Tah-dah the thing booted up to the installer. I had full keyboard support but the darn mouse didn't work. Didn't know why, the mouse was lit up and I could change the dpi toggle on the mouse, So I had already partitioned one of my hard drives for ElCapitan with Mavericks (GUID Mac OS X Journaled). So all i did with the keyboard was tab and enter all the way till it installed. That went successful. I restarted, and loaded up Enoch from the USB installer and ran the El capitan drive (There was a Recovery HD in there. Never seen it in my life.) Then with some boot flags like the npci=0x3000, -f and -v, it got me into verbose and did the USB issue again. Then with curiosity, I loaded back into Mavericks and opened up Kext Wizard. I installed all the USB fixes again but into the El Capitan HDD. I went back to the Boot loader and ran El Capitan with the same boot args as before. I got a KP but didn't see what it was. Then for the 2nd time, I tried again but got this kernel opcode thing. Heres a video.
Thats pretty much it. Im going to try some more things but I cant seem to fix this error at all. Thanks :)

*UPDATE* I found a kernel u linked one fo the other users here and I used that. I managed to use that but whenever I boot it goes to a grey screen with the loading bar. It goes halfway and then goes through a KP and restarts.
I'm going to retry a clean install again.
User avatar
by: Shaneee
#223
Ok using your Mavericks partition add the kernel you found to the system. Remove files within System/Library/Caches/com.apple.kext.caches/Startup and remove System/Library/PrelinkedKernels/prelinkedkernel

Add your Graphics ID to AMD7000Controller.kext and experiment with AMDRadeonX4000.kext under different framebuffers. Install the kexts back to your El Capitan partiton and boot to El Capitan using -f to force rebuild the caches.

As for your mouse. It's a known issue with the USB fix. Simply unplug it and plug it back in. You may need to use a different port.
User avatar
by: Gemajlia
#224
Thanks man, but there is another problem. I did all that. Deleted the kext caches, rebuilt them. The first time I rebuilt, it restarted after rebuilding the prelinked kernel. Then when I went back and booted in verbose again, It got all the way to where I would see my mouse. I was able to move it around for a good 5 seconds before the whole screen went yellow. I dont know what type of issue this is. My mouse and stuff work, just not getting to the login or welcome screen.
User avatar
by: Shaneee
#225
I thought this issue may arise. There is an issue with El Capitan on FX just now with graphical issues. A fix is currently being investigated. Boot in safe mode ( -x ) to see if the system will boot at all.
User avatar
by: Gemajlia
#226
The -x get me to a grey loading bar. It fills up half way and then just restarts. I cant tell if its a kernel panic. It does mention that some apple kext is missing before shutting down/restarting. Im guessing this is because I havent set up the OS yet. I'll just wait for the FX kernel update. Thanks :)
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]