Welcome to AMD OS X

Why not register now to gain full access.

Tutorials for the installation and post install.
User avatar
by: AlGrey
@creep3r, check form how to report issues. Maybe you are running into a port limit issue. google for it
Post Merged
@Crashmymac, that's not an issue with the usb patch. Looks like an issue with an wifi adapter or the gpu. Start by rebuilding cache.


@AlGrey, I have the same symptoms as @Crashmymac. Used automated method, system no longer boots, forced to reinstall.

I'd be willing to try it again (or do the manual method) if you told me how to extract the relevant logs from a system that won't boot.

I've got a 2200G, RX580 8GB on Mojave. Audio, USB, and iCloud are all broken.
If it doesn't boot after running the script simply boot the installer again and run the post install to replace kernel and rebuild caches again.
Shaneee wrote:If it doesn't boot after running the script simply boot the installer again and run the post install to replace kernel and rebuild caches again.
Could you provide a few more details? I don't know how to do that :thumbup:

edit: specifically "run the post install " and "rebuild caches"
Remember when you installed macOS you had to run the script after installing to make it boot on AMD? Run that again.
@Shaneee, Oh this part?
This will now install macOS from the installed drive. Once finished it'll automatically reboot. When it does boot to the USB installer for the last time and run this command in Terminal,
Code: Select all
cp -r /Volumes/"OS X Base System"/System/Library/PrelinkedKernels/prelinkedkernel /Volumes/macOS/System/Library/PrelinkedKernels/
Code: Select all
cp -r /Volumes/"OS X Base System"/System/Library/PrelinkedKernels/prelinkedkernel.amd /Volumes/macOS/System/Library/PrelinkedKernels/
You can now reboot and boot the macOS drive and be welcomed by macOS Mojave.

There's nothing about cache rebuilding on there, but a quick google showed this
Code: Select all
sudo kextcache -i /
Please confirm if that's all I have to do and I'll get right on it. Thank you!
Ahh you've got Mojave? In that case assuming your HDD/SSD is named macOS use this,
Code: Select all
sudo kextcache -i /Volumes/macOS && sudo kextcache -u /Volumes/macOS
Hmmmmm. This time I ran the script and it didn't seem to do anything (MacOS booted just fine, USB hub still doesn't work). Rebuilt kextcache just in case, rebooted, still nothing. Ran the script again, it deleted the "changes", rebooted, back to square one. Oh well. It's not necessary for me, so I'll just wait until someone with a similar build to mine fixes their issues and I'll copy what they did.

FWIW, I ran the script again one last time to make sure I did it right and left it as is.
Guys, if someone had such problem - help! I installed High Sierra 10.13.3. There is one strange thing. USB ports work but chaotic?? Now I'll try to explain. Ports started to work without any problems. Support 3.0 speed. When I connected usb flash drive then all ports worked. When I connected usb hard drive some ports didn't work. In the window Apple > About this Mac > System information > USB - there is empty always. Motherboard MSI X399 SLI PLUS. It has many USB ports - 2.0, 3.0, 3.1. Any suggestions?
User avatar
by: AlGrey
@synoversky, use the report form
  • 1
  • 7
  • 8
  • 9
  • 10
  • 11
  • 13
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]