Welcome to AMD OS X

Why not register now to gain full access.

Tutorials for the installation and post install.
I have prime plus b350, same audio. for me also error no audio cdec. can you please post hdaenabler.kext and where or how to inject it? thank you
edit: attached report
(3.79 MiB) Downloaded 28 times


User avatar
by: AlGrey
@mikiveliki, remove FixHDA from config.plist and rebuild cache
Post Merged
boot in usb installer and open terminal
touch /Volumes/diskname/System/Library/Extensions

replace diskname with your partition name
Then :
kextcache -U /Volumes/diskname

And :

By the way great guide every step is explained precisely :clap:

  • What I did based on my specs
    • Applied all the DSDT Patches on clover
      • AZAL to HDEF
      • D01A to HDEF
      • D018 to HDEF
    • Added these on KextstoPatch on clover
      • add 1022 vendor id
      • hardcoding 1022 1457
    • Run the AMD_audio_cloverALC-130.sh script from the terminal then Reboot
  • Audio Device Status
    • Headphones(green front) - working
    • Microphone(pink front) - not working
    • Internal Speakers(green rear) - working (auto-hide like on a real mac when you plug an external output device)
    • Internal Microphone(pink rear) - not working (but you can select it as input device)
    • USB Headphones/Microphones - working (must be inserted on usb 3.0 port)
    • Bluetooth Headphones/Microphones - not tested yet (since i don't have a bluetooth dongle to test it with but probably it will if the native usb patch is applied)
Thanks, hope you can make a patch for the internal microphone soon :thumbup:
thank you for you,try
Hi, my system no longer boots after running the script. It's stuck on autofs failed to load. I've tried running the amd post-install script however that seems to have not helped. Any suggestions? Thank you in advance.
User avatar
by: AlGrey

boot in usb installer and open terminal:
Code: Select all
touch /Volumes/diskname/System/Library/Extensions
replace diskname with your partition name
Then :
Code: Select all
kextcache -U /Volumes/diskname
And :
Code: Select all
ajitpai101 liked this
User avatar
by: xunil
I have a Gigabyte AB350 Gaming 3 with a Ryzen 1600x. I got the case audio jack working with all 3 Acpi patches and the "add 1022 vendor id" and "harcoding 1022 1457" kext patches, but the audio is absolutely horrific: crackly, popping, glitching. Going to keep trying. Anyone else with this motherboard figure it out?

Edit: Got it working!!!!! disabled D01A to HDEF, so I just have AZAL and D018 enabled, and now everything is working perfectly! Thanks, OP! :D Now all that's left is to figure out how to upgrade to 10.13.6+ so I can actually use XCode and iMovie :crazy:
Hey All! I've been trying to get my OS X Virtual machine running properly over here but haven't had much luck. My build is an Asrock X399 Taichi Ultimate (ALC1220) with a 1950x and gtx 1080, using unRAID 6.6.5 as the host OS. I managed to get an installation working with GPU acceleration and everything without special kernels et cetera, but audio's caused me a ton of trouble. When using VoodooHDA I get really horrible audio quality, hence this thread.

So I tried to follow the guide, but I get an error that seems to suggest there's no audio codec installed? But the audio devices ARE recognized if I simply add voodooHDA.kext and reboot. They just sound so terrible as to be useless. I've tried looking at iOREG myself and couldn't find the @1B entry that would suggest a codec is there, but Toleda's guide that discussed that and pretty much every other led to solutions that seemed specific to intel parts. Wasn't sure how to apply those here. I figure it's also worth mentioning my audio works fine in every other OS, minus occasional issues resetting the controller due to some IOMMU issues mostly resulting from my own laziness.

If following ydeng's original post and using some of the info provided here (viewtopic.php?f=23&t=4642) might help, just point me to the right place and I'll give it a shot. I'm totally out of ideas at this point.

All the files asked for are attached, minus a few things like my serial etc.
(5.27 MiB) Downloaded 29 times
  • 1
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]